• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. As of Oct 19 a new patch has been released. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Tool TerraCustom for 1.3

Pre-K

Terrarian
I'm having trouble getting this to work with TModLoader or is it not currently able to work with TModLoader (the one-off of steam) is it possible to get it to work? I really want to test the large world enabler mod.
 

MBCollector672

Terrarian
I'm having trouble getting this to work with TModLoader or is it not currently able to work with TModLoader (the one-off of steam) is it possible to get it to work? I really want to test the large world enabler mod.
There should be a more recent version on the Github page that works with the steam TModLoader version.
 

Pre-K

Terrarian
Thank you, I will try it.

That's the version I have downloaded actually, I'll try and find out what needs to be done to get it to work.
 

Majorpo's Borpo

Terrarian
Hi, yeah, uuuh, whenever I make a new world, doesn't matter what settings I fiddle with, it gets stuck at this screen
I've waited for like a solid hour here and nothing else happens. The program hasn't crashed or anything it just... stopped generating the world I guess?
I tried what that one guy said a little up in the thread about messing with the height variation and that didn't help either ;-;
1603667319935.png
 

Techdude594

Skeletron Prime
That's happened to me in the past before. Just restart the program and try again, it seems that it can get stuck when it comes to some parts of world gen.
 

Majorpo's Borpo

Terrarian
That's happened to me in the past before. Just restart the program and try again, it seems that it can get stuck when it comes to some parts of world gen.
'Fraid not, I've tried this for the latter half of today on multiple different PCs, have repeatedly uninstalled and reinstalled terraria AND the program at least 5 odd times and it consistently stops loading at that exact, pixel-perfect point each time. I commented here as an absolute last resort because I don't want to believe that generating a world with a corruption biome just ISN'T possible atm :/
 

jopojelly

Retinazer
tModLoader
'Fraid not, I've tried this for the latter half of today on multiple different PCs, have repeatedly uninstalled and reinstalled terraria AND the program at least 5 odd times and it consistently stops loading at that exact, pixel-perfect point each time. I commented here as an absolute last resort because I don't want to believe that generating a world with a corruption biome just ISN'T possible atm :/
I just released 0.8.1, try it, I hope it fixes the issue. There was a typo and all corruption worlds would break.
 

lathemandrel

Terrarian
on one of the older versions (0.5 maybe?) when the temple traps where turned to their highest setting, it would generate a large amount of wired traps (spear traps, etc) but now when it is turned up, it is almost entirely wooden spikes. can that behaviour be somewhat reversed, with the spikes "minimized" so the wired ones can generate in the previous large amounts?
 

Superscram

Terrarian
Cannot get this to run on Mac. I followed the directions in the readme but they are somewhat vague, they say "next to" the Terraria install folder but what exactly does that mean? Do you make a folder inside the terraria app folder in the macOS internal folder where the executable is located or outside it the app folder entirely? I tried both as well as taking Terracustom out of the folder and placing it inside the macOS folder next to the Terraria executable.
No matter where I put the folder or executable it will not launch. I tried opening a terminal and forcing it to open by using chmod but the terminal just tells me "permission denied" I am the only (admin) user on my computer so permission should not be an issue.

This is what terminal gives me when I try to launch it:


/Applications/Terraria\ v1.4.0.5/TerraCustom.Mac.v0.8.1/TerraCustom.app/Contents/MacOS/TerraCustom ; exit;


/Applications/Terraria v1.4.0.5/TerraCustom.Mac.v0.8.1/TerraCustom.app/Contents/MacOS/TerraCustom: line 60: ./TerraCustom.bin.osx: Permission denied


logout


Saving session...


...copying shared history...


...saving history...truncating history files...


...completed.
 

jopojelly

Retinazer
tModLoader
Cannot get this to run on Mac. I followed the directions in the readme but they are somewhat vague, they say "next to" the Terraria install folder but what exactly does that mean? Do you make a folder inside the terraria app folder in the macOS internal folder where the executable is located or outside it the app folder entirely? I tried both as well as taking Terracustom out of the folder and placing it inside the macOS folder next to the Terraria executable.
No matter where I put the folder or executable it will not launch. I tried opening a terminal and forcing it to open by using chmod but the terminal just tells me "permission denied" I am the only (admin) user on my computer so permission should not be an issue.

This is what terminal gives me when I try to launch it:


/Applications/Terraria\ v1.4.0.5/TerraCustom.Mac.v0.8.1/TerraCustom.app/Contents/MacOS/TerraCustom ; exit;


/Applications/Terraria v1.4.0.5/TerraCustom.Mac.v0.8.1/TerraCustom.app/Contents/MacOS/TerraCustom: line 60: ./TerraCustom.bin.osx: Permission denied


logout


Saving session...


...copying shared history...


...saving history...truncating history files...


...completed.
Sounds like you bought Terraria from the GOG store. Look at these instructions, except replace tModLoader with TerraCustom: Can't open Tmodloader (GOG, Mac) · Issue #1183 · tModLoader/tModLoader
 

Flip3n

Terrarian
Hi, I don't wanna sound rude, but when will you release the tool for tmodloader (I am running the 64bit version) for 0.11.8? or will you wait until the tmodloader will be compatible for 1.4.1 terraria? Because, I am getting the .xnb errors on the tmodloader dlc, but not on original terraria. It launches as if it is not on 64bit version, basically saying it ran out of mem. I did try putting some .xnb files from terraria 1.4.1 directory to the tmodloader dlc (to the images subfolder of the contents folder, basically adding any file that comes in the error message) and running terracustom from the tmodloader directory, but I stopped when I think I realized that it might not work due to the 1.4.1 files being run on 1.3.5.3 (I think it should not work by my understandings, correct me if I am wrong). The regular tmodloader did run fine and the terracustom did register that the content/images folder did have new additions, but still did not launch.

Sorry for making you (the author) reply I did read some of the pages of this thread, but I only found that you mentioned it (on 27 June 2020) to be much later, but for him it does not work on both versions but for me it does on vanilla 1.4.1.2 and it acts as a regular non 64bit tmodloader and it doesn't on tmodloader dlc.

Yeah, it wont work until much later, I'm busy with tmodloader

I was just hoping to know how long is that later...

P.S. I did just now realize that the tmodloader dlc did not care if I put the 1.4.1 content/images files to the tmodloader content/images, meaning that it should run on paper but maybe it might have mod conflict due to maybe some mods having reused some of the values of vanilla items.

EDIT: I did merge all 3. I mean I added the tmod dlc files to terraria folder, then terracustom dedicated folder in the side. That does run but it has errors when loading mods and says to disable them. So I am genuenly clueless how it works.
 

jopojelly

Retinazer
tModLoader
Hi, I don't wanna sound rude, but when will you release the tool for tmodloader (I am running the 64bit version) for 0.11.8? or will you wait until the tmodloader will be compatible for 1.4.1 terraria? Because, I am getting the .xnb errors on the tmodloader dlc, but not on original terraria. It launches as if it is not on 64bit version, basically saying it ran out of mem. I did try putting some .xnb files from terraria 1.4.1 directory to the tmodloader dlc (to the images subfolder of the contents folder, basically adding any file that comes in the error message) and running terracustom from the tmodloader directory, but I stopped when I think I realized that it might not work due to the 1.4.1 files being run on 1.3.5.3 (I think it should not work by my understandings, correct me if I am wrong). The regular tmodloader did run fine and the terracustom did register that the content/images folder did have new additions, but still did not launch.

Sorry for making you (the author) reply I did read some of the pages of this thread, but I only found that you mentioned it (on 27 June 2020) to be much later, but for him it does not work on both versions but for me it does on vanilla 1.4.1.2 and it acts as a regular non 64bit tmodloader and it doesn't on tmodloader dlc.



I was just hoping to know how long is that later...

P.S. I did just now realize that the tmodloader dlc did not care if I put the 1.4.1 content/images files to the tmodloader content/images, meaning that it should run on paper but maybe it might have mod conflict due to maybe some mods having reused some of the values of vanilla items.

EDIT: I did merge all 3. I mean I added the tmod dlc files to terraria folder, then terracustom dedicated folder in the side. That does run but it has errors when loading mods and says to disable them. So I am genuenly clueless how it works.
You shouldn't be merging folders, or moving files at all (aside from the install steps, which say to make a new folder), so I'm a bit confused what you are doing. It seems like this will be a lot easier to resolve via chat, come to the #terracustom channel on the my discord and I can walk you through your issues.
 

Superscram

Terrarian
You don't need tmod installed. Maybe the new 0.8.1.1 will help, it includes some fixes for mac file paths: Releases · JavidPack/TerraCustom
It tries to launch, but immediately fails. It seems it still can't find the file path. this is the error I get:

Terraria: Error (tModLoader v0.11.8.1)

Terraria Content folder not found. Make sure to install TerraCustom in a folder next to the Terraria install directory as described in the ReadMe.txt.

I've tried putting the Terracustom folder in the Applications folder next to the terraria folder as instructed and nothing
Tried putting it inside the Terraria folder next to the app
Tried putting it inside the MACOS folder inside the terraria app

I also tried taking the Terracustom app out of the folder and putting it in all the same locations, still gets the same error.
In order to even see the above error I have to open the Terracustom app and launch the unix executable from the terminal, otherwise the icon just bounces then stops and get nothing.

My next step I think is to take everything out of the Terracustom/macos and drop it into the same Terraria folder and overwrite all the duplicate files.
 
Top Bottom