• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Terraria 1.3.4 for Xbox One and PlayStation 4 Available Now!

Spazmatism7

The Destroyer
I have had a bug where A. Multiplayer makes little to no Sound FX and B. Almost permanent sandstorms! I am getting upset about this problem.
I am having almost constant sandstorms as well. This is not a glitch. Sandstorms act like other storms, they can happen at any time so there is a chance it can be almost constant.
 

Trencher

Terrarian
This isn't limited to multiplayer.
Personally haven't had the issue in single player, even when it was happening it was only for the person joining not hosting. I have only had time to try it out once in multiplayer since the update but it seemed to be taken care of for me.
 
I cant hear the audio when im playing splitscreen. The audio only seems to cut out on the main character’s screen, and the audio only cuts out when the 2 players are far apart like 100 blocks apart. Please fix this
 

ED209

Plantera
Personally haven't had the issue in single player, even when it was happening it was only for the person joining not hosting. I have only had time to try it out once in multiplayer since the update but it seemed to be taken care of for me.
There are certain patches of the map where it just won't operate; whether I'm placing or cutting, the line doesn't show up and nothing happens. It still makes the noise though.
 

r4v1n6

Official Terrarian
There are certain patches of the map where it just won't operate; whether I'm placing or cutting, the line doesn't show up and nothing happens. It still makes the noise though.
It's not the sloped tile bug you are encountering?
 

ED209

Plantera
It's not the sloped tile bug you are encountering?
Nope; patches of empty space, solid blocks and everything in between. If I start on a tile where it does work, and then drag it over a spot where it doesn't, the whole line won't place. These "blank spots" are dotted around at all latitudes and longitudes.
 
Last edited:

r4v1n6

Official Terrarian
Nope; patches of empty space, solid blocks and everything in between. If I start on a tile where it does work, and then drag it over a spot where it doesn't, the whole line won't place. These "blank spots" are dotted around at all latitudes and longitudes.
If you try to mine such a spot with a pickaxe, does it emit the sound of a target dummy being hit?

The reason I ask is on pc there was a bug involving target dummies, where it's ghost sometimes became detached and would block all building in that spot.
 

Loki

Consigliere
Staff member
Re-Logic
Administrator
@Loki do you know what we're getting first: 1.3.5 or all of the bugs being fixed?
Well, "all of the bugs being fixed" is a tall order. I think what is more likely is seeing some 1.3.4-specific issues being addressed... and then its a fair question in regards to 1.3.5 vs "the bug list over time" and how those work together/in sequence.

Not sure that has been decided yet....
 

Adil Abdul

Terrarian
Framerate is still choppy on Xbox One and still becomes unplayable when you get to the underworld. There's literally been no change since the launch of 1.3 on console. Is the perfomance issues ever going to get fixed?

I dont see anyone else talking about this.. is it just me? I went and bought another xbox just in case there was something wrong with my console, but on a brand spanking new xbox I still have the same issues.

Heck, my old AF Core 2 Duo with an aged GTS 450 runs the game better.

Sorry if this comes across as a butthurt rant, but isn't there a way to roll back to a version before 1.3? I just want to play the game sitting on my couch again.

EDIT: Looking at it now again, I've noticed something. It's not quite accurate to say it's a low framerate. Looking at it now, it actually looks more like the game is skipping frames. Like a console emulator running on a crappy PC.
Same for PS4 plus I’ve been having a problem with crimson/corruption world generation I created 23 worlds all crimson Idk why it’s either extremely bad luck or it’s a bug
 

ED209

Plantera
Well, "all of the bugs being fixed" is a tall order. I think what is more likely is seeing some 1.3.4-specific issues being addressed... and then its a fair question in regards to 1.3.5 vs "the bug list over time" and how those work together/in sequence.

Not sure that has been decided yet....
I agree that one big fix would be almost impossible; there are tonnes of issues to go through. Is it feasible to go through the ones that affect gameplay as opposed to visual ones? Or will they be chosen a different way?
 

Loki

Consigliere
Staff member
Re-Logic
Administrator
I agree that one big fix would be almost impossible; there are tonnes of issues to go through. Is it feasible to go through the ones that affect gameplay as opposed to visual ones? Or will they be chosen a different way?
Generally, triage goes down two lines"
- How impactful is it?
- How easy/fast is it to fix?

If its easy and fast, may as well fix it even if just graphic wonkiness that doesn't impact gameplay.
If its very impactful and hard... then its clearly a focus - but oftentimes stuff like that requires more time... and then the fixes create more bugs, and then you have to chase those, etc.

Obviously less impactful, hard items are down the list.
 

ED209

Plantera
Generally, triage goes down two lines"
- How impactful is it?
- How easy/fast is it to fix?

If its easy and fast, may as well fix it even if just graphic wonkiness that doesn't impact gameplay.
If its very impactful and hard... then its clearly a focus - but oftentimes stuff like that requires more time... and then the fixes create more bugs, and then you have to chase those, etc.

Obviously less impactful, hard items are down the list.
That makes sense, but what about oversights? Things like the Grand Design UI, which takes you out of the UI every time you click on it? If the selection button was changed from R2 to "X" (such as the Cell Phone functions are toggle with "X" for example) then it would be a lot more useful. At the moment I still carry all four spanners and a the clippers.
 

Loki

Consigliere
Staff member
Re-Logic
Administrator
That makes sense, but what about oversights? Things like the Grand Design UI, which takes you out of the UI every time you click on it? If the selection button was changed from R2 to "X" (such as the Cell Phone functions are toggle with "X" for example) then it would be a lot more useful. At the moment I still carry all four spanners and a the clippers.
Stuff like that gets reviewed as well - under the "feedback" angle (not a bug PER SE, but not ideal functionality).

As for the status of that particular one, I'll do some poking around on my kit and ask around.
 

ED209

Plantera
Stuff like that gets reviewed as well - under the "feedback" angle (not a bug PER SE, but not ideal functionality).

As for the status of that particular one, I'll do some poking around on my kit and ask around.
Thanks. I'd also be interested to know if the cursor re-positioning issue was a choice or a bug,...
 

ED209

Plantera
Stuff like that gets reviewed as well - under the "feedback" angle (not a bug PER SE, but not ideal functionality).
Thanks. I'd also be interested to know if the cursor re-positioning issue was a choice or a bug,...
I've done some experiments with the cursor issue and it seems to be a bug, as the new OOA sentries aren't doing it. Basically, anything that consumes items from the character's inventory (such as placing blacks, guns, hive wand) is working fine, but with things that "conjure" things (suck as summon weapons, ice rod, RoD, starwrath, lunar flare), the cursor doesn't snap back to the player, but stays where it was on the screen. This is in both cursor modes; when it's a circle or a cross (which one is smart cursor by the way?).

This can be infuriating when having walked somewhere while holding one of these items, going to interact with the switch/chest etc. you are standing in front of, only to interact with the one further away from you because your cursor is still ahead of you in the direction you were walking in.
 

Loki

Consigliere
Staff member
Re-Logic
Administrator
I've done some experiments with the cursor issue and it seems to be a bug, as the new OOA sentries aren't doing it. Basically, anything that consumes items from the character's inventory (such as placing blacks, guns, hive wand) is working fine, but with things that "conjure" things (suck as summon weapons, ice rod, RoD, starwrath, lunar flare), the cursor doesn't snap back to the player, but stays where it was on the screen. This is in both cursor modes; when it's a circle or a cross (which one is smart cursor by the way?).

This can be infuriating when having walked somewhere while holding one of these items, going to interact with the switch/chest etc. you are standing in front of, only to interact with the one further away from you because your cursor is still ahead of you in the direction you were walking in.
I'm going to try and get some video of this on my kit so that I can show PW - just gotta find time, its a very chaotic time of the year. :(
 
Top Bottom