• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

PC Terraria Broke, nothing I do works

FraGGNum

Terrarian
Over the past couple weeks, I've tried a long string of different ideas and methods (and even attempted to get community assistance through the discord) that ended in my game simply becoming even more irreversibly broken. I've done everything from erasing all presence of terraria's files on my computer, to a steam uninstall, repeated file verification, even going as far as to attempt to create the files for the game itself.

The game, for whatever reason, cannot read or create the files pertaining to the writable data (characters, research packs, worlds) that gets stored by default in your computer's documents folder: and not having fired up the game between the release of journeys end and a previous update makes it impossible to play the game ever again. I have no idea why exactly this is the case, but it's made it literally impossible to play the game on PC anymore.

As I said before, it cannot read or write to these files. Initially, I tried creating a character and it kept failing. I tried to verify the game files, but that doesn't seem to actually fix them. I noticed that steam was referencing both my old modded 1.3 and 1.4, so I deleted all of my old 1.3 and Tmodloader stuff, and reinstalled the game - nothing. It seemed like there was an issue with the files in documents, so I deleted them and reinstalled the game a second time; it couldn't create the files. So, I tried AGAIN in administrator mode- no luck. Eventually, I went and manually deleted literally every file referencing terraria on my computer, and reinstalled a THIRD time. Again, broke. Regardless of what I do, I always get some kind of "cannot create x Files" with just a string of directory stuff that just references the file location. I literally do not understand what is going on anymore. Coming to the forums today to create an account and post this, there are several other reports stating that the steam version cannot properly start up for the first time. This is a widespread issue and needs correction; I just want to play this amazing game again. :( If there is any way to fix this, PLEASE tell me. I will go as far as rewriting parts of the game files if need be.
 

Mail

Official Terrarian
The steam version of Terraria supports Ubuntu. You could install Ubuntu on a flash drive or make a smaller hard drive partition to install it.

If you play it off of a clean OS install you won't have to worry about fixing whatever software problems you currently have.

I am assuming you don't want to reinstall Windows, but you should consider it if this isn't the only software problem you have with your computer.
 
Top Bottom