• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Terraria Steam Found Server Freeze

Tazer

Terrarian
Hey Guys,
Since I updated to 1.3 and I try to create a server or join via Steam it freezes at Found Server.
I already tried disabling my firewall, reinstalled Terraria and restarted my PC.
It still doesn't work.
Does anyone know how to fix this?
 

Kalle

Eye of Cthulhu
Please do these steps:
General problems - Multiplayer problems + Game crashes on startup?
1. Turn the firewall off.
2. Try running the game in compatability mode. Go to "*Drive*:\Steam\steamapps\common\Terraria" right click choose properties. Then open the compatibility tab and change the settings.
3. Start the game.

.NET Framework Problems - Game crashes while playing/starting a server?

*Always make sure your game is not running, while you are doing this*
1. Close the game, deinstall XNA Framework Redistributable 4.0 and restart the game. If that won't work do step 2.
2. Go to "*Drive*:\Steam\steamapps\common\Terraria"
3. There are a few setups.
4. Run xnafx40_redist.
5. Run a dotNET Setup (depending whether you got 32- or 64-bit)
6. If that won't work do the next step.
7. Download the latest .NET Framework (4.5.2)
8. If that won't work reinstall Terraria.

How do I reinstall Terraria?
1. Deinstall Terraria on Steam, close Steam.
2. Go to "*Drive*:\Steam\steamapps\common" and delete the Terraria folder, if there is one.
3. Search with the explorer for remaining Terraria files, delete them.
4. Delete any files, which are interlinked with older Terraria versions, those might cause problems.
5. That includes deleting the files in "C:\Users\home\Documents\My Games\Terraria"
4. Restart your PC
5. Reinstall Terraria on Steam.
 

Weiss

Terrarian
If the troubleshooting posted above doesn't solve it try checking that the port 7777 its not being used by another process.
You can check this by executing Resource Monitor:
Start>>All Programs>>Accessories>>System Tools>>Resource Monitor
On the network tab, tcp connections or listening ports submenu.
A friend had the same problem and the culprit was HD-Network.exe, a process of Bluestacks Android emulator.
 
Top Bottom