• Labor of Love is here! Visit our Labor of Love thread for a special message from the team, a look at brand new Labor of Love merch, and the changelog (minus a few surprises 😉)

Resolved Terraria Will Not Launch - Windows Steam Error

squibby171

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 10
Terraria Version
1.4.3.6
Controls Used
Keyboard/Mouse
Hello,

I've been searching for a solution to my Terraria launch error and I've seen other people mentioning it but so far none of the solutions have worked. From Steam I launch the game and it simply fails to launch.

Here are the specs on my computer:

Asus ROG Zephyrus GA503Q
Edition Windows 10 Home
Version 21H2
Installed on ‎7/‎15/‎2022
OS build 19044.2006
Experience Windows Feature Experience Pack 120.2212.4180.0

Processor AMD Ryzen 9 5900HS with Radeon Graphics 3.30 GHz
Installed RAM 16.0 GB (15.4 GB usable)
System type 64-bit operating system, x64-based processor

Looking at the system event logs I see the following two error entries related to the Terraria applicaiton launch:
Faulting application name: Terraria.exe, version: 1.4.3.6, time stamp: 0x622fb422
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00000000
Faulting process id: 0x2f30
Faulting application start time: 0x01d8ce21b112352b
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Terraria\Terraria.exe
Faulting module path: unknown
Report Id: 0c636ac0-2c65-438a-b449-0f87bcc13623
Faulting package full name:
Faulting package-relative application ID:

Application: Terraria.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.AccessViolationException
at System.Windows.Forms.SafeNativeMethods.GetWindowTextLength(System.Runtime.InteropServices.HandleRef)
at System.Windows.Forms.Control.get_WindowText()
at System.Windows.Forms.Form.get_WindowText()
at System.Windows.Forms.Control.set_WindowText(System.String)
at System.Windows.Forms.Form.set_WindowText(System.String)
at System.Windows.Forms.Control.set_Text(System.String)
at System.Windows.Forms.Form.set_Text(System.String)
at Microsoft.Xna.Framework.WindowsGameWindow.SetTitle(System.String)
at Microsoft.Xna.Framework.GameWindow.set_Title(System.String)
at ReLogic.OS.Windows.WindowService.SetUnicodeTitle(Microsoft.Xna.Framework.GameWindow, System.String)
at Terraria.Main.SetTitle()
at Terraria.Main.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean)
at Terraria.Program.LaunchGame(System.String[], Boolean)
at Terraria.WindowsLaunch.Main(System.String[])

Things I have tried:
  • Re-installing Terraria completely
  • Validating the integrity of the files through Steam
  • Re-installing the .Net framework (attempted but do not think I succeed. Every time I try it says I can't install it because it is already installed. I tried the .net repair tool and that didn't help.)
  • Installing XNA 4.0
  • Installing/Reinstalling DirectX
  • Running application as Admin and in compatibility mode
It is the first time I have tried running Terraria on this computer and any suggestions or thoughts on what might be causing this and a solution would be greatly appreciated.
 

squibby171

Terrarian
Where is that file normally stored? The only place I can find it is my NVIDIA driver folder which doesn't seem like the right thing to delete (but maybe it is).
 

WolfieTheFurry

Steampunker
This file is usually found within "My Documents" under "Games" then look for the folder labeled "Terraria". If it's not there... sorry I failed ya! I've been having this issue a ton the past year and found this works 99% of the time!
 

Loki

Consigliere
Staff member
Re-Logic
Administrator
Things to try if you have not already:

- Are you running Steam as Admin (rt click on steam shortcut, pick run as admin)? - sounds like you tried this already
- Are any AV programs (even WinDef) blocking access to My Documents?

I've run into both in the past (not just for Terraria, for any game that uses My Documents > My Games for saves and config files) when running Steam.

Valve has an entire help article on this (Steam Support :: Games do not run after 'Preparing to Launch')... but would like to rule out any Terraria-specific issues in case there is some aspect of this solveable on our end. Again, sounds like you tried a lot of these.
 

squibby171

Terrarian
Thank you everyone for the suggestions. From all of the above I was able to find a solution. The config.json file did not exist as indicated which likely fits into the second comment from Loki about program access to files. The Terraria directory did not exist in the My Games folder. By giving it a blank config.json file it was able to launch successfully and I was able to configure the settings as needed.
 
Top Bottom