• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Terraria won't launch, no error message

Cdoggle

Official Terrarian
I found my fix by reinstalling a hidden dll file outside terraria. It was HELL to do.

What I think caused the dll to corrupt was the mod browser in game. I could be wrong, so I mod at my own risk, as my siggy says.

When installing mods, try installing it manually.
 

SweggyCrump

Terrarian
I think you should probably create a new thread for this.
I just want to say that I know this is almost a year after this page wass made but this linked helped, as soon as i downloaded it my Terraria started to work. Thank you so much
[doublepost=1501040802,1501040760][/doublepost]
I fount a fix! i had this problem for about a year or so and i even wrote with re-logic's support people... all i had to do was download microsoft silverlight
and framework Xna u can find it here: https://www.microsoft.com/en-us/download/confirmation.aspx?id=20914
Sorry this was the right link
 

Lucas the PSI Legend

Official Terrarian
I found my fix by reinstalling a hidden dll file outside terraria. It was HELL to do.

What I think caused the dll to corrupt was the mod browser in game. I could be wrong, so I mod at my own risk, as my siggy says.

When installing mods, try installing it manually.
What was it?
 

Lucas the PSI Legend

Official Terrarian
I found my fix by reinstalling a hidden dll file outside terraria. It was HELL to do.

What I think caused the dll to corrupt was the mod browser in game. I could be wrong, so I mod at my own risk, as my siggy says.

When installing mods, try installing it manually.
What's the name of the dll?
 
I have the same Exact problem but Im on a Mac... Anyone know how to fix this? All I did was download TModLoader and put in my Terraria files... Then I tried removing them.... still won't load......
 
Terraria works now... All I had to do was backup my Terraria Data... and uninstall Terraria. Works for me... might work for Mac users. Hope it helps. :)

Edit: After you uninstall... Re-Install and load. Your data should sync back into the game... It worked for me... I hope it works for you. If it doesn't, then I don't know... :\
 

ʙʟɪɴᴅ

Terrarian
alright so it all started when i tried playing with my friend on terraria; i realized that when I tried to make a new character or world, my game would crash, so I tried fixing it. i guess i ended up breaking it because my game started to just stop loading entirely, and now i'm just really confused.
 

Grumpy Squid

Duke Fishron
alright so it all started when i tried playing with my friend on terraria; i realized that when I tried to make a new character or world, my game would crash, so I tried fixing it. i guess i ended up breaking it because my game started to just stop loading entirely, and now i'm just really confused.
I believe I know what's wrong, but I want to verify first. Could you screenshot the error message for me?
 

Attac_Mage

Terrarian
I downloaded the installer but it won't install. It says, "Error reading from file C:\Users\---\Desktop\xnafx40_redist.msi. Verify that the file exists and you can access it."
I'm so sorry I can't help you out with this one, hope you figured it out, but it took me a week or so of constant searching before I found out that what happened was it would create a temporary folder deep in a weird spot on any connected drive, you could find the filepath through some convoluted searching, if I remember correctly it was off of a webpage that would open when I ran the installer, with the path in text on the page. After following that you can copy the folder with the redist.msi, paste it somewhere permanent and select the redist when you run the installer again. That's how I solved it, there where no forum posts on the direct order taken to fix it, so I should have written it down. That's just the end of how I fixed it that I remember, though, so I hope it helped you out.
 

Hardzsi

Terrarian
I'm on a Skylake NUC6i5SYH running Win 10 Home x64 (v1903)

After discovering this gem, i bought Terraria recently on GOG, and then was surprised I couldn't launch it
(no error msg whatever; it just didn't start at all).

Digging around articles and threads i found these suggested solutions, without success:
  • Repair/re-install Microsoft.NET Framework: did it
  • Verify that .NET 4.5 (i have 4.8) is enabled: Press Win+R > Type “optionalfeatures.exe”+Enter > enable all .NET 2/3/4 related items: did it
  • Verify cache files: i don't know, where those are located
  • Re-install Terraria: within GOG Galaxy 2.0 beta i did: Manage installation > Verify / Repair
  • Run as administrator: didn't try it, however all my game files are on a separate location as the system; there are no accessibility restrictions
  • Uninstall anti-virus: in Avast you can switch it off for 10 min w/o uninstalling - i did it
  • Deactivating Windows Defender - it might block Terraria's window w/o warning You: i didn't try
  • Running in compatibility mode: in Terraria folder right click on Terraria.exe > Properties > Compatibility tab > compatibility mode: i switched to Win 7 then Win 8

None of the above helped me :(

Then I found a comment of XPixeLLoveRX from Nov.2016 suggesting to download and (re)install Microsoft XNA Framework Redistributable 4.0 (direct download link)

This solved the problem for me (also), and Terraria is finally running! :)

In my case, there's no need to additionally disable the anti-virus or run in compatibility mode or with admin privileges etc.

If you have no luck with XNA (re)install, you may get lucky with one of the above tips/solutions, though.
 
Top Bottom