tModLoader TGM1234's Mods

Discussion in 'Released' started by thegamemaster1234, Aug 31, 2016.

  1. thegamemaster1234

    thegamemaster1234 Skeletron

    That's because of the way knockback accessories affect knockback. The effect is real and remains until the world or character is reloaded. It's annoying, but I don't have a fix available at the moment.

    No clue what's going on here. Might investigate into it, though as I don't have their source code to know how they're summoning bosses and why in the world that would conflict with my code, don't count on it.
     
    Lunatic Lobbyist likes this.
  2. Endere

    Endere Steampunker

    I doubt this has to do with the few mods I've added since I started playing again (since it wouldn't make much sense for them to conflict with two entirely different mods), but this mod no longer works visually with WeaponOut. A week or two ago, the coloration would appear on dyed weapons while you were holding them, but now they appear undyed until you actually use them. A fix would be great, if possible-- it's a little jarring. I think it might have to do with the latest tModLoader updates, but take my words with a grain of salt, I'm not a skilled modder.
    [​IMG] [​IMG]
     
    RunicGlympse likes this.
  3. GeorgeLVZ

    GeorgeLVZ Terrarian

    umm?
     

    Attached Files:

  4. thegamemaster1234

    thegamemaster1234 Skeletron

    How WeaponOut worked with IC in the past is because it did a bit of hacking to apply the shader correctly on the item. With the advent of 2.0 the codebase changed a lot (ShaderLib, so some code was modified in IC as well) so I expected this would happen. As I do not know of any feasible way to provide support from within Item Customizer at the moment, it's up to the author of WeaponOut to restore support. @Flashkirby99 could you maybe look into this? It shouldn't be too different from what you were doing before.


    o_O
    That shouldn't be happening. Make sure one of your other mods isn't causing it - I've heard that can happen sometimes.
     
  5. Endere

    Endere Steampunker

    I understand. Thanks for the in-depth reply! I'll wait for an update, maybe disable WeaponOut's visuals until then because it bugs me so badly, haha.
     
    thegamemaster1234 likes this.
  6. Okuuegg

    Okuuegg Terrarian

    I'm not sure why summoning bosses would conflict with your code either, but somethings up. Seems Fargo doesn't have his code on github from what i can find, but i believe there's a update in the works for the mod so you 'may' not need to do anything? *shrugs*

    I really like your Item Customizer.. and i don't understand why it isn't in vanilla to begin with. Not being able to color weapons/items since dyes were first released has been my biggest complaint all these years, so id like to try and help. Though with my limited knowledge (none) with coding/programing, best i could probably try and do is contact Fargo on his discord and ask if he could maybe contact you? I donno, may be better if you handle that. I'm guessing maybe both mods are sharing the same id's or class names or something.
     
    Kefke and thegamemaster1234 like this.
  7. Proxiehunter

    Proxiehunter Terrarian

    This error message has been an ongoing issue the past few tModloader updates. It comes up from time to time in various threads, it happens to random mods on an unpredictable basis. Whenever it happens to me I enable any disabled mods again and reload my mods and it fixes the problem.
     
    thegamemaster1234 likes this.
  8. Flashkirby99

    Flashkirby99 Skeletron

    Yup, it's on my todo list. I'll contact you when I get around to it :)
     
  9. PhoeniX Darkcraft8 SPQR

    PhoeniX Darkcraft8 SPQR Skeletron Prime

    terraria overhaul bug whit Item Customizer it make the dye weapon dont appear when used it must be a rendering bug because of the way terraria overhaul render item when used
     
  10. Okuuegg

    Okuuegg Terrarian

    Maybe less of a bug, and more that the way Overhaul handles holding weapons doesn't support IC. Overhaul's code isn't 100% opensource yet, but there may be a possibility to have both mods work nicely together, but that would require that IC both cater to vanilla and Overhaul at the same time, or release a separate version of IC specifically for Overhaul. Or if Overhaul catered to IC.

    I currently use both mods, and find myself not wanting to let go of either, no matter the incompatibilities lol. But if TGM thinks it wouldn't be too hard to do:
    https://forums.terraria.org/index.p...ul-gameplay-enhancements-and-much-more.60369/
    There's a section on the mod's thread providing information to help modders workout compatibility issues, giving tags and a means to get the mods dlls.
     
  11. Twichlove999

    Twichlove999 Eye of Cthulhu

    Oh wow, Very glad to see that this mod is still up and running after i took a huge break from Terraria, thinking the multiplayer issue has been fixed?
     
    thegamemaster1234 likes this.
  12. Kefke

    Kefke Steampunker

    So...I had this crazy thought the other day. Is it possible to get the dye shaders to work as paints? As in, putting dyes on blocks and furniture? I know it shouldn't matter for basic colours, but for the mixed and special dyes, there's not really any paint equivalent, with the exception of shadow and negative. I can't make my steaming animated cog walls a Metallic Copper, create a digital display with a "Skiphs's Blood" or Phase effects, create a planetarium with Twilight, nor even use a mixed colour to get more detailed colouration on furniture than just painting different sections a stripe of something else. So it would be really cool if the dyes that didn't have some condition dependant on player state could be turned into paints.
     
  13. 奶子

    奶子 Terrarian

    new update make itemcustmizer can use in multiplayer but it also make my weapon cant shoot sometimes ,plz fix it ,thx
     
  14. esselion

    esselion Terrarian

    Seems like Item Customiser doesn't like to play nice with Magic Storage, although MS is a little outdated (in that it's not made for the most recent tModLoader).

    EDIT for clarification: my boyfriend and I play multiplayer, and his game has crashed twice now when interacting with a storage heart while having Item Customiser active. I tested it out in another world and it didn't occur to me, so I'm not sure?? I did get some text, though.
     
    Last edited: Jun 22, 2018
  15. Quine

    Quine Official Terrarian

    so i've made a rather large dye mod with shader library(Dye Hard), and @Yoma Amaya found that dyes added using shader lib don't apply to accessories added by mods correctly.
    i tested it with calamity's Skyline Wings and secret dyes' Plaid Dye and it defaults to a different shader (Red Dye)
    [​IMG]
    it works on any vanilla accessories just fine though.
    hope this helps some what with fixing this bug.
     
    Last edited: Jun 24, 2018
    thegamemaster1234 likes this.
  16. thegamemaster1234

    thegamemaster1234 Skeletron

    Hmm, that's strange. I remember there being an issue with Wing Slot, but yours is clearly in a vanilla slot.
    I'll have to look into it when I have time.

    Your mod looks really cool; I'm glad that someone else finally created something using my library! Didn't know about the 256th dye error, I may have to look into that too.

    I'm aware that much of what my library does is hacky and is prone to errors (even after 2.0), so reports like these are very helpful.
    If you have to create workarounds like your "dummy dye" to get my library to work right, or if a feature is lacking, or anything else, please don't hesitate to report it! Even better than posting it here, you can post an issue on ShaderLib's Github repo, which will send me an email informing me of whatever you've discovered ;)

    EDIT: If any modded accessories don't work with modded dyes, the only explanation I have is that the accessory in question modifies how it is normally drawn. Testing with anything else has worked just fine.
     
    Last edited: Jun 29, 2018
  17. Quine

    Quine Official Terrarian

    is still get this error with example mod's example wings and example shield and plaid dye from secret dyes
    only other mods that are active are shader lib and cheat sheet.
    i'll be sure to use github for further issues. thank you for the help so far though!
     
  18. X_Doomester_X

    X_Doomester_X Terrarian

    Help, it turn out that this mod is preventing me from using boss "modded" summon. I really like this mod but I don't want to remove this in order to use boss, can you please fix this? It's really annoying and can often test your patience.
     
  19. thegamemaster1234

    thegamemaster1234 Skeletron

    I'm sorry, could you please elaborate? Which mod adds the summon? Which summon is it? Exactly which mod of mine do you have installed that breaks the summoning? Are there any error logs? Are you certain that it's my mods breaking it, and that the boss isn't just broken?

    ShaderLib and related mods do not do anything related to boss summons, so it is likely that the issue is on the other mod's end.
     
  20. X_Doomester_X

    X_Doomester_X Terrarian

    I mean when I use the mod, all the boss modded summon(from other mod, not this) won't even work.