Mobile The save file ***.player was created with a newer version of terraria and could not be loaded.

Discussion in 'Mobile Bug Reports' started by thecougfan, Feb 11, 2015.

  1. thecougfan

    thecougfan Terrarian

    WTF. I have the paid version. I was playing 4 hrs ago and it worked fine. Anyone know what i can do to recover my player?

    [edit 5/31/2016 by staff - picture link was removed - it was still broken and possibly from a malicious source]
     
    Last edited by a moderator: May 31, 2016
    NOF likes this.
  2. DestroyerOfTheDestroyer

    DestroyerOfTheDestroyer The Destroyer

    Apparently the game thinks it's running an earlier version than it actually is, or the character data was corrupted in such a way that it seems like it was created by a later version of the game- either way, the game was coded to refuse to play characters from later versions than the version it is running (stops file corruption from the use of items whose IDs haven't been coded in yet). That's what I think is going on, code-wise. Fixing it, though? I don't know.
     
  3. Drok

    Drok Spazmatism

    What version are you using? Also the picture doesnt work.
     
  4. thecougfan

    thecougfan Terrarian

    I have the Android version 1.2.
    (not sure why the pic doesn't work, its just the error message I described at the choose a character screen)
     
  5. Drok

    Drok Spazmatism

    I meant the version of terraria.
     
  6. DestroyerOfTheDestroyer

    DestroyerOfTheDestroyer The Destroyer

    He means 1.2.
     
  7. Obsi

    Obsi Terrarian

    I had this same problem too! My second world and main character were gone... I had a full set of hallowed, orichalcum and palladium!!! I even had a goddamn extractinator! All my hard work of defeating Plantera 5 times and Golem has went down the drain... I feel suicidal.
     
    andrewisop likes this.
  8. DestroyerOfTheDestroyer

    DestroyerOfTheDestroyer The Destroyer

    @505Games , you have a major, widespread bug on your hands.
     
    NOF likes this.
  9. SuperLucas335

    SuperLucas335 Terrarian

    That happened to me as well!
     

    Attached Files:

  10. Obsi

    Obsi Terrarian

    right I remember. Mine wasnt the player bug it was the world bug.
    But still my main character was corrupted out too.
    [​IMG]
     
  11. dakotah787

    dakotah787 Steampunker

    Same here has happened to three of my players and worlds and ten times do different friends of mine
     
  12. davit orjan

    davit orjan Terrarian

    my character is unable to loaded to T-T because created from newer version
     
  13. k_g1972

    k_g1972 Terrarian

    Me too I'm so pissed I'm flipping out terraira is my life
     
  14. Same thing happened to my game. I had full turtle armour and had beat plantera 6 times.
     
    Icey Peggy likes this.
  15. TerrariaFanSpriter

    TerrariaFanSpriter Spazmatism

    This just happened to me. ALL MY FRICKING HARD WORK. Someone needs to get attention of a Moderator or 505Games themselves. We cant let this happen. ;-;
     
  16. =A0G= Nom Nom Nom

    =A0G= Nom Nom Nom Terrarian

    Does anyone know how to fix this? It just happened to me and i want to play with all my stuff again! $-_-
     
  17. ShroomiteBunny

    ShroomiteBunny Skeletron Prime

    No way to fix it. I sent email to 505Games. And promised to never do that again. They suggested some useless "ways to fix it". Of course none worked. In the last email they said that there is no possible way to get lost data back. So yeah, let's not fix it and let players lose all their hard work `-_-
     
    NOF likes this.
  18. Gmayor61

    Gmayor61 Steampunker

    They have a backup error message for when a file FROM THE FUTURE tries to load?
    I'm starting to think that 505games' primary work isn't exactly related to games
     
    NOF likes this.
  19. ShroomiteBunny

    ShroomiteBunny Skeletron Prime

    Nah, they have an error message when a file FROM ACTUAL VERSION tries to load. That's difference.
     
    Gmayor61 likes this.
  20. Gmayor61

    Gmayor61 Steampunker

    That's what they want you to think.
     
    ShroomiteBunny likes this.