tModLoader The Thorium Mod

BTW, if anyone is interested in the amount of materials that go into upgrading your Inspiration all the way from game start to absolute maximum Inspiration, here's the breakdown (because I'm a nerd like that :merchantgrin: ):

  • 15 Iron/Lead Ore (to make enough bars for the Iron/Lead Anvil that goes into making the Thorium Anvil)
  • 6 Fallen Stars (for the 30 Arcane Dust you need to make the 6 Inspiration Fragments to max out your pre-Hardmode Inspiration)
  • 266 Thorium Ore
    • 10 for the Thorium Anvil in order to make Thorium Bars
    • 96 to make enough Thorium Bars to max out your pre-Hardmode Inspiration (remember, it's 4 Thorium Ore per Thorium Bar)
    • 80 to make enough Thorium Bars to max out your early Hardmode Inspiration
    • 80 to make enough Thorium Bars for the final boost to your Inspiration pool
  • 8 Souls of Light to make the 30 Bright Soul Dust you need to max out your early Hardmode Inspiration (you'll have 2 Bright Soul Dust left over for your other crafting needs, because each Soul of Light makes 4 Bright Soul Dust)
  • 8 Souls of Night to make the 30 Dark Soul Dust you need to max out your early Hardmode Inspiration (and again, you'll have 2 Dark Soul Dust left over due to the Soul of Night => Dark Soul Dust conversion rate being equivalent to that of Souls of Light => Bright Soul Dust)
  • 50 Solar Pebbles for the final boost to your Inspiration pool
Hope this was more enlightening than boring! :merchantgrin:
Help. Sorry if this isn't the proper forum; point me and I'll go. But I'm getting a BAD HEADER LED TO A READ BUFFER OVERFLOW error connecting to a world on the same LAN, different machine. We can connect with no mods enabled, all the other mods we use enabled but with either just Thorium or all mods including Thorium I get this error. I really love this mod and have used it in the past (different computers) to hours of glee and want
so i think i found a bug (if its a bug) but the enchantments dont seem to work for me at the moment when i equip them im stuck in place and im unable to do anything unless i unequip them again
This mod is one of my favourite mods out of the ones I am able to run. However, while playing the mod with one of my friends, we ran into an issue. I don't know where to put this, so I'll just put it here. If it needs to be moved, tell me and I will put it in the correct place.

In the dungeon, there are the new biome chests. I suspected we couldn't open them until killing Plantera. But, for some reason, it gives us the option to right click on it as if to open it. When we do that, the chest interface opens, but the boxes don't show up, and then we're stuck, causing the game to crash.
ever since i updated to this happened to the center of my world
uhm is there a way to fix this?
I am also having the bug where blocks and NPCs are physically loaded but not visible in the vicinity of spawn

Same problem here.
It has something to do with all Thorium Mod Crafting stations and possibly other tiles as well.
All thorium crafting stations placed previously before the update cause this. Changing the lighting settings to 'color' or 'white' makes blocks visible.
All NPCs and projectiles are invisible but are still there as said previously.
All crafting stations/multi-block stations are cut in half, as pictured.

The only way I could fix this was by disabling Thorium, destroying all thorium tiles near spawn. And then enabling Thorium.

EDIT: Mistletoe causes this as well. And Viscount's altar and Aquatic Depths are unaffected.
EDIT 2: All Player Projectiles Modded or Vanilla DO NOT DO ANY DAMAGE . They still appear and their secondary effects (Bard/Radiant) sill happen but but disappear in impact. All Projectile weapons (yes even bard weapons) and yoyos are currently useless.
EDIT 3: Few Bard Souls from Fargo's Souls are broken and can be crafted with nothing.
Last edited:
Okay, so apparently disabling Fargo's souls mod fixes being unable to damage by projectiles.
No clue about the tiles though.
It's a Fargo's Souls Mod issue not Thorium's.
So it looks like the new update broke my entire game.

I tried to update to the new version which crashed my game.

Then I tried to go back to an older version which i installed manually but then it won't show up in the mod list and if I enable it my game just crashes any way to fix this or do I have to do a new clean install.
In my case, re-placing thorium anvil helped with graphic bug on my spawn. I did nothing more. After re-loading my world, bugs don't show up anymore.
Top Bottom