• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader The Thorium Mod

Naga

Terrarian
so i think i found a bug (if its a bug) but the enchantments dont seem to work for me at the moment when i equip them im stuck in place and im unable to do anything unless i unequip them again
 

a3skales

Terrarian
This mod is one of my favourite mods out of the ones I am able to run. However, while playing the mod with one of my friends, we ran into an issue. I don't know where to put this, so I'll just put it here. If it needs to be moved, tell me and I will put it in the correct place.

In the dungeon, there are the new biome chests. I suspected we couldn't open them until killing Plantera. But, for some reason, it gives us the option to right click on it as if to open it. When we do that, the chest interface opens, but the boxes don't show up, and then we're stuck, causing the game to crash.
 

Malteusa

Official Terrarian
ever since i updated to 1.6.1.0 this happened to the center of my world
uhm is there a way to fix this?
I am also having the bug where blocks and NPCs are physically loaded but not visible in the vicinity of spawn
Same problem here.
It has something to do with all Thorium Mod Crafting stations and possibly other tiles as well.
All thorium crafting stations placed previously before the update cause this. Changing the lighting settings to 'color' or 'white' makes blocks visible.
All NPCs and projectiles are invisible but are still there as said previously.
All crafting stations/multi-block stations are cut in half, as pictured.

The only way I could fix this was by disabling Thorium, destroying all thorium tiles near spawn. And then enabling Thorium.

EDIT: Mistletoe causes this as well. And Viscount's altar and Aquatic Depths are unaffected.
EDIT 2: All Player Projectiles Modded or Vanilla DO NOT DO ANY DAMAGE . They still appear and their secondary effects (Bard/Radiant) sill happen but but disappear in impact. All Projectile weapons (yes even bard weapons) and yoyos are currently useless.
EDIT 3: Few Bard Souls from Fargo's Souls are broken and can be crafted with nothing.
 
Last edited:

Malteusa

Official Terrarian
Okay, so apparently disabling Fargo's souls mod fixes being unable to damage by projectiles.
No clue about the tiles though.
It's a Fargo's Souls Mod issue not Thorium's.
 

bastie

Terrarian
So it looks like the new update broke my entire game.

I tried to update to the new version which crashed my game.

Then I tried to go back to an older version which i installed manually but then it won't show up in the mod list and if I enable it my game just crashes any way to fix this or do I have to do a new clean install.
 

Mucha

Terrarian
In my case, re-placing thorium anvil helped with graphic bug on my spawn. I did nothing more. After re-loading my world, bugs don't show up anymore.
 

Angel 4

Terrarian
I actually haven't been able to get into a world after re-enabling Thorium after its update. When I go to make a new world (because Thorium has things that it spawns in the world like in the ocean etc) it just crashes my game. At first I thought it was tied to Calamity somehow, because I saw the same exact error message in a post over there saying it was Calamity. But it didn't make sense, because me and my friend were playing almost perfectly fine (Calamity Music mod caused us some issues for some reason and had to be deactivated) with no crashes at all.

I updated Thorium just a bit ago, after just randomly checking the mod browser and seeing the update button again. To which it only had Thorium to update. I was kinda hopeful, because Thorium is nice to have with Calamity, it allows for diversity and options while not being as overbearing as Calamity is in terms of "difficulty". Sadly, with Thorium enabled, any time I try to load into a world I get this error after a crash to desktop:
1572973672876.png
 

RazorF157

Terrarian
Well, Thorium broke YoYo's. When I have Thorium enabled none of my yoyo's do damage, vanilla and modded alike. Thanks for a great mod! I hope the yoyo issue gets resolved :D
 
Top Bottom