• Labor of Love is here! Visit our Labor of Love thread for a special message from the team, a look at brand new Labor of Love merch, and the changelog (minus a few surprises 😉)

tModLoader 1.4 insane lag June 2022

Lingler

Terrarian
With or without mods the newest (reinstalled) version of tModLoader lags, the game is constantly dropping frames but never freezes. My computer has never lagged on previous versions of tModLoader or base Terraria I've even lowered the graphics settings which I've never had to do before. Neither my CPU nor memory appear to be the problem as they don't even hit 75% on task manager when the games running. Any ideas on what might be wrong or solutions to fix it without downgrading to pre 1.4 tModLoader?
 
Last edited:

Michaelsoftman

Terrarian
By any chance, are you on a laptop or PC which has more than 1 graphics card? TModloader could be using an integrated card rather than your dedicated graphics card in that case.

Does normal Terraria lag with the same settings?
 

Lingler

Terrarian
By any chance, are you on a laptop or PC which has more than 1 graphics card? TModloader could be using an integrated card rather than your dedicated graphics card in that case.

Does normal Terraria lag with the same settings?
I am using two graphics cards and regular terraria has started lagging the same way, I will try to swap them over to the dedicated one
 

Lingler

Terrarian
By any chance, are you on a laptop or PC which has more than 1 graphics card? TModloader could be using an integrated card rather than your dedicated graphics card in that case.

Does normal Terraria lag with the same settings?
That worked thanks so much! should I delete this forum or leave it for someone else who might have the same issue?
 
Top Bottom