• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Wireless

Masae

Skeletron Prime
I'm having a weird bug that only affects multiplayer.

I have some teleporters set up around my world, but upon loading into a world in multiplayer, if I mouse over the red transmitter, my character will get stuck in place with vanity items appearing hidden. The only way to get unstuck is to move the cursor off of the transmitter, and I'm assuming this is because of the fact that it can be interacted with, since the green receivers don't do this.

But here's the part where it gets weird though: this only happens if I haven't been to the teleporter's destination. For example, let's say I've just loaded into my world, and I attempt to use my Jungle teleporter and obviously get the bug described above. But if I actually go to where that Jungle teleporter leads, suddenly the bug will stop happening, and for the rest of the play session I'll be able to use those teleporters without issue. Now at this point if I try to use my Dungeon teleporter, though, I'll still get the bug, but predictably, going to the Dungeon location fixes it.

So it seems, at least to me, like I guess the wireless connections don't fully load until you've actually had both pairs on-screen? I honestly have no idea, but that's at least what it seems like to me. Figured I might as well be as detailed as possible.

My only other notable mods are:
  • Magic Storage
  • Calamity
 

Intrebute

Terrarian
Is there an extra condition before the steampunker sells these items? She's not selling any of them for me. I'm using v1.2
 

gardenapple

Steampunker
will this mod be updated to tModloader 0.9.2.3 and 0.10 ?
I'm updating all of my mods right now.
Is there an extra condition before the steampunker sells these items? She's not selling any of them for me. I'm using v1.2
There is not. Are you using the latest tModLoader for Terraria v1.3.5? If so, then the mod won't work properly until I update it (hopefully today).
I'm having a weird bug that only affects multiplayer.

I have some teleporters set up around my world, but upon loading into a world in multiplayer, if I mouse over the red transmitter, my character will get stuck in place with vanity items appearing hidden. The only way to get unstuck is to move the cursor off of the transmitter, and I'm assuming this is because of the fact that it can be interacted with, since the green receivers don't do this.

But here's the part where it gets weird though: this only happens if I haven't been to the teleporter's destination. For example, let's say I've just loaded into my world, and I attempt to use my Jungle teleporter and obviously get the bug described above. But if I actually go to where that Jungle teleporter leads, suddenly the bug will stop happening, and for the rest of the play session I'll be able to use those teleporters without issue. Now at this point if I try to use my Dungeon teleporter, though, I'll still get the bug, but predictably, going to the Dungeon location fixes it.

So it seems, at least to me, like I guess the wireless connections don't fully load until you've actually had both pairs on-screen? I honestly have no idea, but that's at least what it seems like to me. Figured I might as well be as detailed as possible.

My only other notable mods are:
  • Magic Storage
  • Calamity
I know the nature of this bug - when you connect to a server, you don't receive the whole world at once, you receive it in chunks. So when a receiver is too far away and it's not loaded yet, weird things happen. But I don't know how the code for this works, so I still haven't figured out how to fix this.
 
Last edited:

Masae

Skeletron Prime
I know the nature of this bug - when you connect to a server, you don't receive the whole world at once, you receive it in chunks. So when a receiver is too far away and it's not loaded yet, weird things happen. But I don't know how the code for this works, so I still haven't figure out how to fix this.
Ah, that makes sense. I only know enough about basic coding to make educated guesses, so that was sorta what I was imagining might be the case. It's nice to be able to understand the specific why of the bug, if nothing else.
 

Intrebute

Terrarian
There is not. Are you using the latest tModLoader for Terraria v1.3.5? If so, then the mod won't work properly until I update it (hopefully today).
I haven't updated tModLoader. When I saw the message asking if I wanted to update, it had the disclaimer that the individual mods might not have been updated yet, so I declined.

I've never had the steampunker sell them, even before the tModLoader update came out in the first place.

Here's to hoping that whatever it is, gets fixed when things get updated to the latest tModLoader though \o wo/
 

HORRIOR

Skeletron Prime
Has it been updated yet? I haven't used Wireless before, but I have been hoping to get to use it after tmod 10 came out :/ Still waiting for Thorium to update though.
 

Just Monika

Skeletron Prime
How do i get the transmitters/recievers? Recipe Browser shows only the recipe for the handheld walkie-talkie-looking one for the entire mod, and i can't but from the mechanic. HALP
 

Just Monika

Skeletron Prime
Thank you so much!
Now i have to kill a mechanical boss ;-;
a loot bag gave me a drax so it should be easy now i have so much chlorophyte :)
 

gardenapple

Steampunker
v1.3.1 (and v1.3) are available!
v1.3:
  • Updated to tML v0.10
  • Added Russian translation
v1.3.1:
  • Tried to fix multiplayer issues with long-distance Transmitters (@Maso)
  • Fixed bug where the Wireless Remote didn't show the stored coordinates properly
 

SlippyCheeze

Terrarian
I'm sure it has been said many times, but it would be convenient to have a 2-way wire device, to reduce the number of blocks used from 4 to 2 for a bi-directional link. The one-way versions are definitely usable for this, just not quite as convenient as would be nice, and what is this other than convenience, eh? ;)
 

gardenapple

Steampunker
I'm sure it has been said many times, but it would be convenient to have a 2-way wire device, to reduce the number of blocks used from 4 to 2 for a bi-directional link. The one-way versions are definitely usable for this, just not quite as convenient as would be nice, and what is this other than convenience, eh? ;)
I've been thinking about it for a while, and I think I will add a Transciever.

Originally I wanted to add a bit of a challenge to my mod but now I've realized that setting up a 2-way link isn't really challenging, it's just inconvenient.
 

SlippyCheeze

Terrarian
I've been thinking about it for a while, and I think I will add a Transciever.

Originally I wanted to add a bit of a challenge to my mod but now I've realized that setting up a 2-way link isn't really challenging, it's just inconvenient.
I understand that motivation! Since triggering the receiver doesn't do anything, right now it's just plop the two down, wire them with a single wire to the destination, done, so yeah. I'd agree that it isn't much in terms of actual challenge.
 
Top Bottom