Search results

  1. direwolf420

    tModLoader [WIP] Risk of Slime Rain - Risk of Rain in Terraria

    No, we've been quite busy with real life and other projects, fingers crossed that it will be ported to 1.4 within this year
  2. direwolf420

    tModLoader Mod Request: NPC Always Viable Houses/Rooms CLOSED

    get rid of the leaves walls and replace them with proper walls
  3. direwolf420

    tModLoader Thorium mod keeps saying that it didnt fully install
  4. direwolf420

    tModLoader The Thorium Mod

    You will find a solution here in our FAQ & Known Issues thread!
  5. direwolf420

    Terraria Sound Suite - Customize all ingame sounds (and more)

    My mod is 1.3 only, I haven't bothered porting it to 1.4
  6. direwolf420

    Why does my game crash whenever i hit "Update All" in mod downloads

    restarting steam usually fixes it as it downloads mods via workshop when the game is closed.
  7. direwolf420

    tModLoader Assorted Crazy Things; A Mod Full of Crazy Things

    Such an item exists in half a dozen mods already (in various forms)
  8. direwolf420

    tModLoader Pings - Create "point of interest" markers

    I didn't really want people to start pinging everything without an easy way of removing those pings (if the duration was set too high) since you have to do that by going to that location and ping it again to remove. I guess I can increase it since it's the users problem, not mine
  9. direwolf420

    tModLoader The Thorium Mod

    How to switch back to 1.3 Legacy tModLoader:
  10. direwolf420

    tModLoader When I try to compile my mod in tmodloader, error CS1061 shows up. Read thread for more info. (Original thread was solved, look at my second comment)

    read the migration guide for that, it's on the tml wiki: Update Migration Guide · tModLoader/tModLoader Wiki I would suggest also checking the 1.4 ExampleMod: tModLoader/ExampleMod at 1.4-stable · tModLoader/tModLoader
  11. direwolf420

    tModLoader When I try to compile my mod in tmodloader, error CS1061 shows up. Read thread for more info. (Original thread was solved, look at my second comment)

    You need to install VS 2022 and then open the csproj To install it correctly, read this: Developing with Visual Studio · tModLoader/tModLoader Wiki
  12. direwolf420

    tModLoader Access localplayer mouseworld (multiplayer)

    You would have to write alot of custom netcode for this, I can't really go into detail with this but other mods have done that so it's possible
  13. direwolf420

    tModLoader The Thorium Mod

    please go to our discord (linked in the first post) and elaborate on your issue there (things like logs) EDIT: Will be fixed in next update
  14. direwolf420

    tModLoader Problems with StatModifier in Tmodloader 1.4?

    You need to add public override void ResetEffects() { dartDamage = StatModifier.Default; } to your NewPlayerStats class
  15. direwolf420

    tmodloaders says mods are 52 years old

    linux/mac problem, use the steam workshop to download mods
  16. direwolf420

    tModLoader The Clicker Class

    Post logs please: [1.3] We need log files to help you. You'll find the log files in the logs folder. Look for client.log. (NOT the .zip file, the file named client or client.log) Windows Logs: %UserProfile%\Documents\My Games\Terraria\ModLoader\Logs (This is typically found in C:\Documents\)...
  17. direwolf420


  18. direwolf420

    Tool tSpritePadder - Ready-to-use sprites for Terraria tiles

    Player sprites are not the focus of this tool. You can get vanilla player sprites by using tExtract or tConvert on the game files.
  19. direwolf420

    tModLoader ItemMagnetPlus - Customizable Item Magnet

    Are you getting it in singleplayer, 1.3 or 1.4, does it happen with only this mod enabled? I need more info, this bug is really hard to figure out the cause of (and it even happens in unmodded multiplayer sometimes, so I think its partially a vanilla issue)
  20. direwolf420

    tModLoader ItemMagnetPlus - Customizable Item Magnet

    If you play 1.4, disable the Quality Of Life mod, it seems to be incompatible EDIT July: Although I cannot reproduce any issues currently
Top Bottom