Mobile Android version has a mouse right-clicking problem


Okay. First off, hello!

I saw one other post related to this in searching here, but it was unanswered. I do have the same issue however, and that post was over a year old. I'm guessing it's been around a while. I figured I may as well point this out with a fresh post instead of bumping the old thread. I hope that's no problem.

So, right-click simply acts as a duplicate key for whatever you map left-click to, and so does the middle mouse button. Oddly, one of the side buttons functions as ESC. I've gotten around part of this issue by simply rebinding RMB to Q.

I bought the game since it was a keyboard+mouse compatible game (I have no PC right now, and I was looking for games with similar play experience), but something this basic not working makes it frustrating to play. Can't split stacks at all, even with Interact rebound, so inventory management has an annoying hinderance, particularily when needing to share items in multiplayer. Double-clicking also does not work, so anything that needs that is unavailable as well, (as I recently found out with goodie bags).

I'm running Android v13 on a Samsung Galaxy Tab S7+5G (SM-T978U). Terraria v1. Build 1081. Oh, and the mouse is bluetooth, if that even matters at all. I run the game in Dex mode, using a monitor as my second screen for the game. Dex is Samsung's version of a desktop PC OS for phones and tablets. While the game is up on the monitor, my tablet displays the home screen, and I usually have discord open on it. So, that means I can't use touch controls at all for games I play, not that I'd ever want to. I've also tried playing with Dex off, only on the tablet, and the issue persists.

I hope that this can be fixed, as it cuts into the enjoyment of the game, I'm not interested in playing at all with a controller or touch.

Well, thanks for reading if you did. And I hope that this is an issue that can be addressed.
Top Bottom