• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Automatic "Lost Connection" error

kaeluxe

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Multi
Operating System
Windows 8/8.1
Terraria Version
1.4.0
Controls Used
Keyboard/Mouse
A friend of mine cannot connect to my server. They join via steam as normal, but as soon as the server is found they get the "lost connection" error. We have reinstalled our games, verified game integrity, and checked firewalls. None of this changed anything. We were playing on the same server with the same characters (journey mode) less than 24 hours ago with no issues at all.

Upon verifying game integrity there was also a single file that was ~600 bytes that was "fixed." This happened for both of us as well.

I really wish these errors at least gave error codes because we have no idea what could be causing this.

I use windows 8, while my friend who is connecting is windows 10. My boyfriend, who is the original host of the world, is also using windows 10.

This is also a fresh journey mode server we're using. All attempts to connect to the server have been made with journey characters.
 

kaeluxe

Terrarian
I have more information!

It seems that the problem may have to do with the IP address it's using for my boyfriend and i's computers. Here's how I found this out:

My friend tried to join the world with my boyfriend as the host via steam. They got the same error. My friend then attempted to start a fresh classic world to see if WE were able to join them. It seemed to work at first and both my boyfriend and I were able to join our friend. However, I got the Lost Connection error after a bit. When I tried rejoining my friend as the host, with my boyfriend still in the server, I was able to join, but it kicked off my boyfriend and gave him the Lost Connection error. This even happened when we used two different internet connections, but they were from the same router (i think one is a 2g and the other is 5g or something).

My boyfriend and I share the same router/house while my friend is in a different state.
 
Top Bottom