• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Having issues after updating tmodloader

PurpleFire4

Terrarian
I recently updated to tmodloader v0.11.5 and I'm encountering issues. Whenever I go into the mod list my cursor freezes and becomes immovable, and whenever going into the mod browser it crashes and shows an error message.
Mods I have installed:
  • Wireless v1.5
  • Wing Slot v1.6.2
  • Tremor Mod Remastered v1.3.2.7
  • Thorium Mod v1.5.1.2
  • Terraria Overhaul v3.2.2
  • TerrariaHooks v0.18
  • Spirit Mod v1.3.4.1
  • SacredTools v1.0.5.2.0
  • Recipe Browser v0.7.1.2 (When i updated It said this mod was incompatible or something)
  • Full Health Respawn v0.0.1
  • Fargo's Soul Mod v0.5.9
  • Fargo's Mutant Mod v1.1
  • Elements Awoken v1.3.7.6
  • Elements Awoken Music v0.1.1.3
  • No More Tombs v1.0.1
  • Dark-Assassin's Mod Library (DALib) v1.2.3.3
  • Boss Checklist v0.2.1
  • Base Mod v1.0.8
  • MaxStackPlus v21.0
  • Crystilium v11.3.1.5
  • Reduced Grinding v4.36
  • Magic Storage v0.4.3.3
  • imkSushi Naturally Occuring Moons Mod v1.0.2
  • Calamity Mod (No Calamity Music) v1.4.1.4
  • Even More Modifiers v0.1.2.3
  • Prefixes For Enemies v2.0.0
  • Calamity's Vanities v2.0.1
  • Auto Trash v0.4.1
  • Even More Modifiers v0.1.2.3
  • Chad's Furniture Mod v1.4.1
  • GRealm v1.0.8
  • JoostMod v0.7.2.12
  • Mod Helpers v4.2.2.1
  • AlchemistNPC v8.2
  • The Antiaris v0.1.0.11
This is the error message I got when trying to access the mod browser:
12/11/2019 3:06:22 AM
HamstarHelpers.Components.Errors.HamstarException: Invalid modList
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.BeginModBrowserPopulateCheck(UIState modBrowserUi)
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.Show(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.LoadUI(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.Update()
at HamstarHelpers.Services.Menus.MenuContextServiceManager._Update(GameTime gametime)
at System.Action`1.Invoke(T obj)
at Terraria.Main.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame_()

Any advice in what to do?
(Sorry I may have missed some mods in the mod list as I'm unable to simply scroll down the list)
 

hamstar

Steampunker
I recently updated to tmodloader v0.11.5 and I'm encountering issues. Whenever I go into the mod list my cursor freezes and becomes immovable, and whenever going into the mod browser it crashes and shows an error message.
Mods I have installed:
  • Wireless v1.5
  • Wing Slot v1.6.2
  • Tremor Mod Remastered v1.3.2.7
  • Thorium Mod v1.5.1.2
  • Terraria Overhaul v3.2.2
  • TerrariaHooks v0.18
  • Spirit Mod v1.3.4.1
  • SacredTools v1.0.5.2.0
  • Recipe Browser v0.7.1.2 (When i updated It said this mod was incompatible or something)
  • Full Health Respawn v0.0.1
  • Fargo's Soul Mod v0.5.9
  • Fargo's Mutant Mod v1.1
  • Elements Awoken v1.3.7.6
  • Elements Awoken Music v0.1.1.3
  • No More Tombs v1.0.1
  • Dark-Assassin's Mod Library (DALib) v1.2.3.3
  • Boss Checklist v0.2.1
  • Base Mod v1.0.8
  • MaxStackPlus v21.0
  • Crystilium v11.3.1.5
  • Reduced Grinding v4.36
  • Magic Storage v0.4.3.3
  • imkSushi Naturally Occuring Moons Mod v1.0.2
  • Calamity Mod (No Calamity Music) v1.4.1.4
  • Even More Modifiers v0.1.2.3
  • Prefixes For Enemies v2.0.0
  • Calamity's Vanities v2.0.1
  • Auto Trash v0.4.1
  • Even More Modifiers v0.1.2.3
  • Chad's Furniture Mod v1.4.1
  • GRealm v1.0.8
  • JoostMod v0.7.2.12
  • Mod Helpers v4.2.2.1
  • AlchemistNPC v8.2
  • The Antiaris v0.1.0.11
This is the error message I got when trying to access the mod browser:
12/11/2019 3:06:22 AM
HamstarHelpers.Components.Errors.HamstarException: Invalid modList
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.BeginModBrowserPopulateCheck(UIState modBrowserUi)
at HamstarHelpers.Internals.Menus.ModTags.ModBrowserTagsMenuContext.Show(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.LoadUI(UIState ui)
at HamstarHelpers.Services.Menus.MenuContextServiceManager.Update()
at HamstarHelpers.Services.Menus.MenuContextServiceManager._Update(GameTime gametime)
at System.Action`1.Invoke(T obj)
at Terraria.Main.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame_()

Any advice in what to do?
(Sorry I may have missed some mods in the mod list as I'm unable to simply scroll down the list)
Hold shift when the tModLoader game window appears until you reach the main menu, update all your mods on the mod browser, then reload your mods.
 
Top Bottom