Low FPS Problem

enes

Terrarian
i have just bought terraria im getting low fps with gtx960 pc and playing on 1.3.5 i researched but couldn't find fixing for this problem
 
Last edited:

Jeff Tabb

Terrarian
I'm Having the same problem..... It's not skipping frames it's playing like the under water level of a sonic game everything is in slow motion. It's doesn't start to run normally until I bump the res down to 800x600 which is insane.
I haven't played the PC version in a few months and when I last ran it it was @ 1080p on my older Samsung TV
I just purchased a 4k Samsung TV and I have windows res set to 4k and I tried playing Terraria @ the native TV res now it runs terribly.

Currently I'm running:
AMD FX 8350 (8 core) @ 4.00 GHz
32Gb ram
AMD Radeon R9 290 4GB 512bit (Latest Driver)
Windows 10 home (Latest software updates)


At first I thought it was the GPU idle issue but I've used GPU -Z and the clock speed jumps to 1GHz and GPU usage jumps to 100% while memory usage never really goes past 20%
Normally, I have the frame skip set to subtle and everything is normally rockin. When I turn frame skip off it looks like I'm playing a flip book. I've tried setting everything to low and nothing changes... except when I turn the res to 800x600.


Update it looks like its an AMD driver issue The recent drivers won't allow my card to output 60fps so it's locked @ 30fps which is why it moves in slow motion..... I think. Will update once I know more.
 
Last edited:

enes

Terrarian
i updated the drivers still same my pc has 8 gb ram gtx960 so on everything is ok os is windows 10 insider preview maybe because of that?
 

Atreedee

Terrarian
I have the same problem. It actually started by the release of 1.2.4 update. But in 1.3, the game is unplayable on resolutions higher than 800x600 as it drops down to 5 fps while there's rain. Even at 800x600 it drops while there are a couple of things going in the screen. My specs are i3-2350M, Geforce 410m and 4GB of RAM.
 
Top Bottom