• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 NEWS: The current plan is to have Terraria: Journey's End out for Xbox and PlayStation in Q3 2021 (Jul-Sep). Switch will follow shortly afterwards. More info here. Stay up to date with console news here
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Need Help Making Language Pack

Experiment201

Terrarian
Hi all,

So, I recently read through the huge guide posted on how we can create our own language packs. I've made some preliminary edits and wanted to test them out; however, I can't find my resource pack once I boot up Terraria. Some detailed information on what's up:

I went ahead and downloaded the massive localization file, made the edits, and then created a ResourcePacks folder (there was not one already made) in my My Games folder. I created a folder within that containing my packs name. I then dropped my pack.json file I made in there along with creating a Content folder. Afterwards, I made a Localization folder and dropped in my file. I tried using it as a .csv file, but that didn't seem to work; neither did having the localization file be in a .json format. I've ensured the file name has the en-US prefix, but the language pack is still not appearing in the game as an option I can select in the "Use Resource Packs" tab/section of the Workshop menu. I then tried making a folder within the Steam Workshop folder identical to everything above, but no dice.

Does anyone know what could possibly be going on? What am I doing wrong? Also, mods, I apologize if this isn't the correct section of the forum to ask these questions; I just created my account, so if I need to go somewhere else, please let me know. Thanks!
 

Zilem

Moon Lord
The file locations needs to be like this (for language packs):
Code:
ResourcePacks
└ "Folder name" (or .zip package)
   ├ Content (folder)
   | └ Localization (folder)
   |   └ en-US.csv / en-US.json
   ├ icon.png (Optional)
   └ pack.json

If there is something in the pack.json, it won't show up in the Resource menu (ingame)

Regardless if you use steam-workshop or otherwise
You have to go into the "workshop" menu in Terraria and "Use Resource Packs" to enable them
^.~
 

Experiment201

Terrarian
Sorry for the late reply! I've got everything looking as you say, but it's still not in the "Workshop" menu. Don't really know what's going on. Do you know what else I might be messing up?

Also, thanks for being willing to help with this. :D
 

Zilem

Moon Lord
If the Directory is correct, then it is likely the pack.json that have something wrong
JSON:
{
    "Name": "Package name",
    "Author": "name(s) of creator(s)",
    "Description": "Long description text",
    "Version": {
        "major": 1,
        "minor": 0
    }
}
if you still have trouble finding out where the culprit is, you can send the package to me in Via PM and I'll take a look at it myself
^.~
 

Experiment201

Terrarian
That did the trick! I don't know what exactly was wrong with my .json file, but using your text did it for me. Thank you so much again for the help!!
 
Top Bottom