• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • SWITCH 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

PC Problem with the new Music Packs.

SkyLink

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 7
Terraria Version
1.4.2.1
Controls Used
Keyboard/Mouse
I made a MusicPack for the new version 1.4.2 (the same problem occurring in 1.4.2.1) and interestingly, when the intro plays, it ends, the game hangs and returns, but the music does not start from the menu, the intro keeps repeating indefinitely, it just goes back to normal if I change the window or reset the pack, and I didn't have this problem before, when I just replaced the WaveBank file in the root folder. In addition, I am unable to post an image when publishing.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Could you provide more information on "unable to post an image when publishing"?

What happens when you try?

Also, what type of music files are you using for your replacements, MP3s? If so, could you try using a wav or ogg and see if the issue persists? This will help us determine whether its a universal issue, or an MP3 issue (MP3s have a lot of technical issues that make them poorly suited for this sort of thing, and finding the conflicts they are causing is an ongoing process).
 

SkyLink

Terrarian
Could you provide more information on "unable to post an image when publishing"?

What happens when you try?

Also, what type of music files are you using for your replacements, MP3s? If so, could you try using a wav or ogg and see if the issue persists? This will help us determine whether its a universal issue, or an MP3 issue (MP3s have a lot of technical issues that make them poorly suited for this sort of thing, and finding the conflicts they are causing is an ongoing process).
Nothing happens, I click to select, but nothing happens, the window doesn't change, there's no option to select the image, that's it. And in the case of the files, they are all wav files that I used in previous versions of the game, when people exchanged the WaveBank file in the root folder, and as I said above, this problem did not happen when I used this method.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Alright, we don't have any leads on what would be causing this, and this is the only report thus far, so Yorai wants to see if we can get a log for this.

1. Go to Terraria properties in Steam Library, to the section that says set Launch options
2. Paste this into the field:
-logerrors -logfile
3. Next time you run (and every time you run the game), it will create a log of things that happen. If you could turn the game on with the log running while you encounter this bug, that may record some information in the log for us to review. After it happens, you can turn the game back off (which will complete the log).
4. The log will be in Documents>My Games>Terraria>Logs.
5. Please send us the file created, and we will try to look into it.
6. When you are done, feel free to REMOVE the -logerrors -logfile, because it will be making these anytime you play, and it can take up space.
 

SkyLink

Terrarian
5. Please send us the file created, and we will try to look into it.
Here it is dear. Sorry for the inconvenience I may be causing in this regard. I hope the log helps you.
Edit: I did a second log, in case you need to check something and everything.
 

Attachments

  • Log_20210401185254400.log
    2.5 KB · Views: 30
  • Log_20210401185935059.log
    2.8 KB · Views: 26
Last edited:
Top Bottom