PS4 All in the family trophy bugged?

Discussion in 'Console Bug Reports' started by Starkiller4344, Jan 16, 2018.

  1. Starkiller4344

    Starkiller4344 Terrarian

    On my journey to platinum terraria on the PS4 I have come across quite a big obstacle. I have all of the required NPCs in my world but the trophy hasn't been bestowed unto me. Is there a set amount of time that needs to pass in game before the trophy registers or do all of the NPCs need to be in the same house or in the same proximity?
     
  2. Unit One

    Unit One Moderator Staff Member Moderator

    Achievements were always kind of finicky, even before the 1.3 update. Sometimes they just won't pop even if you have done the required elements for it. Give it a bit of time, it can be frustrating. Alternatively, are you sure you have all the NPCs? Can you post a screenshot of which NPCs you have?
     
  3. Starkiller4344

    Starkiller4344 Terrarian

    --- Double Post Merged, Jan 16, 2018, Original Post Date: Jan 16, 2018 ---
    I have all of the NPCs except Santa and I read that he isn't required so I guess I'll just have to wait it out then until the game decides to register that I have them all
     
  4. Starkiller4344

    Starkiller4344 Terrarian

    So I know for a fact that I have all of the NPVs required because I got the in game accomplishment but the PS4 trophy still hasn't popped. I've tried killing the NPCs multiple times and having them respawn, I've also tried to rerange them to get the trophy to pop. I've even sat in a world with them afk for an entire day to get the game to register their existence but no matter what I do the trophy will not pop. It's really frustrating and has taken some of the guns way from the game. Does anyone have any possible suggestions that could help me get the trophy to pop?
     
  5. The_BAE_Of_Gravity

    The_BAE_Of_Gravity Terrarian

    1. Are you online
    2. Clear your cache
    3. I have no idea. I don't get any achievements on Xbox one unless I log in online, when that happens, it takes 5 minutes and I get slammed with achievements. This may or may not help. But try problem solving with Sony.
     
  6. gtasthehunter

    gtasthehunter Terrarian

    How about you just list all the NPC's you have, might just be missing one.

    Are they all in the same house, in separate rooms as well? I doubt they need to be in the same house but maybe they do.

    Is Tavernkeep even in this game yet? Maybe it is needed but not added yet?
     
    Last edited: Jan 23, 2018
  7. Unit One

    Unit One Moderator Staff Member Moderator

    They shouldn't need to be in the same house. Tavernkeep was part of the 1.3.4 update which console does not have, so you should not need him.
     
  8. gtasthehunter

    gtasthehunter Terrarian

    Well for me It is just easier to know who you have if they are in the same house and easier to find them when you need to.
     
  9. tomtom201120

    tomtom201120 Terrarian

    Hi gays just got the “All in family” trophy.
    I was going for the pets trophy when I moved the Pirate out to the beach (to get the Parrot Cracker,) when I got this trophy, so try moving him out there.
    I tryed to get this trophy once before and I had your problem. If this dose not do it for you try moving other NPC’s to different biomes.
    Such as the Witch Doctor to the Jungle biome.
    Hope this helps Tomtom201120 OUT!
     
  10. r4v1n6

    r4v1n6 Official Terrarian

    Try killing each NPC once (and allow them to resurrect), until you get the trophy. That worked for me. I think it was the Angler that did it for me (it was a while ago so can't remember).