• Console & Mobile Terrarians - news for 1.4.4.9! As of Nov 30, iOS and Android 1.4.4.9 are out now. PS and Xbox should be very soon. Switch and Amazon are in submission. Great way to end the year - everyone on the same version of Terraria! More details HERE.

tModLoader Magic Storage

absoluteAquarian

Duke Fishron
i cannot find a download for v0.5.6.4. it is not posted in the mod browser, so, is there a download link for it?

edit: i found a download link, but i am confused as to why the update wasn't put into the mod browser. is this intended or not?
Steam tends to not put updates for workshop items out when updates are paused.
You can force an update by verifying game integrity for tModLoader.
 

absoluteAquarian

Duke Fishron
hi, i got this problem when loading in only this mod, after world generation its stuck on the background with terraria logo with nothing else on it and i have to restart the game, after i restart the game i can enter the newly generated world but its missing all UI's and esc to open inventory shows nothing and f11 to enable and disable UI is not working either, no cursor is showing in the game other than hotbar and top part of the screen where you can close the game, i loved the mod back in 1.3, and hoped i could be able to play it in 1.4 so hope there is a way to fix this issue
Update the mod to v0.5.6.4, you're using an older version. You'll also need to make a new world, since the world you mentioned has been corrupted.
 

HookTheHooker

Terrarian
Hi, i played with a couple of friends on a world and we wanted to upgrade the magic storage from regular storage units to demonite storage units. After the upgrade it showed 0 items in the storage heart and the storage units. The storage units colours are red/orange/green and we have the v0.5.6.4 version. Rejoining the world doesnt work. Before the upgrade to demonite everything worked fine. We are also playing with some more mods than just magic storage like calamity. Any idea whats causing this problem?

Update:
Deactivating and reactivating the storage units fixes the problem, but you need a magic storage wand. To obtain this wand u need wires and we didnt had those at the moment.
 
Last edited:

sirgoldenfro

Terrarian
Hi, i played with a couple of friends on a world and we wanted to upgrade the magic storage from regular storage units to demonite storage units. After the upgrade it showed 0 items in the storage heart and the storage units. The storage units colours are red/orange/green and we have the v0.5.6.4 version. Rejoining the world doesnt work. Before the upgrade to demonite everything worked fine. We are also playing with some more mods than just magic storage like calamity. Any idea whats causing this problem?

Update:
Deactivating and reactivating the storage units fixes the problem, but you need a magic storage wand. To obtain this wand u need wires and we didnt had those at the moment.
Im having the same issue
 

absoluteAquarian

Duke Fishron
I cannot craft the Biome globe, I have every item required for it and yet it does not show up in my crafting interface.
The recipe is 5 Tombstones, 1 Broken Snowglobe, 1 Water Bucket, 1 Lava Bucket, 1 Honey Bucket, 3 Campfires and 1 Demon Altar/Crimson Altar.

The Broken Snowglobe and Demon Altar/Crimson Altar are both items from Magic Storage.

Use the Which Mod Is This From? mod to make sure that you have these exact items.
 
1657503389935.png

got all the items yet it still wont show up.
edit: wait the altar was from fargos.
 

Games4GuysYT

Terrarian
Edit: don’t worry about it a simple restart will fix this
This does occur quite frequently however



I have encountered a bad bug, recently I was playing with my friend on a world and when I placed down the magic storage and put stuff in it if I were to put another storage node next to it or put an upgrade from basic to crimson or hit the storage it would delete everything in it and leave an unbreakable block that can’t be changed or broken, I can’t take out the upgrade and it’s kind of ruined a lot for us. We are on update 0.5.6.4
 
Last edited:

absoluteAquarian

Duke Fishron
Edit: don’t worry about it a simple restart will fix this
This does occur quite frequently however



I have encountered a bad bug, recently I was playing with my friend on a world and when I placed down the magic storage and put stuff in it if I were to put another storage node next to it or put an upgrade from basic to crimson or hit the storage it would delete everything in it and leave an unbreakable block that can’t be changed or broken, I can’t take out the upgrade and it’s kind of ruined a lot for us. We are on update 0.5.6.4
This has been fixed in one of the private betas that I've released for v0.5.6.5. I'm going to try to fix other bugs before making v0.5.6.5 public, so wait until that releases.
 

Jamoji

Terrarian
this message appears in chat every time I try to craft anything, and crafting does not work at all.
it was working earlier today, and I hadn't left the world between it working, and when it stopped.
 

Attachments

  • 20220803154910_1.jpg
    20220803154910_1.jpg
    148.7 KB · Views: 52

absoluteAquarian

Duke Fishron
this message appears in chat every time I try to craft anything, and crafting does not work at all.
it was working earlier today, and I hadn't left the world between it working, and when it stopped.
This is a bug in the Weapon Enchantments mod. It will be updated soon according to its dev.
 

0rmal

Terrarian
Two days ago I was able to use this mod then out of nowhere it hit me with an error saying it was made for a different version of tModLoader. I have looked for a v2022.7.29.0 and cannot find it. Is this a problem with Magic Storage, tModLoader, or my computer; is anyone else experiencing this?
Magic Storage not working.png
 

absoluteAquarian

Duke Fishron
Two days ago I was able to use this mod then out of nowhere it hit me with an error saying it was made for a different version of tModLoader. I have looked for a v2022.7.29.0 and cannot find it. Is this a problem with Magic Storage, tModLoader, or my computer; is anyone else experiencing this?View attachment 379699
This is being looked into. Expect a fix once Magic Storage v0.5.7 releases.
 
Top Bottom