• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

PC Make your own music for Terraria 1.3 (instructions and more)

Avani

Terrarian
The only setting that was off was the compression quality. It had changed from the default 60 and is likely causing the building issues. I built it with no errors after that was fixed. Couldn't get my game to load. I'll have to look into it more when I get back home later.
Alright, I updated the project. It built fine with the default compression quality and I even got my game to load. Now the question is what's causing the music to go back down to 0%.

Updated DL: https://www.dropbox.com/sh/zop1b1se3imrqx6/AAC8EAfkYWpzdNGhrZNg-xbXa?dl=0
 

MadaxTheShadow

Official Terrarian
Nope. I'm using Windows 7.
Are you building the wavebank with the file named "Wave Bank" or something different? There's some internal information the final file has that doesn't change when you later rename the wavebank to put it into the Content folder. If it's not named "Wave Bank" on creation it will crash the audio.
 

Avani

Terrarian
Are you building the wavebank with the file named "Wave Bank" or something different? There's some internal information the final file has that doesn't change when you later rename the wavebank to put it into the Content folder. If it's not named "Wave Bank" on creation it will crash the audio.
If the default name is Wave Bank, then yes, I'm naming it that.
 

MadaxTheShadow

Official Terrarian
I haven't come across anything else that messes with the audio. Only other thing I can think of is making sure the file you use has the .xwb extension.
 

Avani

Terrarian
I haven't come across anything else that messes with the audio. Only other thing I can think of is making sure the file you use has the .xwb extension.
It might be because the file size is massive. Most wave banks I've seen are around 50,000 kb I'd say, but mine is... 328.3k? Something around that. I'll try cutting it down as best I can and see if it works and then go from there.
 

Avani

Terrarian
When I built yours it was around 36 MB. My own is 34 MB and works well. (Well, at least last I tried it a month ago)
There must be something I'm doing wrong, then, because mine doesn't seem like it's been compressed all that much judging from the... odd file size.
 

Moon Man

Terrarian
OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHHH FINALLY AFTER 5 :red:ING HOURS ITS WORKING!!!!!!!!!!!!!!!! THANKS SO MUCH!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

CaptainGold1

Skeletron Prime
Thanks so much m8! Just finished my new wavebank!
[doublepost=1481787461,1481787037][/doublepost]uh... My title screen music keeps randomly playing in place of other music. Any way to solve this?
 

Arkenova

Skeletron
Thanks so much m8! Just finished my new wavebank!
[doublepost=1481787461,1481787037][/doublepost]uh... My title screen music keeps randomly playing in place of other music. Any way to solve this?
Did you check if it's on the right number tracks? It did the same thing with me before.
 

Coding Lexicon

Skeletron Prime
I have no idea what I'm doing wrong, but the wavebank doesn't work with the game.
Is it because I can only get it down to 25 mb?
I've tried decreasing the quality in the compressor preset, but I don't know how badly the tracks are affected at 10.
[doublepost=1482200520,1482200125][/doublepost]Never mind, I got it down to 18.5 mb and the wavebank still won't work
 

ohboybisquick

Terrarian
I posted this on another thread but... Could someone help me with this? In the 1.3.3 update i tried this but it took me hours to get the visual studio program alone because it kept saying i didnt have the requirements and I had to search for hours to find a version of xact thats standalone. And even more hours to try to export everything. so instead of trying to reinstall all of that, can someone do it for me? It would be GREATLY appreciated.

Here's a zip file with each wav file (of mostly pokemon songs) numbered accordingly to the song list so you would just have to run it through game studio. Thanks so much in advance!!! https://www.dropbox.com/s/k1a16muwvs5dw0j/Wave Bank.rar?dl=0
 

CaptainGold1

Skeletron Prime

I posted this on another thread but... Could someone help me with this? In the 1.3.3 update i tried this but it took me hours to get the visual studio program alone because it kept saying i didnt have the requirements and I had to search for hours to find a version of xact thats standalone. And even more hours to try to export everything. so instead of trying to reinstall all of that, can someone do it for me? It would be GREATLY appreciated.

Here's a zip file with each wav file (of mostly pokemon songs) numbered accordingly to the song list so you would just have to run it through game studio. Thanks so much in advance!!! https://www.dropbox.com/s/k1a16muwvs5dw0j/Wave Bank.rar?dl=0
I could do it, ill msg you when it is done
-Captain

[doublepost=1482474654,1482474338][/doublepost]
Did you check if it's on the right number tracks? It did the same thing with me before.
No, because when a track ends, sometimes instead of looping it will play the title screen song. When I turn the volume to zero and back again, sometimes it goes back to the correct song, sometimes it doesn't. This also happens sometimes when it tries to transition to a new biome/track..
 

greg.gibbons7

Terrarian
I've built my wave bank. The size is smaller than the defualt by a small amount. It's named correctly, and has the proper extension... and yet, it still keeps my volume at 0. Does anyone have an idea why?
 
Top Bottom