• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.4 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Mod Helpers

RandoomerST

Terrarian
Unfortunately, after i updated to the latest version (the one for the new tmodloader update), I get an error while loading this mod, it says something about mscorlib needing a strong name, I've tried downloading directly from the mod loader browser and from this site, but both versions have this error for me, I'd appreciate some help.
This is the error log I caught which mentions mscorlib:
[18:10:36] [8/ERROR] [tML]: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Failure to load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strong assembly name is necessary. (Exception at HRESULT: 0x80131044)
File Name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at HamstarHelpers.Services.Timers.Timers.SetTimer(String name, Int32 tickDuration, Func`1 action)
at HamstarHelpers.ModHelpersPrivilegedUserConfig.OnChanged() na HamstarHelpers\Config.cs:linha 34
at Terraria.ModLoader.Config.ConfigManager.Add(ModConfig config)
at Terraria.ModLoader.Mod.AutoloadConfig()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)
 

hamstar

Steampunker
Unfortunately, after i updated to the latest version (the one for the new tmodloader update), I get an error while loading this mod, it says something about mscorlib needing a strong name, I've tried downloading directly from the mod loader browser and from this site, but both versions have this error for me, I'd appreciate some help.
This is the error log I caught which mentions mscorlib:
[18:10:36] [8/ERROR] [tML]: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Failure to load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strong assembly name is necessary. (Exception at HRESULT: 0x80131044)
File Name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at HamstarHelpers.Services.Timers.Timers.SetTimer(String name, Int32 tickDuration, Func`1 action)
at HamstarHelpers.ModHelpersPrivilegedUserConfig.OnChanged() na HamstarHelpers\Config.cs:linha 34
at Terraria.ModLoader.Config.ConfigManager.Add(ModConfig config)
at Terraria.ModLoader.Mod.AutoloadConfig()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)
Delete the HamstarHelpers_ModHelpersPrivilegedUserConfig.json file. If you happen to need the "privileged user" function, I'll have a fix for that error with the next version.
 

Jack1248

Terrarian
Hi Hamstar, unfortunatly I have to report that ModHelpers still doesnt work offline for me, even when using the latest version. Is there any way to fix this? Editing the config like
you said didnt help either. Same error as before. Terraria loads up to "Adding Recipes", then closes without warning or error message. :(
 

hamstar

Steampunker
Hi Hamstar, unfortunatly I have to report that ModHelpers still doesnt work offline for me, even when using the latest version. Is there any way to fix this? Editing the config like
you said didnt help either. Same error as before. Terraria loads up to "Adding Recipes", then closes without warning or error message. :(
Try this version, and set DisableOwnIPCheck in the config file. Do you know where the config's json file is?
 

Attachments

Last edited:

espritz

Terrarian
Delete the HamstarHelpers_ModHelpersPrivilegedUserConfig.json file. If you happen to need the "privileged user" function, I'll have a fix for that error with the next version.
Hello, I got the same problem and I can't find the HamstarHelpers_ModHelpersPrivilegedUserConfig.json file anywhere in modloader file.
 

RandoomerST

Terrarian
In case anyone else is having the same problem with the mscorlib thing as I was, something that seems to have fixed my problem was updating NET framework to 4.7.2.
After that I was able to use the mod normally, I didn't even have to use the alternative file that was provided above, I'm not sure if that will work for everyone else, but hopefully what worked for me will work for someone else as well.
 

ASDAS

Terrarian
I have problem! When i trying to enable this mod i get always this error
: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Could not load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)
File name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Signature..ctor(IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimeConstructorInfo.GetParametersNoCopy()
at System.RuntimeType.FilterApplyMethodBase(MethodBase methodBase, BindingFlags methodFlags, BindingFlags bindingFlags, CallingConventions callConv, Type[] argumentTypes)
at System.RuntimeType.GetConstructorCandidates(String name, BindingFlags bindingAttr, CallingConventions callConv, Type[] types, Boolean allowPrefixLookup)
at System.RuntimeType.GetConstructorImpl(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers)
at System.Type.GetConstructor(BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers)
at Terraria.ModLoader.Mod.Autoload()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)
How to deal with this error?
 

hamstar

Steampunker
I have problem! When i trying to enable this mod i get always this error
: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Could not load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)
File name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Signature..ctor(IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimeConstructorInfo.GetParametersNoCopy()
at System.RuntimeType.FilterApplyMethodBase(MethodBase methodBase, BindingFlags methodFlags, BindingFlags bindingFlags, CallingConventions callConv, Type[] argumentTypes)
at System.RuntimeType.GetConstructorCandidates(String name, BindingFlags bindingAttr, CallingConventions callConv, Type[] types, Boolean allowPrefixLookup)
at System.RuntimeType.GetConstructorImpl(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers)
at System.Type.GetConstructor(BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers)
at Terraria.ModLoader.Mod.Autoload()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)
How to deal with this error?
You may need to update your .NET Framework. What version are you using?
 

hamstar

Steampunker
My version of .Net Framework is 4.6.1
Windows 8 is not supported version newer
How I can install this mod without .Net 4.7?
Honestly, I might need some help with this one. I build this mod for v4.5.2, but it still insists it needs v4.7+. Any insight into how to address this is appreciated.
 

EmmyPup

Terrarian
I'm getting an error during "Recipe Browser: Rebuilding Loot Cache" when loading using TModLoader v0.11.5 64-bit.

[1/FATAL] [HamstarHelpers]: ~HamstarHelpers.MenuContextServiceManager.SwitchToUI - 0:000 - 000250.98 (10000th) Could not get MenuUIDefinition UILoadMods

It just hangs after that.
 

hamstar

Steampunker
I'm getting an error during "Recipe Browser: Rebuilding Loot Cache" when loading using TModLoader v0.11.5 64-bit.

[1/FATAL] [HamstarHelpers]: ~HamstarHelpers.MenuContextServiceManager.SwitchToUI - 0:000 - 000250.98 (10000th) Could not get MenuUIDefinition UILoadMods

It just hangs after that.
Does this happen with only Mod Helpers loaded? This is likely an error from another mod, as the error above is actually just a benign UI warning.
 

EmmyPup

Terrarian
Does this happen with only Mod Helpers loaded? This is likely an error from another mod, as the error above is actually just a benign UI warning.
Turns out it wasn't hanging, it was just taking a really long time to load. Sorry for the false alarm!
 

hamstar

Steampunker
Special thanks to ChloeElizabeth (on Discord) for helping track down a long-standing OnEnterWorld issue.
 
Top Bottom