• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.4 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Mod Helpers

Rosealee

Terrarian
your hamstar helper stuff is crashing my terraria tmod. i keep getting the error hamstarhelper when i try to click on mod browser and if i click on mods it just freezes. can you help me with this?
 

hamstar

Steampunker
your hamstar helper stuff is crashing my terraria tmod. i keep getting the error hamstarhelper when i try to click on mod browser and if i click on mods it just freezes. can you help me with this?
I send you the instructions for the fix. You need the latest Mod Helpers version.
 

hunterrftw

Terrarian
Keep getting this every time I try running anything with ModHelpers


[17:03:47] [61/ERROR] [tML]: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Could not load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)
File name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Signature..ctor(IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimeConstructorInfo.GetParametersNoCopy()
at System.RuntimeType.FilterApplyMethodBase(MethodBase methodBase, BindingFlags methodFlags, BindingFlags bindingFlags, CallingConventions callConv, Type[] argumentTypes)
at System.RuntimeType.GetConstructorCandidates(String name, BindingFlags bindingAttr, CallingConventions callConv, Type[] types, Boolean allowPrefixLookup)
at System.RuntimeType.GetConstructorImpl(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers)
at System.Type.GetConstructor(BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers)
at Terraria.ModLoader.Mod.Autoload()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)


[17:03:47] [61/INFO] [tML]: Disabling Mod: HamstarHelpers
[17:12:36] [1/DEBUG] [tML]: Process.Start (UseShellExecute = True): "C:\Users\user1\Documents\My Games\Terraria\ModLoader\Logs\client.log"
 

hamstar

Steampunker
Keep getting this every time I try running anything with ModHelpers


[17:03:47] [61/ERROR] [tML]: An error occurred while loading HamstarHelpers
The mod(s) have been automatically been disabled.
System.IO.FileLoadException: Could not load file or assembly 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. A strongly-named assembly is required. (Exception from HRESULT: 0x80131044)
File name: 'mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=null'
at System.Signature.GetSignature(Void* pCorSig, Int32 cCorSig, RuntimeFieldHandleInternal fieldHandle, IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Signature..ctor(IRuntimeMethodInfo methodHandle, RuntimeType declaringType)
at System.Reflection.RuntimeConstructorInfo.GetParametersNoCopy()
at System.RuntimeType.FilterApplyMethodBase(MethodBase methodBase, BindingFlags methodFlags, BindingFlags bindingFlags, CallingConventions callConv, Type[] argumentTypes)
at System.RuntimeType.GetConstructorCandidates(String name, BindingFlags bindingAttr, CallingConventions callConv, Type[] types, Boolean allowPrefixLookup)
at System.RuntimeType.GetConstructorImpl(BindingFlags bindingAttr, Binder binder, CallingConventions callConvention, Type[] types, ParameterModifier[] modifiers)
at System.Type.GetConstructor(BindingFlags bindingAttr, Binder binder, Type[] types, ParameterModifier[] modifiers)
at Terraria.ModLoader.Mod.Autoload()
at Terraria.ModLoader.ModContent.<>c.<Load>b__39_0(Mod mod)
at Terraria.ModLoader.ModContent.LoadModContent(CancellationToken token, Action`1 loadAction)
at Terraria.ModLoader.ModContent.Load(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)


[17:03:47] [61/INFO] [tML]: Disabling Mod: HamstarHelpers
[17:12:36] [1/DEBUG] [tML]: Process.Start (UseShellExecute = True): "C:\Users\user1\Documents\My Games\Terraria\ModLoader\Logs\client.log"
(Ignore my previous advice.)

Check if you have any .NET Framework updates needed.
 

YOLO01

Terrarian
I playing with my friend in terraria on multi. When we tryin sumon bosses they won't spawn. What can cause this problem?
 
This mod is no longer Multiplayer compatible and disables the Extensible Inventory v1.5.2 after the v5.5.1 update. Please fix and thank you always for your hard work!
 

hamstar

Steampunker
This mod is no longer Multiplayer compatible and disables the Extensible Inventory v1.5.2 after the v5.5.1 update. Please fix and thank you always for your hard work!
Can you give me more information? I'm not able to replicate this issue.
 
Last edited:
When you click the ... under the Powered By Mod Helpers vX.X.X, there doesn't appear to be a way to re-hide it, and it prevents the mod tags from showing up in the mod browser. The only fix for this is to restart the game.
 

hamstar

Steampunker
When you click the ... under the Powered By Mod Helpers vX.X.X, there doesn't appear to be a way to re-hide it, and it prevents the mod tags from showing up in the mod browser. The only fix for this is to restart the game.
Does this happen repeatably? I cannot replicate this issue. Can you describe it any better?
 
Last edited:
Hide it? Clarify what you mean.

Send me your client.log file, just in case.
I mean, when I click the ... to show the additional info (EG: Do you make mods, the discord link, the patreon button), you can't then hide that info without restarting Terraria. When this happens, I cannot enable the mod tagging interface in the mod browser.
 

Attachments

ImmortalZypther

Skeletron Prime
Is it possible to completely disable the control panel and the messages? They get in the way of buttons when you're using The Grand Design. I've tried changing the config in My Games\Terraria\ModLoader\Mod Configs along with the one in My Games\Terraria\Mod Configs but neither one works.

Edit: I've figured out how to disable the control panel, but not the messages. I found out that tModLoader now has a config in the mod list instead of outside in the folders.

Edit2: Found out how to hide the messages. I aligned the inbox to -250 x and y.
 
Last edited:
Top Bottom