• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

Random issues in 1.4

wrr377

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 7
Terraria Version
1.4.0
Controls Used
Keyboard/Mouse
I am having some strange issues with some of the 1.4 updated content:

1) Duplication Listing Bug: I have researched the Honey Bucket, Water Bucket, and Lava Bucket, but only the Water Bucket is showing in the list of duplicates. I tried searching for "bucket", and clicking every tab in the duplication menu, but the only one that shows up is the Water Bucket.

*EDIT* The other buckets showed up after refreshing the Duplication screen a few times - this isn't the only time or item it has happened with...

2) Whenever I am holding Shift and pointing at an edge with moss on it, that I am trying to auto-cut with my Crimson pickaxe (when the pickaxe is not the active tile in the toolbar), most of the time the game will auto-select the Magic Mirror instead and teleport me back to my spawn point.

Those are the only two issues I've encountered so far, but may add others as I continue playing.

My system specs are as follows:

Core i5-4570
16GB DDR3 RAM
GeForce GTX 1070 8GB Founder's Edition
Windows 7 Pro x64
Games are being runoff a dedicated 1TB SSD
Terraria was purchased, and runs, through Steam with the overlay enabled
 
Last edited:

wrr377

Terrarian
3) Sometimes when trying to use the multi-wrench for putting down wire, it refuses to bring up the function selection menu when I right-click. I keep it in the hotbar menu for convenience.

- The work-around is apparently to select another tile in the hotbar, then re-select the multi-wrench tile, at which point the multi-wrench menu works as intended.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
I've been unable to reproduce this Magic Mirror issue. Magic Mirror shouldn't ever be brought up by Smart Select, and when I attempted this, I couldn't get it to happen.

We are getting some intermittent reports of missing items in the duplication menu, but its lost a bit by some false reports and having unclear reproduction steps. I personally was unable to get it to happen either, but we are looking into it.
 

wrr377

Terrarian
4) Some of my settings from both the regular game options menu, and the "Bunny" in-game menu, are not getting saved:
a) I had the Health & Magic bars set as "Old Style", yet when I booted up the game today, it had them as the fancy type with the golden outlines. I went in and changed them back
b) Multiple times now, I have had to change the "bunny" menu options so that the Corruption / Crimson does not spread (golden border) - I initially set it like that, yet at least twice I have found it to not be selected when I have loaded up the game after fully quitting to desktop

I also noticed that Terraria had updated, and I wonder if the updates are wiping out my settings?

In regards to the Magic Mirror issue, would it help by mentioning that I keep the Magic Mirror in the "0" / last slot of my hotbar? I currently arranged the bar as follows:

Slot # - Item
1 - Sword / Lance / [Dedicated Melee]
2 - Picksaw
3 - Hamaxe
4 - Golden Discs
5 - Deathscythe
6 - Hatchet
7 - Sticky Bombs
8 - Lavaproof Bugnet
9 - Multiwrench
0 - Magic Mirror

Also, the "moss" I was trying to cut when the auto-Magic-Mirror happened was the dark-red kind on the edges of grey stone. I wasn't clicking on the stone itself, but the area adjacent to it where the moss sprites were located. It did not put a Magic Mirror symbol over the cursor, but it activated it nonetheless.
 
Last edited:

wrr377

Terrarian
The following are after having beaten the Moon Lord, then setting it for Master difficulty (accomplished through the new slider in the bunny menu) to farm for all boss drops

5) When summoning bosses with their associated consumables, there is a chance for them to de-spawn part way through the fight:
a) Brain of Cthulhu - There has been more than one time (during a marathon boss-drop farming) where if the Brain itself was invisible at the point that I killed all the eyeball minions, but before it re-appears to attack and is vulnerable, it permanently disappears. I can hear its teleport sound a couple times (but no sprite on-screen or the map), and then the life bar vanishes, along with the boss music.
b) Skeletron Prime - I was fighting it outside in my arena, I had changed the time to "Dusk" before summoning him. Partway through the fight, at about 75% health, he simply vanished.
c) Dreadnautilus - He teleported below the surface, into a completed blocked-out area, then as I was fighting the blood squids in the air, he vanished as soon as he was off-screen.

6) Money drop issue - When I am killed, it claims I drop a specific amount of money, ie 20 Gold. When I return to retrieve the money, it is only a fraction of what I dropped (around 3 Gold). I know Master mode is supposed to drop all your cash, but is it supposed to vaporize it, as well?

*EDIT* Added Dreadnautilus account of boss de-spawning.
 
Last edited:

zimboptoo

Terrarian
I'm having the same auto-select issue with Moss. It's not actually that it's selecting the Magic Mirror (although I also keep mine in hotkey 0, so that was my inital assumption as well). It's just highlighting and activating whatever is in hotkey 0.

It appears to happen when:

- You have Extended Placement Range turned on in the Journey Mode Power Menu (I haven't tried in non-Journey Mode, but it doesn't happen if Extended Placement Range is turned off)
- Your inventory is closed (doesn't happen when inventory is open)
- You have Auto-Select held down (doesn't appear to happen when you start pressing Auto-Select while the pointer is already over the moss)
- You move the pointer over the hitbox of the part of the moss that extends from the block (not the block itself).
- Your pointer is within 9 blocks of you

I've been able to reproduce it on glowing green moss as well as red moss. It doesn't seem to matter what hotkey is currently "selected", or what (if anything) is in hotkey 0. You can tell it's happening even without clicking (if you're paying attention) because hotkey 0 highlights right as you move the pointer over the end of the moss. It's a very small hitbox, but it's still pretty easy to hit if you're holding down Auto-Select while mining in an area with moss on the walls.

I'm on 1.4.0.4, Dedicated Server, Journey Mode, pre-HM, Medium world, no mods.
 

Sigma90

Brain of Cthulhu
Thanks for the detailed steps, zimboptoo!
I think I can see what you're referring to, at least partially. If a pickaxe is not in your inventory, moving over the block auto-selects the pickaxe, then moving back away leaves the selected item in your hotbar in the same column the pickaxe was. So if your pickaxe was in column 0, holding auto-select, moving over the moss (selecting the pickaxe) and back again will leave hotbar 0 selected. If that was the Magic Mirror, it'll be highlighted and used.

I won't attach the GIF as it's a little large, but I'll report it to Re-Logic. :)
 
Top Bottom