• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 LAUNCHES SEP 30: The official launch date for Journey's End to arrive on Xbox and PlayStation is September 30th! Click here for more info. The plan is to have the update on Switch out later this year. Stay up to date with console news here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

tModLoader Recipe Browser

Liquidbings

Terrarian
Howdy folks long time Terraria fan.

New to mods though this is the first mod I've tried to install on Tmodloader. When I install the mod, then activate it, then roload the mods it seems like its going to work.

I log into the server and then there is no options in the controls for this mod and when I log back out of the server it says its been deactivated again.

any ideas?
 

jopojelly

Retinazer
tModLoader
Howdy folks long time Terraria fan.

New to mods though this is the first mod I've tried to install on Tmodloader. When I install the mod, then activate it, then roload the mods it seems like its going to work.

I log into the server and then there is no options in the controls for this mod and when I log back out of the server it says its been deactivated again.

any ideas?
which server? does the server show the mod as enabled? if the server is automatically disabling the mod, you'll need to check server.log to see why, it could be caused by another mod breaking recipe browser.
 

Liquidbings

Terrarian
Thank you for such a quick reply.

Its a Tmod Docker Container I have running on my UnRaid Server. I put the mod into the mod folder, "appdata\terraria-tmodloader\TML\Mods" but did not see any other way to activate it since there is no gui for it, and Console lists it as not active. I have restarteed since adding it to the folder but also does not seem to activate it.

Thank you kindly for any help anyone can provide

EDIT:

I actually figured it out somehow. I did 2 things so I'm not sure which it was yet but Ill do some investigative work this afternoon and let you know which it was.

1. I found a .exe that let me access the linux modloader
so it was either this or
2. I was missing the enabled.json file in the original spot I tried to put the mod file. so I added that as well
 
Last edited:

Ljip06

Terrarian
how come when i toggle it, it appears in the bottome right of the page i can only see the top corner and the rest is off screen?
recipe browser bug.png
 

jopojelly

Retinazer
tModLoader
how come when i toggle it, it appears in the bottome right of the page i can only see the top corner and the rest is off screen?View attachment 295040
Not sure, the code should push it back, maybe a mod is messing with some values, you can test with just this mod enabled, see if it's still being weird. You might also have changed the config, you can reset that and see if it helps.
 

Mr Blaze

Official Terrarian
When I load my mods this message appears and when I click continue it disables Recipe Browser. Non of the other mods have this problem.
Maybe I broke something but I don't know. I'm new to modded.
I'm playing calamity mod with some other QoL mods.
Screenshot (3).png
 

jopojelly

Retinazer
tModLoader
When I load my mods this message appears and when I click continue it disables Recipe Browser. Non of the other mods have this problem.
Maybe I broke something but I don't know. I'm new to modded.
I'm playing calamity mod with some other QoL mods.
View attachment 299413
Delete "\Documents\My Games\Terraria\ModLoader\Mods\Cache\LootCache.json" and then try again.
 

FanaticMarioMan

Terrarian
Hi, this might be an extremely stupid question, but I've been doing the standard disable/enable mods troubleshooting and it isn't working. I'm also maybe just doing things wrong
1606629227770.png

Every single item shows No Paths Found for this Recipe/Item. This show no matter what other mods are enabled, even with no other mods enabled. From the videos this should show the crafting path, but nothing seems to show.

Am I using this mod wrong? I downloaded it today to try with some friends and want to make sure I know how to use it before telling my friends to get it.
 

jopojelly

Retinazer
tModLoader
Hi, this might be an extremely stupid question, but I've been doing the standard disable/enable mods troubleshooting and it isn't working. I'm also maybe just doing things wrong
View attachment 300117
Every single item shows No Paths Found for this Recipe/Item. This show no matter what other mods are enabled, even with no other mods enabled. From the videos this should show the crafting path, but nothing seems to show.

Am I using this mod wrong? I downloaded it today to try with some friends and want to make sure I know how to use it before telling my friends to get it.
What items are in your inventory? The craft paths only show what you can craft based on what tiles your player has encountered and which items you currently have.
 

FanaticMarioMan

Terrarian
What items are in your inventory? The craft paths only show what you can craft based on what tiles your player has encountered and which items you currently have.
Oh, so it isn't to show the crafting tree of an item? I think then I was just confused about what it did, because I did not have much in my inventory. So just to clarify, if you have all the required items to craft, then it will show there?
 

jopojelly

Retinazer
tModLoader
Oh, so it isn't to show the crafting tree of an item? I think then I was just confused about what it did, because I did not have much in my inventory. So just to clarify, if you have all the required items to craft, then it will show there?
yes, or items that could craft to craft the ingredients.
 
Top Bottom