• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. As of Oct 19 a new patch has been released. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Linux Steam Overlay rendering issues

Anthony 02

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Both
Operating System
Linux Other
Terraria Version
1.4.2.1
Controls Used
Keyboard/Mouse
System Specs:
OS: Arch Linux, kernel 5.11.14
CPU: Ryzen 7 Pro 4750U
GPU: Radeon RX Vega 7 (Integrated Graphics)
All packages are up-to-date (including Steam)

I recently encountered the following Steam overlay issue on my machine:
14-04-2021 1618388350.png

What this image doesn't convey is the flickering - those visual glitches change every frame, but the UI I need is never displayed.
Any popups that are part of Steam overlay are broken in the same way - such as achievements, friends online, etc.

As far as I can tell, this was caused by a very recent update to Terraria (probably 1.4.2).
Unfortunately, it may be very system-specific. Other people I know who also play Terraria on Arch Linux, with Ryzen integrated graphics do not have this issue.

While this isn't a very big deal, it makes it quite difficult to join a friend's multiplayer session via Steam. We've been using invites to get around it for now.


Other than that, the game runs very well. I really appreciate the work the team has done to bring Terraria to Linux and keep it well-maintained.
 

pacifi5t

Terrarian
This problem has nothing to do with integrated graphics. I too have faced it yesterday. I think something happened with Mesa drivers (don't forget, you're an Arch user)
My system:
OS: Arch Linux
Kernel: 5.12.2-Zen
CPU: Ryzen 5 1600
GPU: RX 570 4GB

Solution:
Install the amdgpu-pro-libgl from AUR. This is proprietary implementation of OpenGL drivers for AMD GPU's. Then open Terraria's properties in Steam and add in launch options
progl %command%

This works with the MangoHud as well:
1620902919080.png
 

Anthony 02

Terrarian
Sorry for the late reply, but I tried this, and it works perfectly!

I usually steer clear of the proprietary drivers, since they've given me trouble in the past, but this time everything seems fine. Thanks for bringing this to my attention.
 

pacifi5t

Terrarian
I'm glad I was able to help :)
Your system will still use the Mesa drivers by default. But when the app requires the proprietary drivers, you use that progl wrapper script. That's how drivers don't conflict with each other (e.g. OpenCL & Vulkan implementations do conflict)

As for Intel GPU's, try downgrading mesa package. If that doesn't work, I can't help you, sorry :(
 

Kazyo

Terrarian
Might be considered necroposting, but I'm having the same issue on Ubuntu. There aren't amdgpu-pro packages available as far as I can tell. The only thing available is the download on AMD's site, which contains many different .deb files with "libgl" and "pro", and an installer-- but I feel like the installer might mess up my existing mesa drivers?
 

Mirppc

Terrarian
I can confirm this is an issue on an RX 580 and RX570, as well as some intel IGPU's perticularly ones made after the patent agreement intel had with Nvidia expired and a new one was signed with AMD. This seems to lead to a MESA issue as there are no other drivers for the intel igpu.

I also refuse to install the amdgpu-pro driver package due to the downgrade in performance in many games and how it breaks proton.
 

Kazyo

Terrarian
Update: Reverting to the default mesa amdgpu packages, rather than those provided by kisak-mesa (as I had added previously, suggested by the proton-GE installation materials) fixed the issue.
 

Anthony 02

Terrarian
Glad to hear it, Zazyo. If you end up needing any help with the AMDGPU-PRO package, I think I understand it enough to help now, but if you found a way to fix the rendering issues without it, that's even better.

As for what you said Mirppc - I haven't noticed any difference in performance with the AMDGPU-PRO drivers, but I also don't like using them, since they're proprietary...
I haven't used Proton, but keep in mind that the AMDGPU-PRO drivers are set up now so that they aren't the default - you have to prepend the 'progl' command to the command which runs the game/application - so in theory they wouldn't affect any of your proton games unless you added 'progl' to the game's launch options.
 

Mirppc

Terrarian
The AMDGPP-pro drivers have a tendency to cause issues launching games like Doom 2016 and they also replace the vulkan libs which i found on Opensuse and PopOS to not be as performant as the normal amdgpu drivers. Another issue has been with steam not loading after installing the amdgpu-pro drivers, issues with OBS-studio capturing windows or games and more. In my experience the benifit of the AMDGPU-pro driver (openGL 4.6 and OCL) are not worth the downsides.

Still the issue with the intel igpu is indeed real and replicable, at least on the generation post the nvidia contract expiring and a new contract signed with AMD by intel.

So far the best work around has been turning off steamoverlay and alt-tabbing to get into steam to join a friend.
 

Psy-Q

Terrarian
I just popped in here to say that for some reason Streets of Rage 4 and other FNA games provoke the same problem for me. I've now tested with Rogue Legacy, Escape Goat 2, Full Metal Furies, same issue.

It seems this is a problem in Steam overlay's handling of point sprites as flibitijibibo writes. Also I found an issue about it on Valve's issue tracker for Steam.
 
Last edited:

Mirppc

Terrarian
I just popped in here to say that for some reason Streets of Rage 4 and other FNA games provoke the same problem for me. I've now tested with Rogue Legacy, Escape Goat 2, Full Metal Furies, same issue.

It seems this is a problem in Steam overlay's handling of point sprites as flibitijibibo writes. Also I found an issue about it on Valve's issue tracker for Steam.
That is interesting. Thank you for this update.
 

TheCOAdventurer

Terrarian
I am so glad in the first time for many months that other people have actually experienced the same issue. I made post a while back on this topic not having clue what the solution was either. Now that this issue is happening to more people hopefully a complete fix will be found soon. Also responding to @Kazyo I discovered the same solution with the kisak-mesa ppa and tried to remove it and the past that worked. Now when I try to remove those drivers the issue is no longer fixed and continues to persist within Terraria. If anyone has more details on solutions please let me know. I am eager to fix this and finally play Terraria on 1.4 on Linux. I found a temporary solution it seems that changing the launch options in steam to force FNA3D to use Vulkan fixes the issue. Launch option: "/gldevice:Vulkan".
 
Last edited:
Top Bottom