• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Terraria.exe will not download

TopherWing

Terrarian
When I connected back to the internet after a long while, I saw that terraria had a new small update that was required to play. But when I tried to install it, I got an error that said Terraria.exe was not found and it paused the update. It just disappeared, and when I ran the "Verify integrity of game files" under properties, it told me that two files were actually missing. I think the other one might be TerrariaOriginalBackup.exe because I couldn't find that either. I checked my AVG Antivirus Free quarantine section to see if it had detected Terraria.exe as some sort of malware but it wasn't there either. I am now at a point where I have backed up my world and character files, and reinstalled the game twice now. The first time, it said (and I checked) that there was no Terraria.exe and that there was a drive disk error when on the installing section. The second time I deleted all of the Terraria files that were still even there and it did the same thing. Before the second time though, I found a crashlog file and it said that there was problems with Microsoft Xna Framework, and I saw in a post somewhere that I should reinstall that too so I tried that and it still isn't working.
I've included some images to help visualize my problem.
terrariaDownloadPaused.PNG
TerrariaDiskDriveError.PNG

Any help with this would be amazing. Thank you.
 

darthmorf

Moderator
Staff member
Moderator
This seems like an issue with Steam itself, rather than Terraria. I would recomend contacting steam support.
 
Top Bottom