• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Tool TML GOG Patcher [ABANDONED]

Status
Not open for further replies.

Jeckel

Terrarian
I came across a bug with blizzard weather. I am unable to move or do anything and once it is over everything is back to normal. I had all mods disabled except for cheat sheet so I could get to a frozen biome faster. It is either a problem with the gog patcher or the mod loader and I posted the problem over there also.

I'm sorry you are having issues, but it is extremely unlikely that it is an issue caused by the patcher, which, if something was wrong, would most likely cause a lot of wide ranging issues if the game even ran at all. Hopefully someone will be able to help you through your post on the TML thread. :)
 

Cyra

Terrarian
1- What ZIP file? it downloads a .dat file
2- I cannot press the 'installation' button
 

Attachments

  • Captura de pantalla 2017-01-18 22.14.01.png
    Captura de pantalla 2017-01-18 22.14.01.png
    40.3 KB · Views: 328

Mistoffelees

Terrarian
Heads up, Jeckel! Gitlabs is down, possibly with permanent widespread data loss:

https://www.theregister.co.uk/2017/02/01/gitlab_data_loss/

I can't download your latest .ZIP for GOG tModLoader. Can you post an alternate download link? The patch files themselves seem to work, at least as of last night (same time I learned I can't download the patcher itself...)

I hope to God you back everything up! This is too good to lose!
 

Mistoffelees

Terrarian
Good news, Gitlab is back and I was able to download the .EXE file (in the .ZIP). I don't know if it is version 1.1.1.0, though, and I can't check it right now (I am not at home).
 

aat

Terrarian
GOG-16 version 1.3.4.4
Linux parch 0.9.1.0

After I patch the game, Terraria doesn't start:
After the loading titles, Terraria is stuck with a black screen and hangs
 

Joelixny

Terrarian
I'm trying to patch the Linux GOG version of the game, however it is running on a headless server (No xorg, only terminal) so I can't run the linux patcher. I have the filesystem network mounted on a windows machine, and the windows patcher will recognize the installation folder from the linux machine and see it as a valid directory, but it won't recognize the "TMLGOGPatch_0.9.1.0_Linux.dat" as a valid patch, as it isn't listed on "Terraria" or "TML" dropdown menu. I'm attaching an image showing this below.
PSnWY.png


Am I supposed to use the Windows patch even though I'm trying to patch the Linux version? Renaming the file to "TMLGOGPatch_0.9.1.0_Windows.dat" still doesn't make it available on the list.
Some pointers would be greatly appreciated.
 

Jeckel

Terrarian
Sorry for the late responses. I took a few weeks off to handle some RL stuff and to take a bit of vacation. Things ran a little longer than I planned, but I'm back now. :)

Heads up, Jeckel! Gitlabs is down, possibly with permanent widespread data loss:

https://www.theregister.co.uk/2017/02/01/gitlab_data_loss/

I can't download your latest .ZIP for GOG tModLoader. Can you post an alternate download link? The patch files themselves seem to work, at least as of last night (same time I learned I can't download the patcher itself...)

I hope to God you back everything up! This is too good to lose!
Good news, Gitlab is back and I was able to download the .EXE file (in the .ZIP). I don't know if it is version 1.1.1.0, though, and I can't check it right now (I am not at home).

Figures, I leave for a bit and that is when gitlab takes a dump, lol. I've done a quick check and everything seems to be in order now that they are back up.

Can you help me?
My file's hash doesn't match. Why?:merchantcry:;(:dryadcry::nursesad:~:sigh:`-_-

Are you using the Russian language version of Terraria? If so, that is the reason it doesn't work.

GOG-16 version 1.3.4.4
Linux parch 0.9.1.0

After I patch the game, Terraria doesn't start:
After the loading titles, Terraria is stuck with a black screen and hangs

Hmm, if the patcher didn't throw any errors while patching, then I'm not sure what the problem could be.

what url please explain, and where to get

Appologies, but I'm not sure what your question is. The download links and directions are in the first post of this thread. If you could clarify your question, I'll be happy to try and help.

I'm trying to patch the Linux GOG version of the game, however it is running on a headless server (No xorg, only terminal) so I can't run the linux patcher. I have the filesystem network mounted on a windows machine, and the windows patcher will recognize the installation folder from the linux machine and see it as a valid directory, but it won't recognize the "TMLGOGPatch_0.9.1.0_Linux.dat" as a valid patch, as it isn't listed on "Terraria" or "TML" dropdown menu. I'm attaching an image showing this below.
PSnWY.png


Am I supposed to use the Windows patch even though I'm trying to patch the Linux version? Renaming the file to "TMLGOGPatch_0.9.1.0_Windows.dat" still doesn't make it available on the list.
Some pointers would be greatly appreciated.

This brings up a use case scenario I hadn't considered before. If you are patching the linux version of the game, then yes you should use the linux patch, but the windows version of the patcher won't see the linux patches. My advice would be to download the linux version of the patcher to your windows machine, it should theoretically run on windows, and try using it to patch linux terraria with the linux patch. I will look into this when I get some free time in the coming week and see if I can work out exactly what steps should solve your issue.

why cant it be on terraria 1.3.1

Unfortunately, I don't have the GOG installers for versions before 1.3.2.1, so I can't currently make patches for them.
 

Jeckel

Terrarian
no, I use original version

Hmm, that is strange. A freshly installed Terraria.exe for version 1.3.4.4 should have a hash of E723824766898DC294C098E3732BD377D425C86D51D613567432E45D4E0D9287. Yours is showing a different hash, one that begins with 5080A8FD.

I see you have tModLoaderInstaller file in your directory, which is the program for installing TML on the Steam version of the game, but doesn't work with the GOG version of the game. If you ran that installer, it might have corrupted your Terraria files.

My only suggestion at this point would be reinstalling Terraria from the GOG installer and then trying the patcher again. I checked the fresh installs on both my Win10 and Win7 machines and the hash for Terraria.exe comes back as the E7238247 one.
 

Jeckel

Terrarian
Я уже пробовал, что даже снимают панель управления террарии
Translation: I have already tried, that even remove the control panel of the terraria

Then I'm afraid I'm out of ideas. I don't know why your GOG installer isn't installing the same Terraria files that mine does, but if the clean install of GOG Terraria doesn't match the hash that my patcher is looking for, then patching it with TML simply won't work. If deleting your Terraria directory, reinstalling GOG Terraria, and patching doesn't work, then I'm afraid you are out of luck.

There might be one thing left we can try, but you will have to send me a Private Message so we can discuss it.
 

Drkitten

Terrarian
fresh gog install sound works perfect but if i patch it then no sound at all and the in game sound slider says 0% i changed it and the music slider resets to 0% on clicking anywhere and the other changes (ambient and game) do not save on sound menu close .. so i went into the games config folder and put it to 50% and after relaunching it now says 5000% and acts identical with no sound at all. this is no mods windows 10. checked that the game is not muted in anyway. reinstalled tried again its the patch causing he sound blackout.

'update' ~ two terraria exe in terraria main directory "Terraria.exe" "Terraria_1.3.4.4.exe" one works flawless no mod menu.. one has mod menu loads silently.. now its suddenly working with sound.. mby alt tab fixed it ?? o_O wtf is going on. lool more testing ... broken again.. fixed again.. figuring i out slowly.. is not alt tab.. its either screen resolution or need o run original terraria in-between attempts.. =( its running flawlessly now without explanation...

possible fixes: running original terraria once.
changing screen resolution and window/border + repeat running original terraria
set to compatible mode windows 7 for both exe

however i can now set it to full screen and bot it so its most likley compat mode and or running old terraria exe

Code:
================================================================================
Installation Started [2017/03/14 16:45:14:5899]
--------------------------------------------------------------------------------
Platform: Windows (Microsoft Windows NT 6.2.9200.0)

Patch: Name:TMLGOGPatch_0.9.1.0_Windows.dat | Terraria:1.3.4.4 | TML:0.9.1.0

Install Path: C:\GOG Games\Terraria\
Client: Install:True | Overwrite:True | Input:Terraria.exe | Output:Terraria.exe
Server: Install:True | Overwrite:True | Input:TerrariaServer.exe | Output:TerrariaServer.exe
Dependencies: Install:True
================================================================================

--------------------------------------------------------------------------------
Installing Client Patch [2017/03/14 16:45:14:6837]
--------------------------------------------------------------------------------

Finding Required Terraria.exe File...
-Found
Checking Terraria.exe Version (1.3.4.4)...
-Matched
Checking Terraria.exe Hash (E723824766898DC294C098E3732BD377D425C86D51D613567432E45D4E0D9287)...
-Matched
Finding Terraria.exe Backup File (Terraria_1.3.4.4.exe)...
-NOT Found
-Creating Terraria.exe Backup File (Terraria_1.3.4.4.exe)...
--The backup file was created successfully.
Creating Patched Terraria.exe File (Terraria.exe)...
-The patch was successfully created.
-Verifying Patched Terraria.exe File (Terraria.exe)...
--The patch was successfully applied.

--------------------------------------------------------------------------------
Installing Server Patch [2017/03/14 16:45:16:5118]
--------------------------------------------------------------------------------

Finding Required TerrariaServer.exe File...
-Found
Checking TerrariaServer.exe Version (1.3.4.4)...
-Matched
Checking TerrariaServer.exe Hash (D045DB95BE82BE9F5969D942933CFF8F09669840A126419A2933CD0FF42252C6)...
-Matched
Finding TerrariaServer.exe Backup File (TerrariaServer_1.3.4.4.exe)...
-NOT Found
-Creating TerrariaServer.exe Backup File (TerrariaServer_1.3.4.4.exe)...
--The backup file was created successfully.
Creating Patched TerrariaServer.exe File (TerrariaServer.exe)...
-The patch was successfully created.
-Verifying Patched TerrariaServer.exe File (TerrariaServer.exe)...
--The patch was successfully applied.

--------------------------------------------------------------------------------
Installing Dependencies [2017/03/14 16:45:18:2931]
--------------------------------------------------------------------------------

Ensuring C:/GOG Games/Terraria/ModCompile/ Directory...
-NOT Found
-The directory has been created.
Ensuring FNA.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring Microsoft.CodeAnalysis.CSharp.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring Microsoft.CodeAnalysis.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring Mono.Cecil.Pdb.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring RoslynWrapper.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring System.Reflection.Metadata.dll Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring tModLoaderMac.exe Dependency...
-NOT Found
-The dependency was copied to the target location.
Ensuring start-tModLoaderServer.bat Dependency...
-NOT Found
-The dependency was copied to the target location.

================================================================================
Installation Stopped [2017/03/14 16:45:18:9806]
--------------------------------------------------------------------------------
Elapsed Time [00:00:00:04.39062]
================================================================================
 
Last edited:
Status
Not open for further replies.
Top Bottom