• PC NEWS: 1.4.2.3 update is out! More info here. Report bugs here
  • CONSOLE 1.4 NEWS: The current plan is to have Terraria: Journey's End out for Xbox and PlayStation in Q3 2021 (Jul-Sep). Switch will follow shortly afterwards. More info here. Stay up to date with console news here
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Tool TML GOG Patcher [ABANDONED]

Status
Not open for further replies.

Jeckel

Terrarian
The same situation
[doublepost=1477813649,1477813217][/doublepost]Wait a minute
So,i download a steam veriosn of terraria and install tml in steam's terraria folder and its working!
[doublepost=1477813728][/doublepost]But i still need a way to play with TML on russian version of Terraria
I think,after few experiments i will find it(I hope)

Hmm, I'm not sure what the problem could be. I just redownloaded the released version of the app and the latest patch and it worked without issue. The part where it says that the hash didn't match is basically saying that the Terraria.exe isn't the vanilla one that the GOG installer creates.

At least you got your steam version up and running.

TML is built against the english versions of the game, so I'm not sure if there is any way to get it working with the russian versions.

I'm slowly working on the next version of the app and it will include more debugging information so that problems like this will be easier to diagnose in the future.
 

Lithalroden

Terrarian
i have mac terraria 1.3.0.8 on gog and the patch files aren't working since theres only up till 1.3.2.1
how can i get terraria 1.3.3.3 on mac gog?
 

Jeckel

Terrarian
i have mac terraria 1.3.0.8 on gog and the patch files aren't working since theres only up till 1.3.2.1
how can i get terraria 1.3.3.3 on mac gog?

Once you've bought Terraria from GOG, then you can download all future versions from there. So go to the GOG site, log in with your account, and download the lasted mac install file.
 

fogofir

Terrarian
didnt worked for me




my version is 1.3.3.3 and says
Finding Required Terraria.exe File...
-Found
Checking Terraria.exe Version (1.3.3.3)...
-NOT Matched
Checking Terraria.exe Hash (C85139DFA57AED4B664CE8F4E26D4332393FEEAE5852F725D605FE0E9D3E347D)...
-NOT Matched
 

John Bernard

Terrarian
my version is 1.3.3.3 and says
Finding Required Terraria.exe File...
-Found
Checking Terraria.exe Version (1.3.3.3)...
-NOT Matched
Checking Terraria.exe Hash (C85139DFA57AED4B664CE8F4E26D4332393FEEAE5852F725D605FE0E9D3E347D)...
-NOT Matched[/QUOTE]

fogofir
what is your platform and what did you do excatly and maybe i can help
[doublepost=1478182411,1478182362][/doublepost]
Once you've bought Terraria from GOG, then you can download all future versions from there. So go to the GOG site, log in with your account, and download the lasted mac install file.

Jackel
Did you download the GOG Galaxy client for the Mac? If so then go back to the Library and either look to see if auto patching is enabled or the option to download it is available. THats how i do it and i run my client on both pc and mac and works like a charm.
 

Jeckel

Terrarian
Sorry, wasn't feeling very well yesterday and ended up spending the day in bed and didn't get around to checking the forum.

didnt worked for me

my version is 1.3.3.3 and says
Finding Required Terraria.exe File...
-Found
Checking Terraria.exe Version (1.3.3.3)...
-NOT Matched
Checking Terraria.exe Hash (C85139DFA57AED4B664CE8F4E26D4332393FEEAE5852F725D605FE0E9D3E347D)...
-NOT Matched

When it checks the version of Terraria.exe, it is saying that it isn't 1.3.3.3. Give me a screenshot of the application or copy/paste all the text from the log window and I might be able to help more.

Did you download the GOG Galaxy client for the Mac? If so then go back to the Library and either look to see if auto patching is enabled or the option to download it is available. THats how i do it and i run my client on both pc and mac and works like a charm.

I've never installed GOG's client, I don't to like clients, but are you saying that I could download the mac terraria 1.3.0.8 .pkg file from galaxy?
 

John Bernard

Terrarian
Sorry, wasn't feeling very well yesterday and ended up spending the day in bed and didn't get around to checking the forum.



When it checks the version of Terraria.exe, it is saying that it isn't 1.3.3.3. Give me a screenshot of the application or copy/paste all the text from the log window and I might be able to help more.



I've never installed GOG's client, I don't to like clients, but are you saying that I could download the mac terraria 1.3.0.8 .pkg file from galaxy?

You should be able to go to gog.com and under your account download the updated pkg. I understand about the client.
 

Jeckel

Terrarian
You should be able to go to gog.com and under your account download the updated pkg. I understand about the client.

Unfortunately, gog's website only offers installers for the most recent release version. I didn't plan ahead and only downloaded the mac .pkg and linux .sh files starting at Terraria 1.3.2.1, which is why I haven't offered patch files for versions before that. If I can ever get .pkg and .sh files for earlier versions, then I'll offer patches for those versions as well. I was hoping galaxy would offer that, but as I understand it only offers a few versions back from the current one.

Anyway, thanks for the info. :)
 

John Bernard

Terrarian
Jeckel,
Sorry for the late post. Somehow this thread dropped off my radar

Unfortunately the only way to get the older version is to use the Client
 

DetonexGamer

Terrarian
Can someone help me with this?
 

Attachments

  • .png
    .png
    27 KB · Views: 789

Jeckel

Terrarian
Can someone help me with this?

It appears that you have Terraria version 1.3.3.0 and are trying to install the patch for Terraria version 1.3.3.3. You will have to update to a newer version of Terraria as there was no TML version for 1.3.3.0.
 

Jeckel

Terrarian
I am on Windows and when I'm in the patcher the install button is grey and I cannot click it.
View attachment 150267

It looks like you haven't downloaded any of the patch files from the opening post. You have to download the patch file that matches the Terraria version that you are trying to install TML for. Unfortunately, there is no TML version for Terraria 1.3.3.0. You will have to update your game to at least Terraria 1.3.3.1 before you can patch it.
 

Jeckel

Terrarian
could I use a different version of terraria (older) to the same effect?

The only older version that is supported by this application is Terraria 1.3.2.1.

If you go to the TML thread and scroll down to the Download area of the opening post and open the Past Version Downloads spoiler, I think there is also a zip that will let you manually patch Terraria 1.3.1.1, but that is as far back as I've been supporting TML for GOG.
 

Jeckel

Terrarian
Alright, TML 0.9.0.2 for Terraria 1.3.4.4 is finally here.

TML GOG Patcher v1.1.1.0

First things first. I have released a new version of TML GOG Patcher, v1.1.1.0, so everyone redownload the application from the opening post as it will be required to install the new TML GOG patch. The changes in the new version of the TML GOG Patcher application are as follows:
  • The biggest change is that the patch files will now come with a .dat extension instead of .zip. This should help remove the confusion where some think that the patch should be unzipped when it shouldn't. Patch files in the application's patches directory with the .zip extension will automatically be renamed to have the .dat extension.
  • The Mac version of the application will now default to looking in /Applications for Terraria related folders instead of /Documents.
  • I improved the log output slightly to help diagnose problems easier, though it still needs some more work.
  • There were also a few other minor fixes, such as the application title now properly says TML GOG Patcher instead of TML GOG Installer, a missing url was fixed in the about dialog, and the Download Patch dialog has been disabled on Mac since it doesn't yet work on that platform.
Once you have downloaded the new version of the application, you can download the TMLGOGPatch_0.9.0.2_Windows.dat, TMLGOGPatch_0.9.0.2_Mac.dat, or TMLGOGPatch_0.9.0.2_Linux.dat file from the opening post and install TML for GOG Terraria 1.3.4.4.

Mac and Linux Warning

My computer is on its last leg and I wasn't able to test the new application version on Mac or Linux as my comp keeps crashing when I have the virtual machine running for more than a minute or so. It was all I could do to install Terraria on it to make the Mac and Linux patch dat files. I'm getting a new comp for xmas, so this won't be a problem for much longer, but I doubt any of you wanted to wait until after xmas to get down on some TML Terraria. If Mac or Linux users run into any issues -- there shouldn't be any new issues, but you never know -- then just let me know and I'll see if I can resolve them.

New TML GOG Feature

TML has shown some love to GOG modders with this latest version and we are now able to publish our mods. You still need a Steam account, but, as far as I'm aware, you don't have to own Terraria on it.

To publish a mod, you will have to go to http://javid.ddns.net/tModLoader/register.php, login with your Steam account, and it will generate a passphrase and show you your Steam ID. Then you will open the Terraria/ModLoader/config.json file with a text editor, enter your Steam ID as the value to SteamID64 element, and the passphrase as the value to the ModBrowserPassphrase element. You will then be able to publish, manage, and unpublish mods just like the Steam Terraria users. If you have any questions, please feel free to ask and I will do my best to help out.
 
Status
Not open for further replies.
Top Bottom