• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

TModLoader Error

Hermit Turtle

Terrarian
Is there anyone who has an idea what causes this issue, because of this I cannot start terraria through the TModLoader x64. I have installed it correctly (as per multiple TModLoader installation videos) and Terraria does start normally but I get this whn using the TModLoader launcher.

I have searched for the House_Banner_0.xnb file but have only been able to find House_Banner.xnb, the _0 one doesn't seem to exist nor was it in the TModLoader zip file.

Edit: I've copied the House_Banner.xnb file and renamed it to House_Banner_0.xnb which changed the error to House_Banner_1.xnb after which I copied and name changed it again to House_Banner_1.xnb and now it shows an error for MiniMapFrame.xnb. Does this mean I've downloaded an incomplete Zip or is there something else behind this error?
 

Attachments

Last edited:

ClydeeDog

Terrarian
Is there anyone who has an idea what causes this issue, because of this I cannot start terraria through the TModLoader x64. I have installed it correctly (as per multiple TModLoader installation videos) and Terraria does start normally but I get this whn using the TModLoader launcher.

I have searched for the House_Banner_0.xnb file but have only been able to find House_Banner.xnb, the _0 one doesn't seem to exist nor was it in the TModLoader zip file.

Edit: I've copied the House_Banner.xnb file and renamed it to House_Banner_0.xnb which changed the error to House_Banner_1.xnb after which I copied and name changed it again to House_Banner_1.xnb and now it shows an error for MiniMapFrame.xnb. Does this mean I've downloaded an incomplete Zip or is there something else behind this error?
The same thing happened to us yesterday as well (forgive me, I'm a mom writing this on behalf of my 10 yo son). We are getting the same message:
Terraria: Error (tModLoader v0.11.6.2)

Microsoft.Xna.Framework.Content.ContentLoadException: Could not load asset Images/UI/House_Banner_0! Error: The content file was not found. --->

I followed the path to the Images folder in the Terraria app and could see the file (House_Banner_0.xnb) there, but I can't get Terraria to run (launching from Steam). Can anyone help please? I know very little about how computers actually work (where files actually are, types of files, etc). Thank you!!
 

Uhhyaahso

Terrarian
So I have found the solution and its pretty simple, so you might already know it. Its because the version we have/had is not the newest one, even though its listed as it is on the tmod front page. Go to tModLoader/tModLoader and download the newest version (it will have mac/Linux/windows). After that extract the folder and move/copy it to your main terraria folder, it will most likely want to replace certain files so its a good idea to make a backup of your original terraria folder. You will then have to run the tModLoader application to play terraria with the tmod loader. Hope this helps a little bit
 

Jofairden

Duke Fishron
tModLoader
The forum thread will usually be behind since blushie isnt around often. The best place to use is either steam (which should auto update) and the github releases. You also shouldnt actually install into the Terraria folder, instead make a tModLoader folder alongside the Terraria folder if you want to install manually.

(As for the error: that is if you dont have the contents folder for tML and you updated Terraria to 1.4, you must have a 0.11.7+ TML install)
 
Top Bottom