tModLoader Specific Mod World Gen Error

lil_ch3f

Terrarian
I have been using tmodloader with calamity for about a week. I have not had any issues until i decided to make a new world today. I am not able to create worlds while i have the calamity mod active. I've seen other people with the same issue as me. some of them had different mods that were having the error, but it mostly seemed the same. There have been some post about the error, but most led to dead ends for me, so here is the error message I got.

A problem was encountered during world generation CalamityDungeonBiomeChests System.NullReferenceException: Object reference not set to an instance of an object. at CalamityMod.World.MiscWorldgenRoutines.GenerateBiomeChests(GenerationProgress progress, GameConfiguration config) in CalamityMod\World\MiscWorldgenRoutines.cs:line 30 at Terraria.GameContent.Generation.PassLegacy.ApplyPass(GenerationProgress progress, GameConfiguration configuration) in tModLoader\Terraria\GameContent\Generation\PassLegacy.cs:line 226 at Terraria.WorldBuilding.WorldGenerator.GenerateWorld(GenerationProgress progress) in tModLoader\Terraria\WorldBuilding\WorldGenerator.cs:line 30

The error only seems to happen when i have the calamity mod active. I am on Calamity version 2.0.0.3, tModLoader Version 2022.7.58.4, and terraria version 1.4.3.6. It doesn't happen with any other mod or combination of mods. It only started happening today even though I have created a world before. Worlds that have already been created are still playable and run perfectly. The world will load to about half way until it starts creating the dungeon, and then the error message will pop up, clicking continue will result in the world not being created and being sent back to the title screen. I have tried at least 20 times to create a world.

I have tried uninstalled the calamity mod and reinstalled it. I have tried uninstalling both tmodloader and terraria but that did not work. I have made sure that i did not have any other betas or previews active. I only have calamity mod installed (no other mods) . I've verified my file integrity.

Also I have read on a forum post that you can get around this by migrating a vanilla world to tModLoader. I could launch the world and the calamity mod worked, but none of the calamity specific structures generated on the world, so it didn't work.

I think there is an error that involves the biome chests that spawn in the dungeon to fail to load, but i have no clue how to fix it and every other forum post about it has led to a dead end for me.
Thank's for any info that you may have.
 
Last edited:

Chelik12l

Terrarian
i have the same problem and it also appeared only today
i think thats because tmodloader got an update today
 
Last edited:

DylPickl3

Terrarian
i was olaying the Calamity mod perfectly and still can play well on other worlds but when i want to generate a new world it says Calamity Dungeon Chest Error and i cant create a new workd to play on with the calamity mod
 

Mega456Pikachu

Terrarian
one thing i did that kinda fixed it was to switch to 1.3, install calamity and make the world on there, and switch back. hope this helps.
 

stu4

Terrarian
Are there any publicly available untouched maps that can be downloaded for Calamity (with the calamity content) to get around the world gen step? Or would anyone be willing to upload one?
 

Jonbabs

Terrarian
I believe that this is due to small worlds not being supported by Calamity anymore. (Edit: Nvm, tried all world size options and the same error pops up. Got no idea what it is.)
 

Jynbr

Terrarian
I installed the world gen previewer mod by jopojelly, and used it to skip/delete the step that adds the calamity dungeon chest. No idea what the cause is, but I hope this "fix" helps.
 

ssccaa

Terrarian
There is a calamity world gen fix mod (search 'calamity' on the tmodloader's mod list and it should be there)
 

futility

Terrarian
calamityfixbugastralbiomechest.png
download this lol and it fixes it
 
Top Bottom