tModLoader Vanilla Tweaks + other little tweak mods

Also, how does the table of contents' links work? What did you do to make those links go to certain parts of the post?
 
Pharaoh's Clothesare now an early-game summoner set.
  • Mask gives 3 defense and +5% minion damage.
  • Robe gives 4 defense and +5% minion damage.
  • Full set gives +1 minion slot.
thats it this is amazing, this is all i needed to have. but why isn't this in vanilla?
 
Hey, I could use some help.

I'm looking to get treasure bags to drop in normal mode via BossExpertise (playing with some friends who aren't very experienced with video games).

I have tmodloader running on a remote linux box. When I try to change the setting in-game, it says that only the owner can do so.

I cannot find the settings .json, and I assume I have to create one. That's where I'm stuck. Any help would be appreciated.
 
Hey, I could use some help.

I'm looking to get treasure bags to drop in normal mode via BossExpertise (playing with some friends who aren't very experienced with video games).

I have tmodloader running on a remote linux box. When I try to change the setting in-game, it says that only the owner can do so.

I cannot find the settings .json, and I assume I have to create one. That's where I'm stuck. Any help would be appreciated.
You can't change it in-game if it is a dedicated server since your player number doesn't match the servers.
stop the server and load up the TModloader and change it from the "Mods" menu but,
It should be creating them automatically like it does on windows, that is handled by the API of TModloader, does TModloader have proper permissions?
Here is my json, report back if you fix it.
 

Attachments

  • BossExpertise_Config.json
    132 bytes · Views: 99
Here is my json, report back if you fix it.

Thanks for the reply. I popped that .json into .local/share/Terraria/ModLoader/Mods alongisde BossExpertise.tmod.

Then, I started the server the same as I always do, './tModLoaderServer'.

From what I can tell, nothing changed - - the radio button for treasure bags in normal mode isn't ticked, and if I try to change it, it still reads "Only the server owner can change the settings."


I took a look at the folder structure in my windows install. My linux install was missing the 'Mod Configs' folder. I made it and I put your supplied .json in there, and it worked like a charm.

Thanks much!
 
Last edited:
I have ported all of gardenapple's mods but Miscellania, and BossExpertise to the alpha 1.4.

I will work on them shortly.
I have to more research about how to use the mod browser and stuff once I figure that out I'll start uploading them to be more rigorously tested.

UPDATE: I published the ones I have done, when I get more time I will finish Miscellania, Journey Mode Borked the crap out of BossExpertise.
Report bugs to me not GardenApple.
Remember TModLoader is in Alpha.

Update 2: disabled tweaks(you can renable them to back to 1.3 versions of those items.) that change items that were reworked in 1.4(cactus gladiator obsidian). I fixed a mistake that I made on meteor armor(applied to the wrong damage type).

Also how many of you use the /expert command and button? That is the only thing broken right now in my BossExpertise.
 
Last edited:
Hey everybody, I've updated the original post: fixed broken images, added links to Steam Workshop for 1.4 content.

Also, I'm really happy about Re-Logic introducing some of my Vanilla Tweaks changes into 1.4, even though it's most likely just a coincidence. I've marked those features with italics, as Pop000100 removed them from VanillaTweaks for 1.4, but a lot of you are probably still playing 1.3, so there's that.
 
Hey everybody, I've updated the original post: fixed broken images, added links to Steam Workshop for 1.4 content.

Also, I'm really happy about Re-Logic introducing some of my Vanilla Tweaks changes into 1.4, even though it's most likely just a coincidence. I've marked those features with italics, as Pop000100 removed them from VanillaTweaks for 1.4, but a lot of you are probably still playing 1.3, so there's that.
Thank you!
 
Seems that this mod has issues with recipe broswer, I reported it to there and I wanted to do the same here as its similar issue. Here's an log. Hope you can fix it soon!
 

Attachments

  • client[1].log
    150.7 KB · Views: 73
The setting "Display World Tooltips" for some reason disables time acceleration when sleeping. It works perfectly fine when I disable that setting so it has to be that
 
Back
Top Bottom