1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

tAPI [Discontinued] tAPI - A Mod To Make Mods

Discussion in 'Released' started by Yoraiz0r, Oct 14, 2014.

Thread Status:
Not open for further replies.
Thread was lock by: Tunnel King
Reason: discontinued prior to 1.3 release
Lock date: 20:26 04-08-2016
  1. The Dark One

    The Dark One Eye of Cthulhu

    I wasn't gonna, I don't even know how.
     
  2. FiendishCatz

    FiendishCatz Eye of Cthulhu

    How can I uninstall I.3? '~'
     
  3. Peeper008

    Peeper008 Terrarian

    Really? Darn, oh well, thanks for telling me.. I would have just been messing around with all the files :p
     
  4. chexo4

    chexo4 Terrarian

    Cool! Any plans to support Mac OS X when you update to 1.3?
     
  5. KilljoyThePsycho

    KilljoyThePsycho Official Terrarian

    can someone explain why when I run TAPI it makes the sound where u put ur mouse over the icon, then stops running it?
    ;(
     
  6. ReaL

    ReaL Terrarian

    happens to me too
     
  7. KilljoyThePsycho

    KilljoyThePsycho Official Terrarian

    [/QUOTE]
    you need Tmodloader for the 1.3 update! unless u have a back-up of 1.2.4
     
  8. Jiggly Dragon

    Jiggly Dragon Terrarian

    my tApi wont launch, it just runs in the background for a bit, then stops
    --- Double Post Merged, Sep 3, 2015, Original Post Date: Sep 3, 2015 ---
    you need Tmodloader for the 1.3 update! unless u have a back-up of 1.2.4[/QUOTE]
    how do you get a tmod loader
     
  9. tonfa

    tonfa Terrarian

    hello i tAPI is insta crashing, i mean when i try to launch it i hear a little "bloop" terraria noise then nothing, if i open my task manager tAPI is popping then vanishing, do any of you know how i might fix this problem?
     
  10. Kitsune11

    Kitsune11 Terrarian

    *sigh*
    For the People who can't read the first page:
    tAPI works for Terraria Version 1.2.4. You are probably running Terraria Version 1.3 or later. Please take the time to read the OP next time. This question is getting rather old, really fast and is being asked again and again each page.
     
    DragonSoulSong likes this.
  11. tonfa

    tonfa Terrarian

    Sorry i wasn't accurate in my statement, I first downloaded and installed the Gamelaucher program, then i installed the tAPI, it's true that it's terraria1.3, the question now is,
    How do i downgrade to 1.2.4 ? i rather want to use legal mean, i didn't buy the game to use a cracked version.
     
  12. Sapharan

    Sapharan Golem

    You can't. The only thing that could do that was Gamelauncher, but right the option is not available.
     
  13. tonfa

    tonfa Terrarian

    Well thanks for your fast reply man , and it's okay i got that to work, don't ask me how :p
     
  14. ReaL

    ReaL Terrarian

    How to download it it just hearing a noise then it crashed how do i fix it
     
  15. selectivemadcop

    selectivemadcop Official Terrarian

    is there a tapi version for 1.2.2?
    if there is what is it?
     
  16. Athentos

    Athentos Terrarian

    I keep getting this message in my logs every time I try and run tAPI
    Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Images\CraftButton". File not found.
    at ContentManager.OpenStream(String assetName)
    at ContentManager.ReadAsset(String assetName, Action`1 recordDisposableObject)
    at ContentManager.Load(String assetName)
    at Main.LoadContent()
    at Game.Initialize()
    at Main.Initialize()
    at Game.RunGame(Boolean useBlockingRun)
    at Program.Main(String[] args)
    at Program.Main(String[] args)
    System.IO.FileNotFoundException: Error loading "Content\Images\CraftButton.xnb". File not found.
    at TitleContainer.OpenStream(String name)
    at ContentManager.OpenStream(String assetName)

    It doesn't even open and it just instantly closes. Can someone please help me out on this?
     
  17. selectivemadcop

    selectivemadcop Official Terrarian

    plz if this updates to 1.3 I swear I will stop using tmodloader
     
  18. Flaming Flamingo

    Flaming Flamingo Terrarian

    Operating System: Windows 10
    Steam or GOG: Steam
    Terraria Version: 1.3.0.8 (Current)
    TAPI installs fine and then i run it but when i check mods there is no file path and TAPI did not make any folders in the My Games folder if i make the file path myself it still wont work.

    I just tried removing everything and reinstalling but it wont even start up now from gamelauncher

    if anyone has any ideas it would help me a lot thanks.
     
  19. MarioKart7z

    MarioKart7z Plantera

    That's your problem. tAPI isn't, and never will be updated for 1.3
     
    DragonSoulSong likes this.
  20. Flaming Flamingo

    Flaming Flamingo Terrarian

    thanks for letting me know i posted about this a few months ago but got no good answer
     
Thread Status:
Not open for further replies.