Standalone DynamicSpriteFontGenerator 0.4 (Generate fonts without XNA Game Studio)

Discussion in 'Released' started by mistzzt, Apr 28, 2017.

  1. mistzzt

    mistzzt Terrarian

    Attached Files:

  2. jopojelly

    jopojelly Retinazer

    Tried it out, got an error:

    [​IMG]
     
  3. mistzzt

    mistzzt Terrarian

    Seems you had installed XNA Game Studio, And the program attempted to load the vanilla DLL.
    I used a modified Microsoft.Xna.Framework.Content.Pipeline.dll.
    Please let the program load the dll in 7z.
     
  4. jopojelly

    jopojelly Retinazer

    Makes sense. Someone else will have to try it on a computer without XNA installed.

    I'm not sure how to force the program to load the dll in the same folder as it though.
     
  5. mistzzt

    mistzzt Terrarian

    I'll rewrite the program using reflection for solving this problem if I have time.
     
  6. jopojelly

    jopojelly Retinazer

    It's not a big deal. I already have XNA installed, so I can just build an xna content project to make a dynamicspritefont. I was just curious to see how much easier this would be.
     
  7. mistzzt

    mistzzt Terrarian

    Just solved this problem in version 0.5

    :D
     
  8. jopojelly

    jopojelly Retinazer

    Just tried it again with the new version, ran into another problem:

    Code:
    Description file detected: 1
    * ExampleFont.dynamicfont
    
    Start loading description file: ExampleFont.dynamicfont ..Done!
    Start compiling font.
    Unhandled Exception: System.NotImplementedException: The method or operation is not implemented.
       at DynamicFontGenerator.DfgContext.get_Logger() in C:\Users\zitwa\Source\Repos\DynamicFontGenerator\DynamicFontGenerator\DfgContext.cs:line 11
       at Microsoft.Xna.Framework.Content.Pipeline.Processors.FontDescriptionProcessor.Process(FontDescription input, ContentProcessorContext context)
       at ReLogic.Content.Pipeline.DynamicFontProcessor.Process(DynamicFontDescription input, ContentProcessorContext context)
       at DynamicFontGenerator.Generator.CompileFonts() in C:\Users\zitwa\Source\Repos\DynamicFontGenerator\DynamicFontGenerator\Generator.cs:line 83
       at DynamicFontGenerator.Generator.Initialize() in C:\Users\zitwa\Source\Repos\DynamicFontGenerator\DynamicFontGenerator\Generator.cs:line 51
       at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
       at DynamicFontGenerator.Generator.Main() in C:\Users\zitwa\Source\Repos\DynamicFontGenerator\DynamicFontGenerator\Generator.cs:line 22
     
  9. mistzzt

    mistzzt Terrarian

    Strange.
    I've tried compile a font using v0.5, and it worked; no idea why it became this.
    Now, I changed some code trying to fix the exception you encountered; if you have time, please try version 0.6.
     
  10. Rhoenicx

    Rhoenicx Terrarian

    Confirmed working! I have XNA installed btw; thanks for the tool! :D (can't seem to find out how to do it with visual studio...)
     
  11. altermaven

    altermaven Steampunker

    Thank you for this wonderful tool. Now I can no longer pull out my precious hair :dryadsmile:
     
  12. SxR

    SxR Official Terrarian

    It can't find the font family even though I got it installed, I even put the font files into the directory but it still crashed, any ideas how to fix this?