• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

**REPORTED** Fonts are broken on Ubuntu

Dedoctor

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Both
Operating System
Linux Other
Terraria Version
1.4.0.3
Controls Used
Keyboard/Mouse
Every font in game, apart from the main menu ones, is broken. I can not make sense of the character creation screen/world gen/items in inventory.

I have ubuntu 20.04, and the problem is not present in any other applications.

I do not know which version of Terraria I am playing, because I can not read it ;p

After deleting and redownloading file called Item_Stack.xnb problem persists.

Thanks in advance for the help.
 

Attachments

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Terraria currently does not fully support Mac/Linux. It works on most OS versions of them, but some have particular issues.

I'll log this for investigation, but we aren't able to fix Mac/Linux issues right now, so it may be some time before it is resolved.
 

giffyfish

Terrarian
This isn't an isolated issue for "some" Linux distrobutions. This exact issue has persisted across multiple mainstream Linux distrobutions I've tried to play this game on, including Ubuntu LTS 20.04, Linux Mint Tricia, and most recently, Fedora 32, with open source and proprietary AMD drivers, and after installing the Andy Bold font for Linux that Terraria apparently uses.

The availability for Linux on steam vs the stance taken here in regards to Linux support is quite conflicting, and the fact that it remains available for Linux on steam despite being stuck in a completely unplayable state across seemingly all up to date Linux distrobutions blows my mind.

I've reached out to steam support (hilariously enough, considering Terraria "doesn't support Linux") as a final resort to solving this unfortunate issue before requesting a refund; which is deeply frustrating, as I genuinely wanted to enjoy this game, but was mislead by the supposed Linux compatibility.
 

Dedoctor

Terrarian
I have found that downgrading my ubuntu to 18.04 solved the issue. I can now play terraria as well as Don't Starve. I agree though, this seems to be some kind issue with AMD graphics and linuxes based on ubuntu 20.04.
 

Mutisk

Terrarian
Hm, I do not have any font issues on Fedora32 using the GOG version. AMD radeon 5700xt mesa/DRI opensource drivers.

Does it go away if you set the environment variable LIBGL_ALWAYS_SOFTWARE=true
It'll be unplayable slow, but might help us understand whether it's a driver issue or something else.
 
Top Bottom