• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Journey's End on Xbox and PlayStation!: Get all the info by clicking here. Click here for Known Issues and FAQ. For any other bugs, report them (with as much detail as possible) here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

Linux Game sometimes can't startup

Volkov

Terrarian
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Linux Other
Terraria Version
1.4.3
Controls Used
Controller (please specify type)
Around 2 weeks ago, i fully switched my laptop and desktop PC from Windows 10 to Pop_OS! 21.04 (specs inside attached file)
Fresh install and 1st run of game on both laptop and desktop was fine, game worked as intended
But after that, game seems to work from time to time
Sometimes i run it and it works fine, but sometimes game starts, and nothing happens
With htop i found 2 terraria processes: "Main Thread" and "Terraria"
If game *fails" to run, "Main Thread" takes around 48mb of ram and 0 of cpu and have "sleeping" status
So the only way to stop game here is to send kill signal to it
It happens on both desktop and laptop (but, looks like game "have" more "chances" to run on desktop, because on it it runs like 7/10 time, but on laptop it happens like 2/10 times, i don't really know why)
So i start digging around and via terminal run shell script "Terraria" in terraria folder to see if game produce output
And it give me some (attached to file)
But unusally it looks like that:
Code:
Error Logging Enabled.
Controller 0: XInput Controller
Setting breakpad minidump AppID = 105600
malloc(): invalid size (unsorted)

=================================================================
    Native Crash Reporting
=================================================================
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================
So looks like problem in mono itself rather in Terraria itself

Additionally, i tried to run Windows version game via Proton on both laptop and desktop and it works fine in terms of ability to start, but it have some gamepad and performance issues (especially on laptop) so i can't use it
It's kinda fun to play in Russian Roulette "If Game Will Work In That Time?" and i can deal with that, but it's just annoying
 

Attachments

  • specs_and_crash_dumps.zip
    17.4 KB · Views: 6
Top Bottom