• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

PC How to (legally) play old versions of Terraria (even up to 1.0.0)

Captain__Crazeh

Official Terrarian
Well you need depo downloader or old steam both will work
Come to think of it, I would rather try restore the old classic textures by using a texture pack (if I can find any).

But still, I wish that Re-Logic would give access to older versions of the game, just like how you can download previous/experimental versions of Minecraft Java (using the launcher). A Terraria launcher would be amazing...
 

tModder147

Official Terrarian
Screenshot (17).png
 

SkyanUltra

Terrarian
Steam broke something in Steam which is why it says manifest not available. You have to use another tool for it to work now: DepotDownloader

To use it, you need to edit the bat file provided in the repository like so:


Code:
@echo off
dotnet %~dp0DepotDownloader.dll %* -username usernameHere -password passwordHere -app 105600 -depot 105601 -manifest 1270558334791485575

If you use Steam Guard, it will likely ask for an auth code from your email. You can enter that in when it asks for it.
I've tried it and it all works fine at first, but its still in 1.4.0.5. Any help you can provide?
 

Lachlan 55

Terrarian
Steam broke something in Steam which is why it says manifest not available. You have to use another tool for it to work now: DepotDownloader

To use it, you need to edit the bat file provided in the repository like so:


Code:
@echo off
dotnet %~dp0DepotDownloader.dll %* -username usernameHere -password passwordHere -app 105600 -depot 105601 -manifest 1270558334791485575

If you use Steam Guard, it will likely ask for an auth code from your email. You can enter that in when it asks for it.

can you elaborate on this please?
 
Top Bottom