1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice
  2. For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.
    Dismiss Notice
  3. TCF will be undergoing a scheduled software and server upgrade on September 26, 2019 beginning at 9:00AM GMT. TCF may be unavailable for an extended period after this time. More information can be found here. We apologize in advance for any inconvenience this may cause, we will try to keep the downtime short.

Xbox One Last Prism mechanic glitch?

Discussion in 'Console Bug Reports' started by Billy Yeomans, Apr 4, 2019.

?

Are you able to recreate this?

  1. Yes

    100.0%
  2. No

    0 vote(s)
    0.0%
  1. Billy Yeomans

    Billy Yeomans Terrarian

    So I was using my last prism on the floor, like you do, then using the upper key on the dpad (with dpad hotbar enabled) to equip my rod of discord. This caused the still in use last prism to turn its aim upward and have infinite duration with no mana usage, but appeared to do no damage to enemies (that was only my solar armour). Tried to make this a clear as possible, might not have explained it too well.

    Edit: I’ve tried this again with other items (specifically a Money Trough and an Uzi) however it just causes the beam to have infinite duration and no damage, but does not snap upwards. Tried to attach video but lacked permissions rip.
     
  2. Unit One

    Unit One Moderator Staff Member Moderator

    That sounds like an interesting glitch you've found there @Billy Yeomans. Yesterday you weren't able to attach a video, but today you should be able to (we updated the forum software since yesterday which fixes the uploading error).

    Also, I suggest you send in this bug information straight to Pipeworks (the console developers) and include as much details as possible along with your video. You can send it here: Terraria: Console & Mobile Bug Form

    They probably won't be able to respond to you individually, but they do look over everything sent in using that form.
     
  3. Chaseblade

    Chaseblade Terrarian

    this glitch/bug is associated with the dpad hot bar, and operates similarly to the vortex beater glitch. if you switch to just about any weapon after mirror it will start to do damage (if it allows you to switch, this only works 50% of the time i try) as there was an attempt to patch out the vortex beater glitch, and was sucessful with alot of weapons, however not with post golem items. i think its due to the game having loaded so much to the point it has a hard time tracking all of the code compiled into the world, however i dont have access to console code/developer tools for console, so i wouldnt even know were to begin to fix this. please upload a video with more details, and im sure someone can point you in the right direction. Just started designing terraria mods, and have seen so many simple organization flaws, and long code that could be simplified. this could attibute to it aswell, in which case its not fixable untill Pipeworks issues a patch/cleaner code.