Linux dedicated server. Launches but get "killed" message

TwistedForHire

Terrarian
I'm testing running Terraria in Azure. I already have my server running fine in a Windows 10 VM. I'm wanting to see the cost of running inside a cheap Linux VM.

I'm following this great guide here that I've seen others on the forum reference:

Everything seems to run fine. The server executable launches but I get this:

sudo ./TerrariaServer.bin.x86_64 -config config.txt
Error Logging Enabled.
Killed

I've tried without sudo. I even tried running TerrariaServer.exe within mono. I get the same message: "Killed".

Does anyone have any idea what that means? Are there logs anywhere (I can't find any)?
 
I know this post was made awhile ago, but i wanted to say. Thanks! this actually helped with my issue on my Raspberry Pi Zero 2 W. Was able to get to the world creation menu.
 
This is often the case with low spec VM. The solution is to increase the available memory either by upgrading to a VM with more RAM or configuring additional swap space which allows the system to use disk storage as virtual memory.
 
Back
Top Bottom