tModLoader Magic Storage

Discussion in 'Works-in-Progress' started by blushiemagic, Apr 6, 2017.

  1. Masamika

    Masamika Terrarian

    In conclusion, this MOD is dangerous and is not it better not to use now?
     
  2. RadkovZ

    RadkovZ Terrarian

    I think, this is fine too, if you use less mods. Atleast for me works ok, but with much mods doesn't look good.
     
    Masamika likes this.
  3. PaumDQuejo

    PaumDQuejo Terrarian

    I have a problem, I saved the game when I finished playing, but when I went in now, my magic storage chests disappeared, I tried to enter with the last save, where the chests were still there ... but when I entered the chests there were also disappeared
     
  4. Jofairden

    Jofairden Golem

    It should be fine, just make sure to separate your storage hearts.
     
    Masamika likes this.
  5. Masamika

    Masamika Terrarian

    Set the storage capacity to 1200 or less,
    Insulate the storage heart with a connector,
    For now, it is working normally.
    I pray that no error will occur as it is. truly.
     

    Attached Files:

  6. Xyore

    Xyore Terrarian

    The only bug I've encountered so far is with Fargo. Apparently, once I have the Tinkerer's Workshop in the Crafting Interface, I can craft any of four essences (Melee, Magic, Range, Throwing) for free. I feel like this ruins a huge portion of the game when items can be crafted this easily. I'm still not 100% if this is Magic Storage, but I wanted to point it out.
     
  7. FoxyLover

    FoxyLover Official Terrarian

    Yeah I've noticed that too, but I suspect that's a bug with the Fargo mod itself.
     
  8. deadfong

    deadfong Plantera

    It's due to Thorium removing some items that were used for the essences. Supposed to be fixed with the next update?
     
  9. Tidgem

    Tidgem Skeletron Prime

    Okay so ive got a major bug, im guessing its due to conflicting mods but I just thought you should know so maybe it might be fixable.

    Whenever I rightclick on any of the storage things it gives me this: attached

    I know its kinda hard to read because of a dodgy RPG mod, but its readable nonetheless.

    Now I love this mod and refuse to play without it, so if you could even slightly help me I would appreciate that, even if all you can do is tell me which mod is fking with it.

    Also attached is the logs since it says to do that.

    Thanks, Dan.
     

    Attached Files:

  10. FoxyLover

    FoxyLover Official Terrarian

    Tried this. It still crashes.
     
  11. Jofairden

    Jofairden Golem

    Did you look at the client crashlog? It contains a bunch of errors from different mods, notably: CalamityMod and TerrariaOverhaul
    This is weird, because I see this error:
    Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Images\Misc\TileOutlines\Tiles_497". File not found. ---> System.IO.FileNotFoundException: Error loading "Content\Images\Misc\TileOutlines\Tiles_497.xnb". File not found.

    Somehow, the tile 497 failed to load its asset. This explains the above mods' errors, as those are coming from tile drawing methods.
    Did your OS lock you out of asset files or something?
     
  12. Tidgem

    Tidgem Skeletron Prime

    Ah.

    Yes see I have this massive issue where I keep getting randomly locked out of harddrives and some folders within, I dont know why either since its been my PC since the start.

    If you know how to globally unlock everything and make it all under my control I would GREATLY appreciate that.

    And I didnt check it because I didnt really know what it meant mostly sorry.

    Please help me haha :D
     
  13. Jofairden

    Jofairden Golem

    There is a take ownership script available for Windows, you could try it.
    Take ownership: https://www.howtogeek.com/howto/win...ership-to-explorer-right-click-menu-in-vista/
    It has saved me many times
     
  14. Tidgem

    Tidgem Skeletron Prime

    Holy crap man, this is an absolute lifesaver! I just downloaded the wee hack at the bottom AFTER trying it myself because it didnt work haha. But now it works and its so helpful! It worked instantly and perfectly thank you so much ^^
     
    Jofairden likes this.
  15. Anubis

    Anubis Terrarian

    Any chance you might add a trash all option? for those instances you realize your hoarding problem as you go to move your containers, but can't because they have items in them.
     
  16. Azuriae

    Azuriae Terrarian

    Same issue as the others on a Dedicated server (running with only Calamity.)
    Shows 0/0 and can't deposit items. Unfortunate :(
     
  17. The Epic Gamer

    The Epic Gamer Terrarian

    For some reason bullets crafted through the system have modifiers, although I've only seen unreal and deadly
    20181005140211_1.jpg
    Mods:
    Magic Storage 0.4.3.3
    Simple auto chests 1.0.1
    Enemy Affixes 1.0.4
    AlchemistNPC 7.4.1
    Boss Checklist 0.1.6.1
    WMITF 2.6
    Recipe Browser 0.7
    Wing Slot 1.6.2
    Even More Modifiers 0.1.2.2
    OmniSwing 2.1
    Mod Helpers 2.1.0.2
    Motion Blurs 1.2.1
    Yet Another Boss Health Bar 1.3.2
    Death Screen Countdown 0.15
    Wildlife Mod 0.9.10
    Bottomless Lava Bucket 1.1
    Fargo's Mutant Mod: Summons and Souls 0.16.2
    Cheat Sheet 0.4.3.1
    MaxStackPlus 3.2
    Crushed! 1.6.2
    DALib 1.1.1
    Dual Wielding 1.0
    imkSushi's Mod 4.3.1
    imkSushi's Mod - Old Recipes Enabler 1.0
    Silk Touch 0.7
    MechTransfer 1.6.1
    Friendly NPCs Don't Die 1.1
    Health and Mana From Bosses 1.1.2.1
    Infinity - Endless Items 18.1
    Luiafk 1.0.0.128
    Reduced Grinding 4.31
    WeaponOut 1.6.3
    Calamity Mod 1.3.4.1
    VeinMiner 1.3.0.5
    Auto Trash 0.3.1​
     
  18. MasterOfBacon

    MasterOfBacon Steampunker

  19. Twsted

    Twsted Terrarian

    Do I need only 1 shadow diamond in replacement of 3 regular diamonds ?
    or do I need the same amount of shadow diamonds as regular diamonds. ?
    its a bit confusing because I tried to craft the unit with a shadow diamond and nothing shows up to craft.
    I got all the materials needed but just replaced with 1 shadow diamond for the 3 diamonds.
     
  20. deadfong

    deadfong Plantera

    I believe 1 shadow diamond = 1 regular diamond.