tModLoader Recipe Browser

jopojelly

Retinazer
tModLoader
Hey Jopojelly I was just wondering (if its not to much trouble) if you could add the option to turn off the item check list along with the text that pops up every time you get a new item. Its a really cool feature but it can sometimes be annoying.

Thanks
I'm pretty sure the announce button on the item checklist mod does that.
 

Melly the WM

Official Terrarian
for some reason bestiary does not want to work in my favor. i click on the enemies but nothing happens. i go to see what items can drop from enemies but nothing happens. i've changed nothing in the recipe browser but i don't know what to do.

anyone know a solution to the problem?
 

Serity

Terrarian
Huh, that's a huge mod list. I'm pretty sure one of those mods is limiting loot, but I don't really want to download all those mods to try it out. If you can narrow it down to the mod that is preventing it from rebuilding correctly, I can look into it. Or maybe we can intersect your list with someone else who has the problem.
Getting this issue too; I uploaded my LootCache.json after deleting it and letting it rebuild over here [ https://pastebin.com/raw/DfD49TUY ] - when rebuilding it sat on "Terraria" for a long time then took about a quarter second for each of the rest of the mods. Like dedelac, the only things listed in mine are a few of the Calamity lore tidbits. I cross-referenced our mods list [ https://pastebin.com/raw/VWjaumD5 ] here, removing the differences (with version differences noted though I doubt it matters). If you remove the mods he said he still had when it was "working as intended" later, you get this list [ https://pastebin.com/raw/i4tDMN4A ].
 

KittyKitCatCat

Skeletron Prime
I use the recipe browser to balance recipes (i often forget what they are as well) while playtesting my mod. I often build and reload... The drops from enemies do not update. Not a big issue i can just check the code but that might be a problem.
 

jopojelly

Retinazer
tModLoader
I use the recipe browser to balance recipes (i often forget what they are as well) while playtesting my mod. I often build and reload... The drops from enemies do not update. Not a big issue i can just check the code but that might be a problem.
Well, this is by design. Unless you update the build.txt version, it won't waste load time recalculating drops. For modders, this means a little extra work, but maybe just make a bat file that deletes the lootcache.json file that you can quickly click on. (easier than changing build versions.)
 

imkSushi

Eater of Worlds
Well, this is by design. Unless you update the build.txt version, it won't waste load time recalculating drops. For modders, this means a little extra work, but maybe just make a bat file that deletes the lootcache.json file that you can quickly click on. (easier than changing build versions.)
Alternatively, you could make it so that there is a setting that enables/disables recalculating drop rates each time you reload.
 

KittyKitCatCat

Skeletron Prime
Well, this is by design. Unless you update the build.txt version, it won't waste load time recalculating drops. For modders, this means a little extra work, but maybe just make a bat file that deletes the lootcache.json file that you can quickly click on. (easier than changing build versions.)
Well yeah, makes sense acually. Now that i think about it id rather not have to wait it to redo all the drop caches.
 

64BTX

Official Terrarian
Is anyone else having an incredibly long time for rebuilding the loot cache? It's been sitting on Terraria for a while now so far.
 
Sorry for bad English.

I have a problem I can't see which enemies drop which items in blue bar on the right side.
Can anyone help me?
 

Attachments

  • qwe.png
    qwe.png
    258.5 KB · Views: 506

jopojelly

Retinazer
tModLoader
Sorry for bad English.

I have a problem I can't see which enemies drop which items in blue bar on the right side.
Can anyone help me?
If you ever have trouble with the loot, deleting "\Documents\My Games\Terraria\ModLoader\Mods\Cache\LootCache.json" and reloading so it builds again should help.
 

DontEatSocks

Spazmatism
Found A bad bug: I have many large content mods (I'd rather not get into detail, but i'm not using tremor) and i am playing with a friend and whenever i put a crimtane bar in the recipe browser, the game crashes after about 10 secounds. This happens both is single and multiplayer. Except when it happens in Multiplayer, I can no longer join my friends game and it gets stuck at "retrieving world information". Then when my friend leaves to re-host the server, it gets stuck at "retrieving world info" aswell. He can load it in singleplayer, but no longer host it. This happened 3 times, and we lost 3 world to it.

This is also around the time when we get Magic Storage's storage system up. So I will post this on that forum aswell.

https://imgur.com/a/xYRl9
 

jopojelly

Retinazer
tModLoader
Found A bad bug: I have many large content mods (I'd rather not get into detail, but i'm not using tremor) and i am playing with a friend and whenever i put a crimtane bar in the recipe browser, the game crashes after about 10 secounds. This happens both is single and multiplayer. Except when it happens in Multiplayer, I can no longer join my friends game and it gets stuck at "retrieving world information". Then when my friend leaves to re-host the server, it gets stuck at "retrieving world info" aswell. He can load it in singleplayer, but no longer host it. This happened 3 times, and we lost 3 world to it.

This is also around the time when we get Magic Storage's storage system up. So I will post this on that forum aswell.

https://imgur.com/a/xYRl9
Well, placing crimtane works for me, so you'll have to to do this:

5nGP6Qi.png
 
Top Bottom