1. For issues you find with the Console 1.3 release, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    A FAQ with notes and workarounds can be found HERE. Please check this first to see if this helps your issue.

tModLoader Recipe Browser

Discussion in 'Released' started by jopojelly, Sep 30, 2017.

  1. MrGatoKun

    MrGatoKun Terrarian

    Hi, I have a problem, I do not know how to activate the browser, how can someone help me with this problem? second if it does not work tell me I have to download it in the steam terraria so that the recipe browser mod works for me?
     
  2. jopojelly

    jopojelly Retinazer

    Set the hotkey in the keybindings menu, press the hotkey.

    Not sure what your 2nd question is asking.
     
  3. Tristam

    Tristam Terrarian

    Thanks for making a great mod. Signed up here to make a request, like most new people do.

    I was hoping you'd implement a hotkey to close your mod. There is one to open it, but then I have to hit the 'x' to close it. I'd prefer to be able to use a button for speed. Please, and thank you.
     
  4. novatitas

    novatitas Steampunker

    Hi i have a problem when i try to load the recipe browser with thorium it rebuilds loot cache forever when i used 0.5.2 it worked perfectly but ever since i updated it doesn't work so please help thank you.[​IMG]
     
  5. Sidetracked

    Sidetracked Official Terrarian

     
  6. Celestin6669

    Celestin6669 Steampunker

    I can't even get in menu to do that... is there a way to manually desable mod?
     
  7. jopojelly

    jopojelly Retinazer

    holding shift before it starts to load mods, you can skip loading mods.
     
  8. Celestin6669

    Celestin6669 Steampunker

    Now when you get in bestiary/item tab and close browser you cant move, even mouse doesnt do any.
    Pressing browser button don't work either...
    Changing the the browser popup button fix it.
     
  9. novatitas

    novatitas Steampunker

    thanks it worked
     
  10. Sidetracked

    Sidetracked Official Terrarian

    You can disable mods outside of the game by opening your "Documents" in your files, navigating to "My Games", "Terraria", "ModLoader", then "Mods". You can open "enabled.json" with a text editor and delete all lines with mods that that isn't the problem mod or Recipe Browser, then save it. The other mods should be disabled then. Load up the game and when it gets to the menu, enable all the other mods and reboot the game.
     
  11. jopojelly

    jopojelly Retinazer

    New update, finally all languages are supported.

    v0.6.1.1
    • Chinese - thanks 抗药又坚硬汉化组(SBMW GROUP)
    • Italian - thanks @Al Fahrel
    • German - thanks xxSephiroth
    • All 9 Terraria supported languages now complete, thanks everyone!
     
  12. Ayyno

    Ayyno Terrarian

    Hey there, looks like the latest update may have broken something or a conflict got worse? I'm trying to diagnose it so I figured I'd let you know to see if maybe it's something you knew about already.

    Looks like Recipe Browser is hanging trying to rebuild the loot cache for Terraria itself!

    upload_2018-3-14_9-25-40.png

    I followed the previous instructions of only loading Thorium and then adding the rest of the mods, didn't help. So I figured I'd add in the new mods I've wanted to start using (Fargo's) and try again. It does not rebuild cleanly with just Thorium, Overhaul (what I thought might be the culprit for vanilla Terraria causing the hang) and Fargo's so I'm not sure if the issue is exacerbated by mods being jerks to each other.

    I don't have much time in the mornings to test other mod combos but my solution is as follows:
    1. Load with Recipe Browser, Fargo's, and Shorter Respawn
    2. Add Thorium, load again
    3. Add rest of mods, load again
    4. Finally play!
    Hope this helps anyone else experiencing this issue getting a bit worse! :eek:
     
  13. Trippy

    Trippy Terrarian

    can somebody please help me? I recently downloaded a lot of mods and when im starting the game up it says Recipe Browser : Rebuilding loot cache. And it never changes, ive been waiting for hours!
     
  14. jopojelly

    jopojelly Retinazer

    Read the above post
     
  15. Khazsper

    Khazsper Terrarian

    None of the attempted methods to fix this issue are working for me. I've even tried reverting to every single version from v0.6.1.1 all the way to v0.5.2 but none seem to work anymore. When the mod is "Rebuilding Loot Cache" it gets stuck on either the Thorium Mod or vanilla Terraria every single time. The only option I've had is to either disable the Thorium mod or the Recipe Browser mod to fix it. Hopefully this gets fixed really soon, this mod made playing with multiple mod packs bearable since the wikis for most mods besides Thorium are completely outdated or unusable.

    I've tried reloading all my mods in different orders and everything, but nothing seems to get it to work. If anyone has any other workarounds I'd love to hear them.

    Thanks.
     
  16. jopojelly

    jopojelly Retinazer

    The issue I know of is with overhaul (they know a fix, might be soon), if it is happening with only Thorium and Recipe Browser enabled, let me know, that is something I'd need to look into. Thorium hasn't updated in over 2 months, so I doubt that.
     
  17. [SoF] Gatsu

    [SoF] Gatsu Terrarian

    As soon as I open the browser, terraria crashes and this screen. I do not understand the problem :(
     

    Attached Files:

  18. jopojelly

    jopojelly Retinazer

    If you can identify the minimum steps to reproduce this, I can look into it. (Like, new character, new world, only recipe browser and X mod enabled.)
     
  19. [SoF] Gatsu

    [SoF] Gatsu Terrarian

    Ok, the problem is with calamity mod :( :(
    I have this mods. Without calamity, recipe work
     

    Attached Files:

  20. jopojelly

    jopojelly Retinazer

    1.3.0.2 or 1.3.0.1?