Terraria 1.3.1 help


Hey everyone, with the new 1.3.1 update I tried to reinstall the game again only to be greeted with the Terraria stopped working with the following message:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: terraria.exe
Problem Signature 02:
Problem Signature 03: 5741a9c3
Problem Signature 04:Terraria
Problem Signature 05:
Problem Signature 06: 5741a9c3
Problem Signature 07:888
Problem Signature 08: 27
Problem Signature 09: System.BadImageFormatException
OS Version: 6.1.7601.
Locale ID: 1046
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Searching for similar problems made me find most of them concerning either reintalling .NET4 then XNA, which I did, yelding no results.
For more help my specifications are:
Processor: Intel core i5-5200U CPU @ 2.2Ghz
RAM : 8,00 GB
OS: Windows 7
If you need further information on anything, just ask.

I can provide screenshots of anything, but my laptop language is set to Portuguese.

Thanks in advance.


Well then, I did try to open it again to show the error but the game suddently started working.
I can't really explain what could've happened.

However, a new issue was the there's absolutely no sound, I went to the volume and tried to adjust it, but it keeps going back.
Here's a recording of what's happening (even if the other two parts of it show there's sound I can't even hear effects):

Top Bottom