• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

The game does not start

I am trying to fix the game more than 1 month ago but I still can not find a solution, I have done what everyone says (download all the xnaf) and in doing so it still does not work ...... My mistake is that when I start the game nothing happens, no error or anything. When I enter terrariaserver.exe it shows me this error:
Unhandled exception: System.BadImageFormatException: Unable to load the file or assembly 'Microsoft.Xna.Framework.dll' or one of its dependencies. it is not a valid Win32 application. (Exception from HRESULT: 0x800700C1)
in Terraria.Program.LaunchGame (String [] args, Boolean monoArgs)
in Terraria.WindowsLaunch.Main (String [] args) Thanks for Watching... :D
 

Grumpy Squid

Systems Administrator
Staff member
Administrator
Hello, let me get that cleared up for you.

Could you do the following for me?

  • Press Windows+R.
  • Type "winver" without the quotes and press enter.
  • screenshot the Window that comes up for me.
 
upload_2019-1-20_0-11-50.png
This
 

Grumpy Squid

Systems Administrator
Staff member
Administrator
I'm giving you all the DLL's that may be the source of the problem, I can't give you any of the System DLL's since they are protected and you wouldn't be able to replace them anyway. We're going to manually replace each and every one that we can though. Read carefully and do not get any of these mixed up, your hexcode for the file path for the framwork dll may be different, browse to the folders through the file explorer, it will be the only subfolder. Do not paste any file paths. Yes the 32 bit files go in SysWow64 and the 64 bit files go in System32. No, I did not get them mixed up. Yes it's weird, long story on why that is.

Microsoft.XNA.Framework.dll goes in C:\Windows\Microsoft.NET\assembly\GAC_32\Microsoft.Xna.Framework\v4.0_4.0.0.0__842cf8be1de50553

32 Bit MSVCR100.dll goes in C:\Windows\SysWOW64

64 Bit MSVCR100.dll goes in C:\Windows\System32

32 Bit MSVCP100.dll goes in C:\Windows\SysWOW64

64 Bit MSVCP100.dll goes in C:\Windows\System32

32 Bit X3DAudio_7.dll goes in C:\Windows\SysWOW64

64 Bit X3DAudio_7.dll goes in C:\Windows\System32

If it doesn't work, first double check to make sure you put the proper versions in their proper places. Watch those P's and R's and the 32's and 64's.

Link to DLL Files.
 
Last edited:

Grumpy Squid

Systems Administrator
Staff member
Administrator
It should, but let me know if it doesn't and we can verify a few things. I can't stress enough though that it will only work if you get the right dll's in the right folder so read carefully take it slow and don't rush.

Edit: You will need to restart your machine after making the switch.
 

Grumpy Squid

Systems Administrator
Staff member
Administrator
If replacing the DLL's result in the same error for you in means the dependency that is the issue is most likely a Windows one, which is something we can't simply replace. Because you are on the latest version of Windows it also means we can't use Windows Update to attempt to fix the issue. You are most likely going to have to reinstall Windows to fix the issue.

Is the error still the same when using TerrariaServer.exe? Could you screenshot it for me?
 

Grumpy Squid

Systems Administrator
Staff member
Administrator
Which means we solved the original error, but you're saying that when you try to launch the application it still closes? Correct?

Let's enable logging to see what the new issue is. Follow the guide below:

0eiPNMV.png
 
Last edited:

Grumpy Squid

Systems Administrator
Staff member
Administrator
Once you have enabled logging you need to attempt to launch the game and then when it fails upload the log file so I can read it.
 
Top Bottom