• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

TML GOG Patch for 1.3.5.3/0.10.1.5

gamax92

Terrarian
It seemed a little weird for GOG owners to not be able to use mods on the newest version despite how little changes needed to be made.
So I made a new patch. Have played with it for several hours now and didn't run into any issue.

Only made a Windows patch for now, tML 0.10.1.5 for Linux and macOS is in a bad shape and it's best to wait for tML 0.11 to release.
Download the TML GOG Patcher, click the Patch Tools icon, Download Patch, and enter the .dat url
Then you should be able to install normally.

You can also manually download the patch into:
Code:
%UserProfile%\Documents\My Games\Terraria\TMLGOGPatcher\Patches
Windows:
32bit: https://gamax92.keybase.pub/TMLGOGPatch_0.10.1.5_Windows.dat
64bit: https://gamax92.keybase.pub/TMLGOGPatch_0.10.1.5.x64_Windows.dat
 
Last edited:

kowalskiy

Terrarian
It seemed a little weird for GOG owners to not be able to use mods on the newest version despite how little changes needed to be made.
So I made a new patch. Have played with it for several hours now and didn't run into any issue.

Only made a Windows patch for now, macOS and Linux can be looked into as well if necessary.
Download the TML GOG Patcher, click the Patch Tools icon, Download Patch, and enter the .dat url
Then you should be able to install normally.

You can also manually download the patch into:
Code:
%UserProfile%\Documents\My Games\Terraria\TMLGOGPatcher\Patches
32bit: https://gamax92.keybase.pub/TMLGOGPatch_0.10.1.5_Windows.dat
64bit: https://gamax92.keybase.pub/TMLGOGPatch_0.10.1.5.x64_Windows.dat
I'm sorry if it was something obvious but, does it work for tmodloader 64 bit? I mean, every time i try with it it gives error and stops intallation.
If it is not meant to work with it, could it be possible to patch it so it works?

thanks in advance

Edit: forget i said anything, it works! for some reason it kept saying my game was 1.3.5.1 and wouldnt patch it, but in one of the reinstallations, everything went smoothly.

Thanks a lot for this!
 
Last edited:

gamax92

Terrarian
tModLoader has the game version set to 1.3.5.1 for some reason, so it "downgrading" is expected, it's still actually 1.3.5.3
I won't be making a Linux and macOS patch, it seems that tML 0.10.1.5 tends to black screen and lockup on launch which is fixed in the beta builds of tML
 
Last edited:

Airarret

Terrarian
Thanks for doing that, hopefully you'll be able to make a patch for Terraria 1.3.6 once it's eventually released.
 

Dr Jones

Terrarian
Thanks for making this! I was seriously gonna re-buy the game because of the patches being outdated.
 

islender123

Plantera
Hey, awesome work! Now I can play with my friend who owns the GOG version instead of the Steam version. Just saying, 0.11 is out now, so if you have the time it would be awesome if you worked towards a patch for it cause 0.11 is much much better than 0.10.x.x. :D
 

jopojelly

Retinazer
Hey, awesome work! Now I can play with my friend who owns the GOG version instead of the Steam version. Just saying, 0.11 is out now, so if you have the time it would be awesome if you worked towards a patch for it cause 0.11 is much much better than 0.10.x.x. :D
0.11 supports gog natively, no need for anyone to make patches.
 
Top Bottom