• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Very big problem... Need help :/

.-.

Terrarian
I own Terraria for pc and every world I make ends up not being able to load. I haven't downloaded any mods or stuff like that and my PC is fairly new so I doubt it can be a virus or anything like that. I deleted the worlds that wouldn't load and I'm afraid that it will happen to my new main as I have put a lot of work into it. I will appreciate any help.:sigh:
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Please take a screenshot of your world list menu, if don't mind?

You will also need to provide your PC specs, and you should take a look at this page and read it: http://forums.terraria.org/index.php?threads/section-guidelines-please-read-before-posting-here.78/

More details are useful, this is an extremely limited amount of detail for diagnosing the issue. Did you have crashes before these worlds were corrupted? Did you stop playing Terraria between the time they became corrupted? Everything you can share helps.
 

.-.

Terrarian
OK so my pc has 4.00 gigs of RAM and yes I stopped playing between the time I played. I didn't upload to worlds to the cloud and both of the worlds were normal mode. I made a basic house with 7 rooms on two of my worlds because it stopped loading the first time. The first time it crashed the day after the world was created and the second time it happened that day when I stopped playing and decided to play later. My pc is windows 10 and is an ASUS Laptop. The worlds didn't crash at all but when I tried to play again it said failed to load and gave me a choice to try the backup but that failed as well.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
OK so my pc has 4.00 gigs of RAM and yes I stopped playing between the time I played. I didn't upload to worlds to the cloud and both of the worlds were normal mode. I made a basic house with 7 rooms on two of my worlds because it stopped loading the first time. The first time it crashed the day after the world was created and the second time it happened that day when I stopped playing and decided to play later.
You are going to need to provide a bit more info than that. At the very least, what version of Windows are you using? Are you even using Windows?

Getting that screenshot of your world menu would also be useful. I will not be able to help you without enough information; solving these issues is rather difficult even with all of the relevant information.
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
For starters, the world labeled "HARD" does have Steam Cloud activated. Which is why we ask this, because a lot of people do this and don't realize it, and there are a lot of world corruption related issues with Steam Cloud right now.

So I would recommend ENSURING you are not using it first. Then make a manual backup of your saves, (keep them updated frequently) and then continue playing. If the issue continues with Steam Cloud definitely deactivated, we can look into it further.
 

.-.

Terrarian
Oh I forgot about that. Thanks and I will definitely keep you updated!
[DOUBLEPOST=1451431712,1451431177][/DOUBLEPOST]Ok how would I manually back them up
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Go to My Documents>My Games>Terraria>Worlds, and then keep a backup folder where you won't forget about it. Copy and paste the relevant worlds into that backup folder as often as you can remember (once a day should be good for the short term, since you are concerned about immediate crashes).
 

Marcus101RR

Master of Ravens
Wonder why Cloud Sync is so bad in Terraria? Hope the developers are paying attention to this issue and fixing it for 1.3.1. Or maybe this is a Steam issue...
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Wonder why Cloud Sync is so bad in Terraria? Hope the developers are paying attention to this issue and fixing it for 1.3.1. Or maybe this is a Steam issue...
From what I hear, it may be a bit of both. Its also difficult to replicate; a LOT of people have it, but a lot of people don't, and its mostly forum users who aren't beta testers. Its not a "all Steam cloud users encounter this" issue. They've managed to replicate some issues, and those are being looked into, but a lot of it may well be Steam side.

All we can do is continue to urge people NOT to use it at this time, and if you do, keep manual backups.
 
Last edited:

.-.

Terrarian
Maybe if it happens next time, I could send you the world and maybe you could check what is causing the problem(if I knew how :confused:)
 
Last edited:

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Well, if its corrupt, its unlikely I can figure out what is wrong with it, I'm not particularly well versed in that area. :(
 

.-.

Terrarian
Um it happened again now I really feel discouraged to play:(:confused:. It also says unknown world now instead of the name
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
Are you absolutely sure you did not set it to Cloud Saving?

Also, if you made a manual backup, you should be able to resume from the last time you updated it . . . I hope you did so?
 

.-.

Terrarian
I did but for some reason that messed up also. I tried loading that up but it crashed the whole game entirely every time I tried.
I also didn't put it on the cloud
It also doesn't say unknown world after I loaded the backup save but it still crashes
 

.-.

Terrarian
I was able to recover the last save file and that seemed to work! I just searched through the recycle bin and found it and it works fine. I did lose some previous data though and for some reason, I have some duplicated Items...
 

Leinfors

Quality Assurance
Staff member
Moderator
Re-Logic
At this point, I'm not sure what to say. If your clean backups, stored separately, are spontaneously corrupting on you, that wouldn't be anything Terraria is doing.

As for the save in the recycle bin, was that a save version you deleted? Or did you just find it there.
 
Top Bottom