**REPORTED** Game crashes on trying to load legacy world, potential bug?

KingofDergs2001

Skeletron
Your Terraria Device
OnePlus 7 Pro
Mobile Bug Priority
High
Mobile OS
Android 11, security update 2022-04-01
Been a while since I had to come here, but this time I come with an issue that has annoyed me quite a bit and made my old saves practically unrecoverable.
I have old worlds from the PC version of terraria, version 1.3.5.2 to be exact. I just bought the mobile version a couple hours ago and want to move a world or two that I spent a lot of time on from my old computer with a dying hard drive to my phone.Firstly, I checked to be sure the world wasn't corrupted. It plays perfectly fine and everything appears to be in order when I play it on my old version on my old PC. I transferred the .wld of the world I wanted to move to mobile into the proper folder for worlds. It shows up in the world selection menu and allows me to hit "play" but when it tries to load the world, the entire app crashes. Perhaps I am doing something wrong, or this is an actual bug.
 
Last edited:

Nescre

Duke Fishron
DR Studios
Thanks for the report - would I be able to test out the .wld file in question? Wanting to check whether or not the crash is reproducible on my end
 

KingofDergs2001

Skeletron
Thanks for the report - would I be able to test out the .wld file in question? Wanting to check whether or not the crash is reproducible on my end
My apologies for the belated reply, I didn't think anyone was going to respond so I didn't check for a while. But yes, I'll attach the world in question.
 

Attachments

  • The_Beginning..wld
    8.7 MB · Views: 11

KingofDergs2001

Skeletron
Thanks for the report - would I be able to test out the .wld file in question? Wanting to check whether or not the crash is reproducible on my end
UPDATE:
After updating the app, the crash is still occuring. So unfortunately it seems this bug is still an issue.
 

Nescre

Duke Fishron
DR Studios
I'm unable to load into this world without getting the following error - same applies when attempting to load it on PC. Could you try sending the world file from your PC again? I'm thinking this one might be corrupted
 

Attachments

  • 0E289FD0-BAE5-49C5-8814-3C508C06D152.png
    0E289FD0-BAE5-49C5-8814-3C508C06D152.png
    590.9 KB · Views: 11
Last edited:

KingofDergs2001

Skeletron
I'm unable to load into this world without getting the following error - same applies when attempting to load it on PC. Could you try sending the world file from your PC again? I'm thinking this one might be corrupted
Oh my, I'm so sorry! Weird, that file worked fine. Let's try this again lol, here's a fresh copy of the .wld
 

Attachments

  • The_Beginning..wld
    8.7 MB · Views: 8

Nescre

Duke Fishron
DR Studios
Oh my, I'm so sorry! Weird, that file worked fine. Let's try this again lol, here's a fresh copy of the .wld
This one's still erroring for me, sorry 😞

I think the issues you're experiencing here most likely stem from save corruption, as I know this loading error can be a common side-effect of that across all platforms. By chance, do you have any worlds under the same name with a ".wld.bak" or a ".wld.bak2" file extension?
 
Top Bottom