1. Encountering issues with the Localization/Translations with 1.3.5? Please report them via the section linked below so that we can account for all of them and have them addressed. Thanks! Localization Bugs & Issues Section
  2. We have hub threads for known bugs/issues and statuses of fixes for Mobile, 3DS, and Console platforms (UPDATED):
    Click here for Mobile
    Click here for 3DS
    Click here for PS3/PS4/PS Vita/XBox 360/XBox One

Mobile Local Multiplayer won't join, stops after 1/3 progress

Discussion in 'Mobile Technical Support' started by defiantworkshop, Apr 13, 2016.

  1. defiantworkshop

    defiantworkshop Terrarian

    Any tips? I have two ipad 2s, both with latest ios, both with latest version of the game (11964 as of this writing). I can load Terraria up on both ipads, have one start a game, and the other try to join. I can ALWAYS successfully see the other game over the wifi connection. However, when I tap "Join" the progress bar slowly creeps up, stalls at about 33%, sits there idle for about a minute or two, then gives a failed error message. Works both way, with both ipads. There has to be some routing issue with the home network, b/c both can successfully join at a different location. I have typical ports forwarded on my router (Rt-66n) for gaming, though I understand 7777 is the one for Terraria servers, but I'm not sure that's applicable here. My router will only allow port forwarding from one IP address, which basically means if 7777 is the port I need, I can still only do it from one of the ipads, b/c if I add 7777 a second time from a different IP, my router rejects it. I'm still not 100% convinced that's the issue. Its apparent that the issue is somehow over the home network, but I can't figure out exactly what special setting this game needs to allow that traffic to pass.

    505 support tells me they've never heard of the issue, but I've seen a few other threads with similar problems, and no solutions. I've done it over VPN, and it takes some working, but works about 2/3 of the time, but takes a lot of time and patience to set up for something that should be easy. Anyone have any solutions I can try? I'm pretty tech savvy, so assume I've turned everything off and on again and done fairly simple troubleshooting steps.
     
    Last edited: Apr 13, 2016
  2. Unit One

    Unit One Moderator Staff Member Moderator

    It sounds like you've got everything in line. I'm not sure that I've got any tips since you've done everything that is normally missed.

    Normally people aren't on the same version, or they aren't on the same wifi. But that's not the case for you especially since you can actually see the game to join.

    The port forwarding is just for the PC multiplayer version. I'm not sure if having that in place would affect the mobile multiplayer version trying to load up or not. It does sound like it is a problem with your home network since it will work at different locations.

    I did just try to have my own two iOS devices - that are both on the current version - load up together in the same world in multiplayer and it worked flawlessly.

    Sorry I don't have anything for you to try, but wanted to let you know it sounds like you've got all the normal things settled. I hope that 505 is still trying to troubleshoot with you and didn't close the ticket. Good luck.
     
  3. defiantworkshop

    defiantworkshop Terrarian

    No, 505 just said they'd never heard of it and bailed, actually. They were kind enough to offer me a PS3 code for the game. But this is for my kids (8 and 6) who are both in Hard Mode (for what little I know of the actual game) and probably won't want to ditch their characters and worlds.

    So my home network is set up for quick and constant access...I do networking/pc break/fix for a living. So while I'm not a CCIE or anything, I know what I'm doing. The lack of customization options, especially on mobile, is maddening. They're able to connect at school (wife is a teacher so they play while she does paperwork), which is a MORE restrictive network. I'm just out of things to try. For some reason, just inside my four mortgaged walls, it doesn't work, and I spend a lot of my time getting them set up, troubleshooting local multplayer, then doing a lot of resets and such to get VPN to work when local inevitably fails. It stresses them out (my 8 yo is on the spectrum and when things don't work, I usually have an uphill battle the rest of the day b/c his mood changes so much), so I just want them to be able to work on this themselves without getting frustrated.

    I'm hesitant to delete the game for fear of killing off worlds and characters, but I'm to the point that might be the next step. 505 just shrugged and said they dunno and bailed. Port fwding isn't the option, and the game sees itself...there' just SOMETHING missing or not configured right that I just can't see. This happened before the most recent upgrade, so I don't imagine its a version flaw. Maybe multiplayer is that spotty and they're just rolling the dice at the wrong times sometimes?

    Unit One, thanks for your reply! Hopefully eventually there can be a concrete answer to fix this.
    --- Double Post Merged, Apr 14, 2016, Original Post Date: Apr 14, 2016 ---
    This was 505's final word on the matter:

    If there were any options, we definitely would have forwarded them over to you now but there are none that we're aware of whatsoever. It's a bizarre issue and it really doesn't help that there are such a wide varieties of setups and devices so it's hard to pinpoint the cause since it's so inconsistent -- even in this case with it working elsewhere but not on your home setup.
     
  4. Unit One

    Unit One Moderator Staff Member Moderator

    Ahh sorry to hear that. It's tough when it involves the kiddos. I'm not well versed enough in networking to know if this is even possible to do, but what if you had an old unused router laying around and you hooked it up with just vanilla settings, and just the two iOS devices were connected to it.
     
    panckage likes this.
  5. panckage

    panckage Terrarian

    I agree with Unit One about trying a different router. I've had strange problems with tablets on certain routers.

    Also if you do uninstall you can use helium backup to save your kids save games beforehand in order to prevent them from disowning you ;)
     
    Unit One likes this.
  6. defiantworkshop

    defiantworkshop Terrarian

    Thanks everyone. I have considered upgrading the infrastructure, router included, though I'm sure my wife would disown me for buy more expensive gear....

    All that being said, this weekend I sat down with them b/c they couldn't get VPN working. After multiple restarts/app closures/etc VPN still wouldn't work. They decided to just try joining locally, and voila....it worked all weekend. I have no clue at this point. Maybe even something on 505's end? No clue....seems like it wouldn't have to touch the outside world to join locally, but lo and behold it worked fine every time they tried to connect. I think that just makes me scratch my head even more at the issue....I'd almost rather it not work outright.
     
    panckage and diekonradish like this.
  7. Unit One

    Unit One Moderator Staff Member Moderator

    Ooh really great news. *fingers crossed* that it continues to work.
     
  8. firethorne

    firethorne Terrarian

    Yep, sounds exactly like what I have too. The iPad can see the other's game, but it won't connect, stalling about a third of the way through.

    I'm having a hard time believing this is purely a nework issue, as I was able to also test with an android phone on the same network, and it joins the iPads and they join it just fine. It is only iPad to iPad that is broken.
     
  9. Cloud551

    Cloud551 Skeletron Prime

    i replied in another thread but this one hmm. it could be a connection problem. or a loading game problem. (OP sounds more like a connection problem. idk if you mentioned firewalls? certain permissions for gaming could be locked either on your devices(since theyre kids and might have a safety mode on) or internet.
    i use a vpn app.(multiterraria-it is a pain, but i can connect to anywhere other people have the app) anyways. ive learned that something doesnt load properly and causes the game to crash sometimes and only certain games. a quick fix COULD(not guaranteed) be opening a tutorial world and exiting back to the main menu before joining a friends world. otherwise with time it will fix (and break) itself. its just a mystery.
     
  10. firethorne

    firethorne Terrarian

  11. CaptainNapkinz

    CaptainNapkinz Terrarian

    I don't think this is a "router" issue. It used to work on my phone and my son's phone (linking on the same network). Now there is some "compatibility issue" b/c he can play with another friend when he comes to the house via Iphone but our phones will no longer connect. I have uninstalled/reinstalled Terraria and that doesn't seem to help. I wish someone could give me advice as to how to fix it. I have the same issue, loads 1/3 of the way and then says "connectivity is lost." Very frustrating that no one has an answer.
     
  12. Unit One

    Unit One Moderator Staff Member Moderator

    On a similar thread there was this solution that was brought up. It worked for one person, but I haven't heard that anyone else has tried it. Might be worth a try for you.
     
    Cloud551 likes this.