Resolved [Mobile] I screwed up?

whoisthis

Terrarian
9DEC798E-D2D8-464B-BDDA-C50415CF4141.png
Something’s wrong with my main world and I would rather not lose it forever. I think I messed with a file somehow because I was trying to download a PDF the other day and I found that I could look through all my files for once, including my Terraria ones. It says the world was created on 10/30 but I made it the same day as the 1.3 update. I’m not sure what I screwed up but I definitely screwed something and unscrewing instructions would be much appreciated.
 
View attachment 229288Something’s wrong with my main world and I would rather not lose it forever. I think I messed with a file somehow because I was trying to download a PDF the other day and I found that I could look through all my files for once, including my Terraria ones. It says the world was created on 10/30 but I made it the same day as the 1.3 update. I’m not sure what I screwed up but I definitely screwed something and unscrewing instructions would be much appreciated.
Hi there @whoisthis, welcome to the forums. :)

Unfortunately, worlds that are in red may be incompatible and will no longer work. Unless you have a copy of the world before it turned red, there may not be any fix.

Here's info from the Sep 9 update Terraria Mobile 1.3 Post-Launch Hotfixes Build Notes
"Worlds will now be indicated in red if they are not compatible with the current version of Mobile Terraria. We do not recommend using worlds made in a non-1.3.0.7 compatible version, nor should you attempt to utilize worlds altered in any way - as even the slightest changes/modifications can cause unexpected issues"

I highly recommend making frequent backups of your characters and worlds so that if anything happens to them you can restore from your backup. Here is info on that:
Mobile - Terraria Mobile 1.3 Local File Structure, Explained
Mobile - Terraria Mobile 1.3 Backup/Restore Instructions for Android
Mobile - Terraria Mobile 1.3 Backup/Restore Instructions for iOS
 
It’s a post-update world, but I guess there isn’t really anything I can do now. Oh well, it be like that sometimes :sigh:
I’m still happy that someone took the time to respond even if it was to tell me there’s nothing I can do, so thanks for that.
 
Heya, while Unit One is 100% spot on, would you be able to upload the world anyway? We would be interested in having a look to see if we can identify what caused the issue. No promises as 99.9% of the times we cannot recover worlds of characters, it is mostly for debug purposes.
 
I think the forum is censoring the name because there’s an “explicit word”, but I hope that doesn’t affect the actual file.
 

Attachments

  • o_:red:.wld.bak
    2.8 MB · Views: 79
I've been able to load red worlds before. They turned white after the first load in my case. This was on PC though so it might not be any help.
 
I've noticed the file was reading on my end, as that is the backup file (.bak) I removed the .bak, I'm not sure how old a backup is but it should in theory work, could you have a try and let us know?
 

Attachments

  • o_:red:.wld
    2.8 MB · Views: 77
Back
Top Bottom